Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Applied Mitigation Bulletin

Identifying and Mitigating Exploitation of the Multiple Vulnerabilities in Cisco PIX and Cisco ASA

Advisory ID: cisco-amb-20080604-asa

http://tools.cisco.com/security/center/content/CiscoAppliedMitigationBulletin/cisco-amb-20080604-asa

Revision 1.1

For Public Release 2008 June 4 16:00  UTC (GMT)


Contents

Cisco Response
Device-Specific Mitigation and Identification
Additional Information
Revision History
Cisco Security Procedures
Related Information

Cisco Response

This Applied Mitigation Bulletin is a companion document to the PSIRT Security Advisory Multiple Vulnerabilities in Cisco PIX and Cisco ASA and provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

There are multiple vulnerabilities in Cisco PIX and Cisco ASA. These vulnerabilities are summarized in the following subsections:

Crafted TCP ACK Packet Vulnerability: This vulnerability can be exploited remotely without authentication and without user interaction. Successful exploitation of this vulnerability may cause the affected device to crash. Repeated attempts to exploit this vulnerability could result in a sustained denial of service (DoS) condition.

The attack vectors for exploitation are through packets using the following protocols and ports via either IPv4 or IPv6 transports:

  • Secure Shell (SSH) using TCP port 22
  • Telnet using TCP port 23
  • HTTP using TCP port 80
  • HTTPS using TCP port 443

This vulnerability has been assigned CVE identifier CVE-2008-2055.

Crafted Transport Layer Socket Packet Vulnerability: This vulnerability can be exploited remotely without authentication and without user interaction. Successful exploitation of this vulnerability may cause the affected device to crash. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition.

The attack vectors for exploitation are through packets using the following protocols and ports:

  • HTTPS using TCP port 443
  • Secure Skinny (SCCP) using TCP port 2443
  • Secure Session Initiation Protocol (SIP) using TCP port 5061

This vulnerability has been assigned CVE identifier CVE-2008-2056.

Instant Messenger Inspection Vulnerability: This vulnerability can be exploited remotely without authentication and without user interaction. Successful exploitation of this vulnerability may cause the affected device to crash. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through Instant Messaging packets using the multiple TCP ports; thus, no mitigation techniques will be discussed for this vulnerability. This vulnerability has been assigned CVE identifier CVE-2008-2057.

Vulnerability Scan Denial of Service: This vulnerability can be exploited remotely without authentication and without user interaction. Successful exploitation of this vulnerability may cause the affected device to crash. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through HTTPS packets using TCP port 443. This vulnerability has been assigned CVE identifier CVE-2008-2058.

Control-plane Access Control List Vulnerability: This vulnerability can be exploited remotely without authentication and without user interaction. Successful exploitation of this vulnerability may result in traffic being inadvertently permitted to the control plane. The attack vector for exploitation is through IP packets that are destined to the addresses of the affected device. This vulnerability has been assigned CVE identifier CVE-2008-2058.

Note: Although the mitigation examples below specifically address potential exploitation of the crafted TCP ACK packet, crafted TLS packet, and vulnerability scan DoS vulnerabilities, they do not necessarily mitigate exploitation of the control-plane access control list vulnerability. To address the control-plane access control list vulnerability, the trusted hosts and protocols included in the control-plane ACL must be included in each of the respective ACL examples in this document. This allows a device to serve as a "shielding device" that will protect vulnerable ASA devices that are located behind it.

Vulnerable, non-affected, and fixed software information is available in the PSIRT Security Advisory: http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20080604-asa.

Mitigation Technique Overview

Cisco devices provide several countermeasures for the crafted TCP ACK packet vulnerability, the crafted TLS packet vulnerability, the vulnerability scan denial of service vulnerability, and the control-plane ACL vulnerability. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using IPv4 and IPv6 infrastructure access control lists (iACLs). This protection mechanism filters and drops packets that are attempting to exploit the vulnerabilities that have a network attack vector.

Effective exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance, the Cisco PIX 500 Series Security Appliance, and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers using IPv4 and IPv6 transit access control lists (tACLs). This protection mechanism filters and drops packets that are attempting to exploit the vulnerabilities that have a network attack vector.

Cisco IOS NetFlow can provide visibility into network-based exploitation attempts using flow records.

Cisco IOS Software, Cisco ASA, Cisco PIX security appliances, and FWSM firewalls can provide visibility through syslog messages.

Effective use of Cisco Intrusion Prevention System (IPS) event actions provides visibility into and protection against attacks that attempt to exploit the Crafted TCP ACK Packet Vulnerability as discussed later in this document.

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of these vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

caution Caution: The effectiveness of any mitigation technique is dependent on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Cisco IOS Routers and Switches

Mitigation: Infrastructure Access Control Lists

To protect infrastructure devices and minimize the risk, impact, and effectiveness of direct infrastructure attacks, administrators are advised to deploy infrastructure access control lists (iACLs) to perform policy enforcement of traffic sent to infrastructure equipment. Administrators can construct an iACL by explicitly permitting only authorized traffic sent to infrastructure devices in accordance with existing security policies and configurations. For the maximum protection of infrastructure devices, deployed iACLs should be applied in the ingress direction on all interfaces to which an IP address has been configured. An iACL workaround cannot provide complete protection against the vulnerabilities that have a network attack vector when the attack comes from a trusted source address.

The iACL policy denies unauthorized SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, and HTTPS packets on TCP port 443 that are sent to affected devices. In the following example, 192.168.60.0/24 is the IP address space that is used by the affected devices, and the host at 192.168.100.1 is considered a trusted source that requires access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic. Whenever possible, infrastructure address space should be distinct from the address space used for user and services segments. Using this addressing methodology will assist with the construction and deployment of iACLs.

Additional information about tACLs is available in Protecting Your Core: Infrastructure Protection Access Control Lists..

To address the control-plane access control list vulnerability, the trusted hosts and protocols included in the control-plane ACL must be included in the iACL.

ip access-list extended Infrastructure-ACL-Policy
  
  !
  !-- When applicable, include explicit permit statements for trusted
  !-- sources that require access on the vulnerable ports
  !

  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq telnet
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq www
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 2443
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061
  
  !
  !-- The following vulnerability-specific access control entries
  !-- (ACEs) can aid in identification of attacks
  !

  deny tcp any 192.168.60.0 0.0.0.255 eq 22
  deny tcp any 192.168.60.0 0.0.0.255 eq telnet
  deny tcp any 192.168.60.0 0.0.0.255 eq www
  deny tcp any 192.168.60.0 0.0.0.255 eq 443
  deny tcp any 192.168.60.0 0.0.0.255 eq 2443
  deny tcp any 192.168.60.0 0.0.0.255 eq 5061
  
  !
  !-- Explicit deny ACE for traffic sent to addresses configured within
  !-- the infrastructure address space
  !

  deny ip any 192.168.60.0 0.0.0.255
  
  !
  !-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance
  !-- with existing security policies and configurations
  !


!-- Apply iACL to interfaces in the ingress direction

interface GigabitEthernet0/0
 ip access-group Infrastructure-ACL-Policy in

!

Note:  Filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration command no ip unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration command ip icmp rate-limit unreachable interval-in-ms.

Mitigation: IPv6 Infrastructure Access Control Lists

To protect infrastructure devices and minimize the risk, impact, and effectiveness of direct infrastructure attacks, administrators are advised to deploy infrastructure access control lists (iACLs) to perform policy enforcement of traffic sent to infrastructure equipment. Administrators can construct an iACL by explicitly permitting only authorized traffic sent to infrastructure devices in accordance with existing security policies and configurations. For the maximum protection of infrastructure devices, deployed iACLs should be applied in the ingress direction on all interfaces to which an IP address has been configured.

The IPv6 iACL policy denies SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, and HTTPS packets on TCP port 443 that are sent to affected devices. In the following example, 2001:DB8:1:128::/64 is the IPv6 address space that is used by the affected devices, and the host at 2001:DB8:1:100::1 is considered a trusted source that requires access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic. Whenever possible, infrastructure address space should be distinct from the address space used for user and services segment. Using this addressing methodology will assist with the construction and deployment of iACLs.

Additional information about iACLs is available in Protecting Your Core: Infrastructure Protection Access Control Lists.

To address the control-plane access control list vulnerability, the trusted hosts and protocols included in the IPv6 control-plane ACL must be included in the IPv6 iACL.

ipv6 access-list IPv6-Infrastructure-ACL-Policy
  
  !
  !-- When applicable, include explicit permit statements for trusted
  !-- sources that require access on the vulnerable ports
  !

  permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq 22
  permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq telnet
  permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq www
  permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq 443    
  
  !
  !-- The following vulnerability-specific access control entries
  !-- (ACEs) can aid in identification of attacks
  !

  deny tcp any 2001:DB8:1:128::/64 eq 22
  deny tcp any 2001:DB8:1:128::/64 eq telnet
  deny tcp any 2001:DB8:1:128::/64 eq www
  deny tcp any 2001:DB8:1:128::/64 eq 443 
  
  !
  !-- Permit other required traffic to the infrastructure address 
  !-- range and allow IPv6 Neighbor Discovery: Neighbor Solicitation and 
  !-- Neighbor Advertisement packets
  !

  permit icmp any any nd-ns 
  permit icmp any any nd-na 
  
  !
  !-- Explicit deny for all other IP traffic
  !

  deny ipv6 any 2001:db8:1:128::/64 
 
  !
  !-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance 
  !-- with existing security policies and configurations
  !
!-- Apply iACL to interfaces in the ingress direction

interface GigabitEthernet0/0
 ipv6 traffic-filter IPv6-Infrastructure-ACL-Policy in

! 

Note: Filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration command no ipv6 unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration command ipv6 icmp error-interval interval-in-ms [bucketsize].

Identification: Infrastructure Access Control Lists

After the administrator applies the iACL to an interface, the show ip access-lists command will identify the number of SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, HTTPS packets on TCP port 443, Secure SCCP on TCP port 2443, and Secure SIP on TCP port 5061 that have been filtered. Administrators should investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ip access-lists Infrastructure-ACL-Policy follows:

router#show ip access-lists Infrastructure-ACL-Policy
Extended IP access list Infrastructure-ACL-Policy
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22 (16 matches)
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq telnet
    30 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq www
    40 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443 (42 matches)
    50 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 2443
    60 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061
    70 deny tcp any 192.168.60.0 0.0.0.255 eq 22
    80 deny tcp any 192.168.60.0 0.0.0.255 eq telnet
    90 deny tcp any 192.168.60.0 0.0.0.255 eq www
    100 deny tcp any 192.168.60.0 0.0.0.255 eq 443
    110 deny tcp any 192.168.60.0 0.0.0.255 eq 2443
    120 deny tcp any 192.168.60.0 0.0.0.255 eq 5061
    130 deny ip any 192.168.60.0 0.0.0.255
router#

In the preceding example, access list Infrastructure-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 16 SSH packets on TCP port 22 for ACE line 10
  • 42 HTTPS packets on TCP port 443 for ACE line 40

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Applied Intelligence white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Applied Intelligence white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: IPv6 Infrastructure Access Control Lists

After the administrator applies the tACL to an interface, the show ipv6 access-lists command will identify the number of SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, HTTPS packets on TCP port 443, Secure SCCP on TCP port 2443, and Secure SIP on TCP port 5061 that have been filtered. Administrators should investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ipv6 access-lists IPv6-Infrastructure-ACL-Policy follows:

router#show ipv6 access-list IPv6-Infrastructure-ACL-Policy
IPv6 access list IPv6-Infrastructure-ACL-Policy
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq 22 (1240 matches) sequence 10
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq telnet sequence 20
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq www sequence 30
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:128::/64 eq 443 (740 matches) sequence 40
    deny tcp any 2001:DB8:1:128::/64 eq 22 sequence 50
    deny tcp any 2001:DB8:1:128::/64 eq telnet sequence 60
    deny tcp any 2001:DB8:1:128::/64 eq www sequence 70
    deny tcp any 2001:DB8:1:128::/64 eq 443 sequence 80
    permit icmp any any nd-ns sequence 90
    permit icmp any any nd-na sequence 100
    deny ipv6 any 2001:DB8:1:128::/64 sequence 110
router#

In the preceding example, access list IPv6-Infrastructure-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 1240 IPv6 SSH packets on TCP port 22 for ACE line 10
  • 740 IPv6 HTTPS packets on TCP port 443 for ACE line 40

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Applied Intelligence white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Applied Intelligence white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: Access List Logging

The log and log-input access control list (ACL) option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

caution Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

For Cisco IOS Software, the ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by ACL logging. The logging rate-limit rate-per-second [except loglevel] command limits the impact of log generation and transmission.

The CPU impact from ACL logging can be addressed in hardware on the Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging.

For additional information about the configuration and use of ACL logging, reference the Understanding Access Control List Logging Applied Intelligence white paper.

Cisco IOS NetFlow

Identification: Traffic Flow Identification Using NetFlow Records

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of traffic flows that may be attempts to exploit the vulnerabilities described in this document that have a network attack vector. Administrators are advised to investigate flows to determine whether they are attempts to exploit the vulnerabilities or whether they are legitimate traffic flows.

router#show ip cache flow

IP packet size distribution (148472485 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .394 .091 .016 .028 .022 .019 .004 .011 .001 .003 .002 .002 .006 .008

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .014 .002 .221 .070 .077 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  24 active, 65512 inactive, 7176841 added
  130916958 ager polls, 0 flow alloc failures
  Active flows timeout in 2 minutes
  Inactive flows timeout in 60 seconds
IP Sub Flow Cache, 336520 bytes
  0 active, 16384 inactive, 3108972 added, 3108972 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet       12401      0.0        31    45      0.1       9.8      30.7
TCP-FTP            727      0.0         9    58      0.0      25.6      21.0
TCP-FTPD           260      0.0      2380   493      0.1      15.2      20.6
TCP-WWW          66933      0.0        13   563      0.2       9.6      41.0
TCP-SMTP          1316      0.0         7   134      0.0       7.5       9.7
TCP-X                2      0.0         1    40      0.0       0.0      60.3
TCP-BGP           1686      0.0         3    43      0.0      13.9      60.6
TCP-NNTP             2      0.0         1    40      0.0       0.0      60.5
TCP-other      5305913      1.3        25   334     35.1       2.2       6.6
TCP-DNS          91715      0.0         5    72      0.1      39.4      42.8
TCP-NTP         430918      0.1         1    76      0.1       5.8      58.1
TCP-TFTP           360      0.0         1    81      0.0       0.6      59.1
TCP-Frag        301039      0.0         6   569      0.4       0.0      15.6
TCP-other       882238      0.2         8   388      1.8       7.7      21.7
ICMP             76254      0.0         3   120      0.0      19.3      55.1
IPv6INIP             8      0.0         5   104      0.0       0.3      60.6
GRE               4942      0.0        47    52      0.0     119.6       0.8
IP-other            72      0.0        13   156      0.0     102.7      11.0
Total:         7176786      1.8        20   338     38.4       3.8      13.3

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.8.4     Local         192.168.128.20  06 0E12 0017    18 
Gi0/0         192.168.14.132  Gi0/1         192.168.150.60  06 1A29 AE3D     1 
Gi0/0         192.168.14.132  Gi0/1         192.168.150.60  06 1A29 B8AE     1 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E9B 01BB    11
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E9A 01BB    21 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E99 01BB    10 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E98 01BB    67 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E0C 13C5     1 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E88 01BB     1
Gi0/0         192.168.26.80   Gi0/1         192.168.130.66  11 0035 10EE     1 
Gi0/0         192.168.26.81   Gi0/1         192.168.130.66  11 0035 10F7     1 
Gi0/0         192.168.26.80   Gi0/1         192.168.130.66  11 0035 10F1     1 
Gi0/0         192.168.26.120  Gi0/1         192.168.130.66  11 0035 10EF     1 
Gi0/0         192.168.26.120  Gi0/1         192.168.130.66  11 0035 10ED     1 
Gi0/0         192.168.26.120  Gi0/1         192.168.130.66  11 1001 0016     1 
Gi0/0         192.168.26.120  Gi0/1         192.168.130.66  11 1002 0017     1 
Gi0/0         192.168.26.120  Gi0/1         192.168.130.66  11 1003 0050     1 
Gi0/0         192.168.26.120  Gi0/1         192.168.130.66  11 1004 098B     1 
Gi0/0         192.168.26.81   Gi0/1         192.168.130.66  06 0035 10FA     4 
router#

In the preceding example, there are multiple flows for SSH packets on TCP port 22 (Hex value 0016), Telnet packets on TCP port 23 (Hex value 0017), HTTP packets on TCP port 80 (Hex value 0050), HTTPS packets on TCP port 443 (Hex value 01BB), Secure SCCP on TCP port 2443 (Hex value 098B), and Secure SIP on TCP port 5061 (Hex value 13C5). Administrators are advised to compare these flows to baseline utilization for SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, HTTPS packets on TCP port 443, Secure SCCP on TCP port 2443, and Secure SIP on TCP port 5061 and investigate the flows to determine whether they are sourced from untrusted hosts or networks.

To view only the traffic flows for HTTPS packets on SSH packets on TCP port 22 (Hex value 0016), Telnet packets on TCP port 23 (Hex value 0017), HTTP packets on TCP port 80 (Hex value 0050), HTTPS packets on TCP port 443 (Hex value 01BB), Secure SCCP on TCP port 2443 (Hex value 098B), and Secure SIP on TCP port 5061 (Hex value 13C5) use show ip cache flow | include SrcIf|_06_.*(0016|0017|0050|01BB|098B|13C5)_ to display the related TCP NetFlow records as shown here:

TCP Flows

router#show ip cache flow | include SrcIf|_06_.*(0016|0017|0050|01BB|098B|13C5)_
SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E9B 0016    11 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E9A 01BB    21 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E99 0017    10 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E98 01BB    67 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E9C 0050     1 
Gi0/0         192.168.100.1   Gi0/1         192.168.60.40   06 0E88 01BB     1 
router#

Note: For the control-plane ACL vulnerability, administrators should investigate flows for protocols and ports configured in the control-plane ACL that terminate on the IP address of vulnerable device. These flows can indicate attempts to exploit this vulnerability.

Identification: Traffic Flow Identification Using IPv6 NetFlow Records

Administrators can configure Cisco IOS IPv6 NetFlow on Cisco IOS routers and switches to aid in the identification of traffic flows that may be attempts to exploit the vulnerabilities described in this document. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

router#show ipv6 flow cache 
IP packet size distribution (50078919 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .990 .001 .008 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 475168 bytes
  8 active, 4088 inactive, 6160 added
  1092984 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes

  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33928 bytes
  16 active, 1008 inactive, 12320 added, 6160 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets 
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x06 0x1204 0x01BB 1464K
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x06 0x1100 0x0016 68
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x06 0x112B 0x0017 37
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x06 0x114A 0x0050 5
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x06 0x13B2 0x01BB 1464K   
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x3A 0x0000 0x8000 1191    
2001:DB...6A:5BA6 Gi0/0    2001:DB...134::3 Gi0/1    0x3A 0x0000 0x8000 1191    
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::4 Gi0/1    0x3A 0x0000 0x8000 1192    
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x150A 0x01BB 1597    
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::3 Gi0/1    0x3A 0x0000 0x8000 1192    
2001:DB...6A:5BA6 Gi0/0    2001:DB...146::3 Gi0/1    0x3A 0x0000 0x8000 1192    
2001:DB...6A:5BA6 Gi0/0    2001:DB...144::4 Gi0/1    0x3A 0x0000 0x8000 1193 

Note: To permit display of the full 128 bit IPv6 address, please use the terminal width 132 exec mode command.

In the preceding example, there are multiple IPv6 flows for SSH packets on TCP port 22 (Hex value 0016), Telnet packets on TCP port 23 (Hex value 0017), HTTP packets on TCP port 80 (Hex value 0050), and HTTPS packets on TCP port 443 (Hex value 01BB). The TCP packets in these flows may indicate an attempt to exploit the vulnerabilities described in this document. Administrators should compare these flows to baseline utilization for packets on SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, and HTTPS traffic sent on TCP port 443 and also investigate the flows to determine whether they are sourced from untrusted hosts or networks.

To view the traffic flows for SSH packets on TCP port 22 (Hex value 0016), Telnet packets on TCP port 23 (Hex value 0017), HTTP packets on TCP port 80 (Hex value 0050), and HTTPS packets on TCP port 443 (Hex value 01BB), the command show ip cache flow | include SrcAddress|_0x06_.*0x(0016|0017|0050|01BB) will display the related IPv6 NetFlow records as shown here:

IPv6 TCP Flows

router#show ipv6 cache flow | include SrcAddress|_0x06_.*0x(0016|0017|0050|01BB) 
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets 
2001:DB...06::220 Gi0/0    2001:DB...144::2 Gi0/1    0x06 0x17A1 0x0016 3853    
2001:DB...06::220 Gi0/0    2001:DB...144::2 Gi0/1    0x06 0x07E8 0x0050 4806    
2001:DB...06::230 Gi0/0    2001:DB...34::21 Gi0/1    0x06 0x1798 0x01BB 21    
2001:DB...06::230 Gi0/0    2001:DB...34::21 Gi0/1    0x06 0x16A2 0x01BB 357    
router#

Note:  For the control-plane ACL vulnerability, administrators should investigate flows for protocols and ports configured in the control-plane ACL that terminate on the IP address of vulnerable devices. These flows can indicate attempts to exploit this vulnerability.

Cisco ASA, PIX, and FWSM Firewalls

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities that have a network attack vector when the attack comes from a trusted source address.

The tACL policy denies unauthorized SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, HTTPS packets on TCP port 443, Secure SCCP on TCP port 2443, and Secure SIP on TCP port 5061 that are sent to affected devices. In the following example, 192.168.60.0/24 is the IP address space that is used by the affected devices, and the host at 192.168.100.1 is considered a trusted source that requires access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is available in Transit Access Control Lists: Filtering at Your Edge.

To address the control-plane access control list vulnerability, the trusted hosts and protocols included in the control-plane ACL must be included in the tACL.


!
!-- Include any explicit permit statements for trusted sources
!-- requiring access on the vulnerable ports
!


access-list Transit-ACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq ssh
access-list Transit-ACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq telnet
access-list Transit-ACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq www
access-list Transit-ACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq https
access-list Transit-ACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq 2443
access-list Transit-ACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq 5061  

!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!


access-list Transit-ACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq ssh
access-list Transit-ACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq telnet
access-list Transit-ACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq www
access-list Transit-ACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq https
access-list Transit-ACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 2443
access-list Transit-ACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 5061


!
!-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!


access-list Transit-ACL-Policy extended deny ip any any


!
!-- Apply tACL to interface(s) in the ingress direction
!


access-group Transit-ACL-Policy in interface outside


!

Mitigation: IPv6 Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities that have a network attack vector when the attack comes from a trusted source address.

The IPv6 tACL policy denies unauthorized SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, and HTTPS traffic sent on TCP port 443 that are sent to affected devices. In the following example, 2001:db8:1:128::/64 is the IPv6 address space that is used by the affected devices and the host at 2001:DB8:1:100::1 is considered a trusted source that requires access to the affected devices. To mitigate against exploits of these vulnerabilities, all IPv6 traffic on vulnerable ports that is addressed to the affected devices must be denied. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is available in Transit Access Control Lists: Filtering at Your Edge.

To address the control-plane access control list vulnerability, the trusted hosts and protocols included in the IPv6 control-plane ACL must be included in the IPv6 tACL.


!
!-- When applicable, include explicit permit statements for trusted
!-- sources that require access on the vulnerable protocol
!

ipv6 access-list IPv6-Transit-ACL-Policy permit tcp host 2001:DB8:1:100::1 2001:db8:1:128::/64 eq 22
ipv6 access-list IPv6-Transit-ACL-Policy permit tcp host 2001:DB8:1:100::1 2001:db8:1:128::/64 eq 23 
ipv6 access-list IPv6-Transit-ACL-Policy permit tcp host 2001:DB8:1:100::1 2001:db8:1:128::/64 eq www 
ipv6 access-list IPv6-Transit-ACL-Policy permit tcp host 2001:DB8:1:100::1 2001:db8:1:128::/64 eq 443 


!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!

ipv6 access-list IPv6-Transit-ACL-Policy deny tcp any 2001:db8:1:128::/64 eq 22
ipv6 access-list IPv6-Transit-ACL-Policy deny tcp any 2001:db8:1:128::/64 eq 23 
ipv6 access-list IPv6-Transit-ACL-Policy deny tcp any 2001:db8:1:128::/64 eq www 
ipv6 access-list IPv6-Transit-ACL-Policy deny tcp any 2001:db8:1:128::/64 eq 443 

!
!-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!

ipv6 access-list IPv6-Transit-ACL-Policy deny ip any any


!-- Apply tACL to interfaces in the ingress direction


access-group IPv6-Transit-ACL-Policy in interface outside

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the number of HTTPS packets on TCP port 443 that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show access-list Transit-ACL-Policy follows:

firewall#show access-list Transit-ACL-Policy
access-list Transit-ACL-Policy; 13 elements
access-list Transit-ACL-Policy line 1 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq ssh (hitcnt=0)  
access-list Transit-ACL-Policy line 2 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq telnet (hitcnt=0)  
access-list Transit-ACL-Policy line 3 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq www (hitcnt=0)  
access-list Transit-ACL-Policy line 4 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq https (hitcnt=0)  
access-list Transit-ACL-Policy line 5 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq 2443 (hitcnt=0)  
access-list Transit-ACL-Policy line 6 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq 5061 (hitcnt=0)  
access-list Transit-ACL-Policy line 7 extended deny tcp any 192.168.60.0 255.255.255.0 eq ssh (hitcnt=0)  
access-list Transit-ACL-Policy line 8 extended deny tcp any 192.168.60.0 255.255.255.0 eq telnet (hitcnt=0)  
access-list Transit-ACL-Policy line 9 extended deny tcp any 192.168.60.0 255.255.255.0 eq www (hitcnt=0)  
access-list Transit-ACL-Policy line 10 extended deny tcp any 192.168.60.0 255.255.255.0 eq https (hitcnt=51)
access-list Transit-ACL-Policy line 11 extended deny tcp any 192.168.60.0 255.255.255.0 eq 2443 (hitcnt=0)   
access-list Transit-ACL-Policy line 12 extended deny tcp any 192.168.60.0 255.255.255.0 eq 5061 (hitcnt=0)  
access-list Transit-ACL-Policy line 13 extended deny ip any any (hitcnt=0)   
firewall#

In the preceding example, access list Transit-ACL-Policy has dropped 51 HTTPS packets on TCP port 443 received from an untrusted host or network. In addition, syslog message 106023 can provide valuable information, which includes the source and destination IP address, the source and destination port numbers, and the IP protocol for the denied packet.

Identification: IPv6 Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show ipv6 access-list command to identify the number of SSH packets on TCP port 22, Telnet packets on TCP port 23, HTTP packets on TCP port 80, and HTTPS packets on TCP port 443 that have been filtered. Administrators should investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show access-list IPv6-Transit-ACL-Policy follows:

firewall#show ipv6 access-list IPv6-Transit-ACL-Policy
ipv6 access-list IPv6-Transit-ACL-Policy; 9 elements
ipv6 access-list IPv6-Transit-ACL-Policy line 1 permit tcp host 2001:db8:1:100::1 2001:db8:1:128::/64 eq ssh (hitcnt=0)  
ipv6 access-list IPv6-Transit-ACL-Policy line 2 permit tcp host 2001:db8:1:100::1 2001:db8:1:128::/64 eq telnet (hitcnt=0)  
ipv6 access-list IPv6-Transit-ACL-Policy line 3 permit tcp host 2001:db8:1:100::1 2001:db8:1:128::/64 eq www (hitcnt=0)  
ipv6 access-list IPv6-Transit-ACL-Policy line 4 permit tcp host 2001:db8:1:100::1 2001:db8:1:128::/64 eq https (hitcnt=0)  
ipv6 access-list IPv6-Transit-ACL-Policy line 5 deny tcp any 2001:db8:1:128::/64 eq ssh (hitcnt=160) 
ipv6 access-list IPv6-Transit-ACL-Policy line 6 deny tcp any 2001:db8:1:128::/64 eq telnet (hitcnt=0)  
ipv6 access-list IPv6-Transit-ACL-Policy line 7 deny tcp any 2001:db8:1:128::/64 eq www (hitcnt=0)  
ipv6 access-list IPv6-Transit-ACL-Policy line 8 deny tcp any 2001:db8:1:128::/64 eq https (hitcnt=71) 
ipv6 access-list IPv6-Transit-ACL-Policy line 9 deny ip any any (hitcnt=0)  
firewall#

In the preceding example, access list IPv6-Transit-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 160 IPv6 SSH packets on TCP port 22 for ACE line 5
  • 71 IPv6 HTTPS packets on TCP port 443. for ACE line 8

Identification: Firewall Access List Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an access control entry (ACE) that does not have the log keyword present. Additional information about this syslog message is available in Cisco Security Appliance System Log Message - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance or the Cisco PIX 500 Series Security Appliance is available in Configuring Logging on the Cisco Security Appliance. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is available in Configuring Monitoring and Logging on the Cisco FWSM.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate attempts to exploit the vulnerabilities described in this document that have a network attack vector. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is available in Using the Command Line Interface.

firewall#show logging | grep 106023
May 28 2008 19:25:52: %ASA-4-106023: Deny tcp src outside:192.168.93.163/57540 dst inside:192.168.60.112/443 by access-group "Transit-ACL-Policy"
May 28 2008 19:26:52: %ASA-4-106023: Deny tcp src outside:192.168.231.104/54464 dst inside:192.168.60.80/443 by access-group "Transit-ACL-Policy"
May 29 2008 23:44:52: %ASA-4-106023: Deny tcp src inside:2001:db8:1:130:217:a4ff:fe48:6f57/1629 dst outside:2001:db8:1:128::22/443 by access-group "IPv6-Transit-ACL-Policy" 
May 29 2008 23:44:53: %ASA-4-106023: Deny tcp src inside:2001:db8:1:130:217:a4ff:fe48:6f57/1629 dst outside:2001:db8:1:128::22/443 by access-group "IPv6-Transit-ACL-Policy" 
firewall#

In the preceding example, the messages logged for the tACL Transit-ACL-Policy show HTTPS packets for TCP port 443 sent to the address block assigned to the infrastructure devices.

Cisco Intrusion Prevention System

Mitigation: Cisco IPS Signature Event Actions

Administrators can use the Cisco Intrusion Prevention System (IPS) appliances and services modules to provide threat detection and help prevent IPv4 attempts to exploit the Crafted TCP ACK Packet Vulnerability described in this document. The IPv6 attack vector of this vulnerability is not currently addressed by the IPS. This vulnerability may be detected by the following signatures, both signatures require the IPS to be configured in in-line mode:

  • Signature 1306/0: TCP Option Other
  • Signature 1330/4: TCP Drop - Bad Option Length

Signature 1306/0: TCP Option Other

Beginning with signature update S272 for sensors running Cisco IPS version 6.x or 5.x, the Crafted TCP ACK Packet Vulnerability described in this document can be detected by signature 1306/0 (Signature Name: TCP Option Other). Signature 1306/0 operation requires the IPS to be configured in in-line mode and is enabled by default, triggers a Low severity event, has a signature fidelity rating (SFR) of 100, and is configured with a default event action of produce-alert. Signature 1306/0 fires when a single TCP packet is detected. Firing of this signature may indicate a potential exploit of the Crafted TCP ACK Packet Vulnerability described in this document.

Signature 1330/4: TCP Drop - Bad Option Length

Beginning with signature update S272 for sensors running Cisco IPS version 6.x or 5.x, the Crafted TCP ACK Packet Vulnerability described in this document can be detected by signature 1330/4 (Signature Name: TCP Drop - Bad Option Length). Signature 1330/4 is enabled by default, triggers an Informational severity event, has an SFR of 100, and is configured with a default event action of produce-alert and modify-packet-inline. Signature 1330/4 fires when a single TCP packet is detected. Firing of this signature may indicate a potential exploit of the Crafted TCP ACK Packet Vulnerability described in this document.

Administrators can configure Cisco IPS sensors to perform an event action when an attack is detected. The configured event action performs preventive or deterrent controls to help protect against an attack that is attempting to exploit the Crafted TCP ACK Packet Vulnerability described in this document.

Cisco IPS sensors are most effective when deployed in inline protection mode combined with the use of an event action. Automatic Threat Prevention for Cisco IPS 6.x sensors deployed in inline protection mode provides threat prevention against an attack that is attempting to exploit the Crafted TCP ACK Packet Vulnerability described in this document. Threat prevention is achieved through a default override that performs an event action for triggered signatures with a riskRatingValue greater than 90.

Cisco IPS 5.x sensors that are deployed in inline protection mode require an event action configured on a per-signature basis. Alternatively, administrators can configure an override that can perform an event action for any signatures that are triggered and are calculated as a high-risk threat. Using an event action on sensors deployed in inline protection mode provides the most effective exploit prevention.

For additional information about the risk rating and threat rating calculation, reference Risk Rating and Threat Rating: Simplify IPS Policy Management.

Identification: IPS Signature Events

Signature 1306/0: TCP Option Other

IPS#show events alert
evIdsAlert: eventId=1210361203139064086 severity=low vendor=Cisco
  originator:
    hostId: IPS
    appName: sensorApp
    appInstanceId: 19928
  time: 2008/06/05 17:31:32 2008/06/05 17:31:32 UTC
  signature: description=TCP Option Other id=1306 version=S272
    subsigId: 0
    sigDetails: TCP Option Other Detected
    marsCategory: Info/Misc
  interfaceGroup: vs0
  vlan: 0
  participants:
    attacker:
      addr: locality=OUT 192.168.208.200
      port: 1029
    target:
      addr: locality=OUT 192.168.60.1
      port: 23
      os: idSource=unknown relevance=relevant type=unknown
  riskRatingValue: attackRelevanceRating=relevant targetValueRating=medium 60
  threatRatingValue: 25
  interface: ge0_1
protocol: tcp

Signature 1330/4: TCP Drop - Bad Option Length

IPS#show events alert
evIdsAlert: eventId=1210361203139064085 severity=informational vendor=Cisco
  originator:
    hostId: shiva-4240-1
    appName: sensorApp
    appInstanceId: 19928
  time: 2008/06/05 17:31:32 2008/06/05 17:31:32 UTC
  signature: description=TCP Drop - Bad Option Length id=1330 version=S272
    subsigId: 4
    sigDetails: TCP Packet with bad option length
    marsCategory: Penetrate/ProtocolAnomaly/TCPIP
  interfaceGroup: vs0
  vlan: 0
  participants:
    attacker:
      addr: locality=OUT 192.168.208.200
      port: 1024
    target:
      addr: locality=OUT 192.168.60.1
      port: 23
      os: idSource=unknown relevance=relevant type=unknown
  riskRatingValue: attackRelevanceRating=relevant targetValueRating=medium 35
  threatRatingValue: 0
  interface: ge0_1
  protocol: tcp

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Revision History

Revision 1.1

2008-June-05

Include Signature information for the Crafted TCP ACK Packet Vulnerability

Revision 1.0

2008-June-04

Initial public release

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information


Download this document (PDF)
View Printable Version