Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Applied Mitigation Bulletin

Identifying and Mitigating Exploitation of the Cisco Secure Desktop ActiveX Control Command Execution Vulnerability

Advisory ID: cisco-amb-20100414-csd

http://tools.cisco.com/security/center/content/CiscoAppliedMitigationBulletin/cisco-amb-20100414-csd

Revision 1.0

For Public Release 2010 April 14 16:00  UTC (GMT)


Contents

Cisco Response
Device-Specific Mitigation and Identification
Additional Information
Revision History
Cisco Security Procedures
Related Information

Cisco Response

This Applied Mitigation Bulletin is a companion document to the PSIRT Security Advisory Cisco Secure Desktop ActiveX Control Command Execution Vulnerability and provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

The Cisco Secure Desktop contains a vulnerable ActiveX control. This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. This vulnerability has been assigned CVE identifier CVE-2010-0589.

Information about vulnerable, unaffected, and fixed software is available in the PSIRT Security Advisory, which is available at the following link: http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20100414-csd.

Mitigation Technique Overview

Cisco devices provide several countermeasures for this vulnerability. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Effective exploit prevention can be provided by the Cisco ASA 5500 Series Adaptive Security Appliance, the Cisco PIX 500 Series Security Appliance, and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers using application layer protocol inspection.

Effective exploit prevention can also be provided by the Cisco ACE Application Control Engine Appliance and Module using Application Protocol Inspection.

These protection mechanisms filter and drop packets that are attempting to exploit this vulnerability.

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of this vulnerability. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

caution Caution: The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco ASA, PIX, and FWSM Firewalls

Mitigation: Application Layer Protocol Inspection

Application layer protocol inspection is available beginning in software release 7.2(1) for the Cisco ASA 5500 Series Adaptive Security Appliance and the Cisco PIX 500 Series Security Appliance and in software release 4.0(1) for the Firewall Services Module. This advanced security feature performs deep packet inspection of traffic that transits the firewall. Administrators may construct an inspection policy for applications that require special handling through the configuration of inspect class maps and inspect policy maps, which are applied via a global or interface service policy.

Additional information about application layer protocol inspection is in the Applying Application Layer Protocol Inspection section of the Cisco Security Appliance Command Line Configuration Guide.

caution Caution: Application layer protocol inspection will decrease firewall performance. Administrators are advised to test performance impact in a lab environment before this feature is deployed in production environments.

HTTP Application Inspection By using the HTTP inspection engine on the Cisco ASA 5500 Series Adaptive Security Appliances, the Cisco PIX 500 Series Security Appliances, and the Firewall Services Module, administrators can configure regular expressions (regexes) for pattern matching and construct inspect class maps and inspect policy maps. These methods can help protect against specific vulnerabilities, such as the one described in this document, and other threats that may be associated with HTTP traffic. The following HTTP application inspection configuration uses the Cisco Modular Policy Framework (MPF) to create a policy for inspection of traffic on TCP ports 80, 3128, 8000, 8010, 8080, 8888, and 24326, which are the default ports for the Cisco IPS #WEBPORTS variable. The HTTP application inspection policy will drop connections where the HTTP response body contains any of the regexes that are configured to match the ActiveX control that is associated with this vulnerability.

caution Caution: The configured regexes can match text strings at any location in the body of an HTML response. Care should be taken to ensure that legitimate business applications that use matching text strings without calling the ActiveX control are not affected. Additional information about regex syntax is in Creating a Regular Expression.


 !
 !-- Configure regexes for the ActiveX Class ID 
 !-- "705EC6D4-B138-4079-A307-EF13E4889A82"
 !-- that is associated with this vulnerability
 !
 
 regex CLSID_activeX "705[eE][cC]6[dD]4[-][bB]138[-]4079[-][aA]307[-][eE][fF]13[eE]4889[aA]82"
 
 ! 
 !-- Configure a regex class to match on the regular  
 !-- expressions that are configured above
 !
 
 class-map type regex match-any vulnerable-activeX-class
  match regex CLSID_activeX
 
 !
 !-- Configure an object group for the default ports that 
 !-- are used by the Cisco IPS #WEBPORTS variable, which 
 !-- are TCP ports 80 (www), 3128, 8000, 8010, 8080, 8888, 
 !-- and 24326
 !

 object-group service WEBPORTS tcp
  port-object eq www 
  port-object eq 3128 
  port-object eq 8000 
  port-object eq 8010 
  port-object eq 8080 
  port-object eq 8888 
  port-object eq 24326 
 
 !
 !-- Configure an access list that uses the WEBPORTS object 
 !-- group, which will be used to match TCP packets that 
 !-- are destined to the #WEBPORTS variable that is used 
 !-- by a Cisco IPS device
 !

 access-list Webports-ACL extended permit tcp any any object-group WEBPORTS 
 
 !
 !-- Configure a class that uses the above-configured
 !-- access list to match TCP packets that are destined
 !-- to the ports that are used by the Cisco IPS #WEBPORTS
 !-- variable
 !

 class-map Webports-Class
  match access-list Webports-ACL
 
 !
 !-- Configure an HTTP application inspection policy that  
 !-- looks for and drops connections that contain HTTP  
 !-- protocol violations and looks for and drops connections   
 !-- that contain the regexes for the affected ActiveX Class
 !-- ID or Program ID that are configured above
 ! 
 
policy-map type inspect http http-Policy
  parameters
 
 !
 !-- "protocol-violation" below is not required to
 !-- mitigate this vulnerability but is
 !-- included to provide more robust protection against
 !-- potential HTTP attacks. Care should be taken to ensure that
 !-- legitimate applications that do not fully conform to
 !-- HTTP protocol standards are not dropped by this inspection
 !

   protocol-violation action drop-connection
  match response body regex class vulnerable-activeX-Class
   drop-connection log
 
 !
 !-- Add the above-configured "Webports-Class" that matches 
 !-- TCP packets that are destined to the default ports  
 !-- that are used by the Cisco IPS #WEBPORTS variable to  
 !-- the default policy "global_policy" and use it to 
 !-- inspect HTTP traffic that transits the firewall
 ! 

 policy-map global_policy
  class Webports-Class
   inspect http http-Policy  

 !
 !-- By default, the policy "global_policy" is applied 
 !-- globally, which results in the inspection of 
 !-- traffic that enters the firewall from all interfaces 
 !

service-policy global_policy global

For additional information about the configuration and use of object groups, reference the Cisco Security Appliance Command Reference for object-group.

Additional information about HTTP application inspection and the MPF is in the HTTP Inspection Overview section of the Cisco Security Appliance Command Line Configuration Guide.

Identification: Application Layer Protocol Inspection

Firewall syslog message 415007 will be generated when an HTTP message body matches a user-defined regular expression. The syslog message will identify the corresponding HTTP class and HTTP policy and indicate the action applied to the HTTP connection. Additional information about this syslog message is in Cisco Security Appliance System Log Message - 415007.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance or the Cisco PIX 500 Series Security Appliance is in Monitoring the Security Appliance - Configuring and Managing Logs. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is in Monitoring the Firewall Services Module - Configuring and Managing Logs.

In the following example, the show logging | include regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate attempts to exploit this vulnerability. Administrators can use different regular expressions with the include keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

HTTP Application Inspection

firewall#show logging | include 415007
  Apr 14 2010 14:35:54: %ASA-5-415007: HTTP - matched response 
         body regex class vulnerable-activeX-Class in policy-map 
         http-Policy, Body matched - Dropping connection from 
         outside:192.0.2.117/4369 to inside:192.168.60.65/80
  Apr 14 2010 14:36:57: %ASA-5-415007: HTTP - matched response 
         body regex class vulnerable-activeX-Class in policy-map 
         http-Policy, Body matched - Dropping connection from 
         outside:192.0.2.150/4370 to inside:192.168.60.65/80
 

With HTTP application inspection enabled, the show service-policy inspect protocol command will identify the number of HTTP packets that are inspected and dropped by this feature. The following example shows output for show service-policy inspect http:

firewall# show service-policy inspect http
Global policy: 
  Service-policy: global_policy
    Class-map: inspection_default
    Class-map: Webports-Class
      Inspect: http http-Policy, packet 5025, drop 20, reset-drop 0       protocol violations
          packet 0
        match response body regex class vulnerable-activeX-Class
          drop-connection log, packet 20

In the preceding example, 5025 HTTP packets have been inspected and 20 HTTP packets have been dropped.

Cisco ACE

Mitigation: Application Protocol Inspection

Application protocol inspection is available for the Cisco ACE Application Control Engine Appliance and Module. This advanced security feature performs deep packet inspection of traffic that transits the Cisco ACE. Administrators can construct an inspection policy for applications that require special handling through the configuration of inspect class maps and inspect policy maps, which are applied via a global or interface service policy.

Additional information about application protocol inspection is in the Configuring Application Protocol Inspection section of the Application Control Engine Module Security Configuration Guide.

HTTP Deep Packet Inspection

To conduct HTTP deep packet inspection, administrators can configure regular expressions (regexes) for pattern matching and construct inspect class maps and inspect policy maps. These methods can help protect against specific vulnerabilities, such as the one described in this document, and other threats that may be associated with HTTP traffic. The following HTTP application protocol inspection configuration inspects traffic on TCP ports 80, 3128, 8000, 8010, 8080, 8888, and 24326, which are the default ports for the Cisco IPS #WEBPORTS variable. The HTTP application protocol inspection policy will drop connections where the HTTP content contains any of the regexes that are configured to match the ActiveX control that is associated with this vulnerability.

caution Caution: The configured regexes can match text strings at any location in the content of an HTML packet. Care should be taken to ensure that legitimate business applications that use matching text strings without calling the ActiveX control are not affected.



 ! 
 !-- Configure an HTTP application inspection class that
 !-- looks for HTTP packets that contain the regexes for the
 !-- ActiveX Class ID "705EC6D4-B138-4079-A307-EF13E4889A82" 
 !-- that is associated with this vulnerability
 ! 

 class-map type http inspect match-all vulnerable-activeX-http-class
   match content ".*705[eE][cC]6[dD]4[-][bB]138[-]4079[-][aA]307[-][eE][fF]13[eE]4889[aA]82.*"
  
 !
 !-- Configure an HTTP application inspection policy that
 !-- looks for and resets connections that contain
 !-- the regexes for the ActiveX Class ID or 
 !-- Program ID that are configured above
 !

 policy-map type inspect http all-match vulnerable-activeX-http-policy
   class vulnerable-activeX-http-class
     reset

 !
 !-- Configure an access list that matches TCP packets
 !-- that are destined to the #WEBPORTS variable that is
 !-- used by a Cisco IPS device
 !

 access-list WEBPORTS line 8 extended permit tcp any any eq www 
 access-list WEBPORTS line 16 extended permit tcp any any eq 3128 
 access-list WEBPORTS line 24 extended permit tcp any any eq 8000 
 access-list WEBPORTS line 32 extended permit tcp any any eq 8010 
 access-list WEBPORTS line 40 extended permit tcp any any eq 8080 
 access-list WEBPORTS line 48 extended permit tcp any any eq 8888 
 access-list WEBPORTS line 56 extended permit tcp any any eq 24326 

 !
 !-- Configure a Layer 4 class that uses the above-configured
 !-- access list to match TCP packets that are destined
 !-- to the ports that are used by the Cisco IPS #WEBPORTS
 !-- variable
 !

 class-map match-all L4-http-class
   match access-list WEBPORTS
 
 !
 !-- Configure a Layer 4 policy that applies the HTTP application
 !-- inspection policy configured above to TCP packets that
 !-- are destined to the ports that are used by the Cisco IPS
 !-- #WEBPORTS variable
 !

 policy-map multi-match L4-http-inspect-policy
   class L4-http-class
     inspect http policy vulnerable-activeX-http-policy
 
 !
 !-- Apply the configuration to a specific VLAN interface,
 !-- which results in the inspection of traffic that enters
 !-- the ACE from this interface only
 !
 !-- The configuration could also be applied globally
 !-- which is not shown here
 !

 interface vlan 200
   service-policy input L4-http-inspect-policy

Identification: Application Protocol Inspection

HTTP Deep Packet Inspection

ACE syslog message 415007 will be generated when an HTTP message body matches a user-defined regular expression. The syslog message will identify the corresponding HTTP class and HTTP policy and indicate the action applied to the HTTP connection. Additional information about this syslog message is in Cisco ACE 4700 Series Appliance System Message Guide - System Message 415007.

ACE/Admin# show logging | include 415007
Apr 14 2010 15:26:43: %ACE-5-415007: HTTP - matched vulnerable-activeX-http-class 
      in policy-map vulnerable-activeX-http-policy, Body matched - Dropping 
      connection from 192.0.2.97/6618 to 192.168.60.65/80 Connection 343
Apr 14 2010 15:30:33: %ACE-5-415007: HTTP - matched vulnerable-activeX-http-class
      in policy-map vulnerable-activeX-http-policy, Body matched - Dropping 
      connection from 192.0.2.97/6618 to 192.168.60.65/8080 Connection 401

When HTTP deep packet inspection is enabled, the show service-policy policyname detail command will identify the number of HTTP connections that are inspected and dropped by this feature. The following example shows output for show service-policy L4-http-inspect-policy detail:

ACE/Admin# show service-policy L4-http-inspect-policy detail


Status     : ACTIVE
-----------------------------------------
Interface: vlan 200 
  service-policy: L4-http-inspect-policy
    class: L4-http-class
            inspect http:
                  L7 inspect policy : vulnerable-activeX-http-policy
                   Url Logging: DISABLED
                   curr conns       : 0         , hit count        : 1         
                   dropped conns    : 0         
                   client pkt count : 3         , client byte count: 589                 
                   server pkt count : 3         , server byte count: 547                 
                   L4 policy stats:
                         Total Req/Resp: 2          , Total Allowed: 1         
                     Total Dropped : 1          , Total Logged : 0    
        L7 Inspect policy : vulnerable-activeX-http-policy
          class/match : vulnerable-activeX-http-class
                       Inspect action :
               reset
                       Total Inspected      : 2          , Total Matched: 1         
                       Total Dropped OnError: 0 

In the preceding example, 2 HTTP connections have been inspected and 1 HTTP connection has been dropped. Additional information about HTTP Deep Packet Inspection and Application Protocol Inspection is in the Configuring Application Protocol Inspection section of the Application Control Engine Module Security Configuration Guide.

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Revision History

Revision 1.0

2010-April-14

Initial public release.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information


Download this document (PDF)
View Printable Version