Cisco Applied Mitigation Bulletin

Identifying and Mitigating Exploitation of Multiple Vulnerabilities in Cisco TelePresence Products

Advisory ID: cisco-amb-20110223-telepresence

http://tools.cisco.com/security/center/content/CiscoAppliedMitigationBulletin/cisco-amb-20110223-telepresence

Revision 1.1

For Public Release 2011 February 23 16:00  UTC (GMT)


Contents

Cisco Response
Device-Specific Mitigation and Identification
Additional Information
Revision History
Cisco Security Procedures
Related Information

Cisco Response

This Applied Mitigation Bulletin is a companion document to the PSIRT Cisco TelePresence Bundle of Security Advisories and provides identification and mitigation techniques that administrators can deploy on Cisco network devices. The individual Security Advisories covered by this AMB are as follows:

Vulnerability Characteristics

There are multiple vulnerabilities in Cisco TelePresence products. The following subsections summarize the individual PSIRT Security Advisories and the respective vulnerabilities covered in each Advisory:

Cisco TelePresence Endpoint Devices

Unauthenticated CGI Access: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through HTTP packets using TCP port 8082. This vulnerability has been assigned CVE identifier CVE-2011-0372.

CGI Command Injection: These vulnerabilities can be exploited remotely with authentication and without end-user interaction. Successful exploitation of these vulnerabilities may allow arbitrary code execution. The attack vector for exploitation is through malformed Secure Sockets Layer (SSL) packets using TCP port 443. These vulnerabilities have been assigned CVE identifiers CVE-2011-0373, CVE-2011-0374, and CVE-2011-0375.

TFTP Information Disclosure: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow information disclosure, which enables an attacker to learn information about the affected device. The attack vector for exploitation is through TFTP GET request packets using UDP port 69. This vulnerability has been assigned CVE identifier CVE-2011-0376.

Malicious IP Address Injection: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in a sustained denial of service (DoS) condition. The attack vector for exploitation is through malformed Simple Object Access Protocol (SOAP) packets using TCP ports 8081 and 9501. This vulnerability has been assigned CVE identifier CVE-2011-0377.

XML-RPC Command Injection: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through XML-RPC packets using TCP ports 61441 and 61445. This vulnerability has been assigned CVE identifier CVE-2011-0378.

Cisco Discovery Protocol Remote Code Execution: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through Cisco Discovery Protocol packets. Because Cisco Discovery Protocol works at the Data-Link layer, an attacker must have a way to submit a frame directly to an affected device. This document will not provide any further information for this vulnerability. This vulnerability has been assigned CVE identifier CVE-2011-0379.

Cisco TelePresence Manager

SOAP Authentication Bypass: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow elevation of privilege. The attack vector for exploitation is through malformed SOAP packets using TCP ports 8080 and 8443. This vulnerability has been assigned CVE identifier CVE-2011-0380.

Java Remote Method Invocation (RMI) Command Injection: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through crafted Java RMI packets using TCP ports 1100 and 32000. This vulnerability has been assigned CVE identifier CVE-2011-0381.

Cisco Discovery Protocol Remote Code Execution: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution The attack vector for exploitation is through Cisco Discovery Protocol packets. Because Cisco Discovery Protocol works at the Data-Link layer, an attacker must have a way to submit a frame directly to an affected device. This document will not provide any further information for this vulnerability. This vulnerability has been assigned CVE identifier CVE-2011-0379.

Cisco TelePresence Multipoint Switch

Unauthenticated Java Servlet Access: These vulnerabilities can be exploited remotely without authentication and without end-user interaction. Successful exploitation of these vulnerabilities may allow elevation of privileges. The attack vector for exploitation is through crafted HTTP packets using TCP ports 80 and 8080 and SSL packets using TCP port 443. These vulnerabilities have been assigned CVE identifiers CVE-2011-0383 and CVE-2011-0384.

Unauthenticated Arbitrary File Upload: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through crafted HTTP packets using TCP port 80 and SSL packets using TCP port 443. This vulnerability has been assigned CVE identifier CVE-2011-0385.

Cisco Discovery Protocol Remote Code Execution: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution The attack vector for exploitation is through Cisco Discovery Protocol packets. Because Cisco Discovery Protocol works at the Data-Link layer, an attacker must have a way to submit a frame directly to an affected device. This document will not provide any further information for this vulnerability. This vulnerability has been assigned CVE identifier CVE-2011-0379.

Unauthorized Servlet Access: This vulnerability can be exploited remotely with authentication and without end-user interaction. Successful exploitation of this vulnerability may allow elevation of privileges. The attack vector for exploitation is through HTTP packets using TCP port 80 and SSL packets using TCP port 443. This vulnerability has been assigned CVE identifier CVE-2011-0387.

Java RMI Denial of Service: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in a denial of service (DoS) condition. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through crafted Java RMI packets using TCP port 8999. This vulnerability has been assigned CVE identifier CVE-2011-0388.

Real-Time Transport Control Protocol (RTCP) Denial of Service: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in a denial of service (DoS) condition. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through malicious UDP packets sent to a listening RTCP control port that is randomly selected and negotiated during call setup. An attacker could exploit this vulnerability using spoofed packets. This vulnerability has been assigned CVE identifier CVE-2011-0389.

XML-RPC Denial of Service: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in a denial of service (DoS) condition. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through XML-RPC packets using TCP port 9000. This vulnerability has been assigned CVE identifier CVE-2011-0390.

Cisco TelePresence Recording Server

Unauthenticated Java Servlet Access: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow elevation of privileges. The attack vector for exploitation is through crafted HTTP packets using TCP ports 80 and 8080 and SSL packets using TCP port 443. This vulnerability has been assigned CVE identifier CVE-2011-0383.

CGI Command Injection: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through SSL packets using TCP port 443. This vulnerability has been assigned CVE identifier CVE-2011-0382.

Unauthenticated Arbitrary File Upload: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through crafted HTTP packets using TCP port 80 and SSL packets using TCP port 443. This vulnerability has been assigned CVE identifier CVE-2011-0385.

XML-RPC Arbitrary File Overwrite: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in a denial of service (DoS) condition. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through malformed XML-RPC packets using TCP ports 12102 and 12104. This vulnerability has been assigned CVE identifier CVE-2011-0386.

Cisco Discovery Protocol Remote Code Execution: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation is through Cisco Discovery Protocol packets. Because Cisco Discovery Protocol works at the Data-Link layer, an attacker must have a way to submit a frame directly to an affected device. This document will not provide any further information for this vulnerability. This vulnerability has been assigned CVE identifier CVE-2011-0379.

Ad-Hoc Recording Denial of Service: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in a denial of service (DoS) condition. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through HTTP packets using TCP port 80. This vulnerability has been assigned CVE identifier CVE-2011-0391.

Java RMI Denial of Service: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in a denial of service (DoS) condition. Repeated attempts to exploit this vulnerability could result in a sustained DoS condition. The attack vector for exploitation is through crafted Java RMI packets using TCP port 8999. This vulnerability has been assigned CVE identifier CVE-2011-0388.

Unauthenticated XML-RPC Interface: This vulnerability can be exploited locally without authentication and without end-user interaction. Successful exploitation of this vulnerability may result in the performing of arbitrary actions. The attack vector for exploitation is through XML-RPC packets using TCP port 8080. This vulnerability has been assigned CVE identifier CVE-2011-0392.

Information about vulnerable, unaffected, and fixed software is available in the individual PSIRT Security Advisories, which are available at the following links:

Mitigation Technique Overview

Cisco devices provide several countermeasures for these vulnerabilities. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using the following methods:

  • Infrastructure access control lists (iACLs)
  • Unicast Reverse Path Forwarding (Unicast RPF)
  • IP source guard (IPSG)

These protection mechanisms filter and drop, as well as verify the source IP address of, packets that are attempting to exploit these vulnerabilities.

The proper deployment and configuration of Unicast RPF provides an effective means of protection against attacks that use packets with spoofed source IP addresses. Unicast RPF should be deployed as close to all traffic sources as possible.

The proper deployment and configuration of IPSG provides an effective means of protection against spoofing attacks at the access layer.

Effective means of exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance and the Cisco Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers using the following:

  • Transit access control lists (tACLs)
  • Unicast RPF

These protection mechanisms filter and drop, as well as verify the source IP address of, packets that are attempting to exploit these vulnerabilities.

Effective use of Cisco Intrusion Prevention System (IPS) event actions provides visibility into and protection against attacks that attempt to exploit these vulnerabilities.

Cisco IOS NetFlow records can provide visibility into network-based exploitation attempts.

Cisco IOS Software, Cisco ASA and FWSM firewalls can provide visibility through syslog messages and counter values displayed in the output from show commands.

The Cisco Security Monitoring, Analysis, and Response System (Cisco Security MARS) appliance can also provide visibility through incidents, queries, and event reporting.

For additional information on the various aspects to consider when securing a Cisco TelePresence environment please refer to the Cisco TelePresence Hardening Guide.

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of these vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

Caution: The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Infrastructure Access Control Lists

To protect infrastructure devices and minimize the risk, impact, and effectiveness of direct infrastructure attacks, administrators are advised to deploy infrastructure access control lists (iACLs) to perform policy enforcement of traffic sent to infrastructure equipment. Administrators can construct an iACL by explicitly permitting only authorized traffic sent to infrastructure devices in accordance with existing security policies and configurations. For the maximum protection of infrastructure devices, deployed iACLs should be applied in the ingress direction on all interfaces to which an IP address has been configured. An iACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The iACL policy denies unauthorized the packets on the following protocols/ports that are sent to affected devices:

  • TCP port 80
  • TCP port 443
  • TCP port 1100
  • TCP port 8080
  • TCP port 8081
  • TCP port 8082
  • TCP port 8443
  • TCP port 8999
  • TCP port 9000
  • TCP port 9501
  • TCP port 12102
  • TCP port 12104
  • TCP port 32000
  • TCP port 61441
  • TCP port 61445
  • UDP port 69

In the following example, 192.168.60.0/24 is the IP address space that is used by the affected devices, and the host at 192.168.100.1 is considered a trusted source that requires access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic. Whenever possible, infrastructure address space should be distinct from the address space used for user and services segments. Using this addressing methodology will assist with the construction and deployment of iACLs.

Additional information about iACLs is in Protecting Your Core: Infrastructure Protection Access Control Lists.

 ip access-list extended Infrastructure-ACL-Policy
 
!
 !-- Include explicit permit statements for trusted sources 
 !-- that require access on the vulnerable ports
 !

  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 80
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 1100
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8080
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8081
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8082
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8443
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8999
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9000
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9501
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 12102
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 12104
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 32000
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 61441
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 61445
  permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 69
 
 !
  !-- The following vulnerability-specific access control entries
  !-- (ACEs) can aid in identification of attacks
  !

  deny tcp any 192.168.60.0 0.0.0.255 eq 80
  deny tcp any 192.168.60.0 0.0.0.255 eq 443
  deny tcp any 192.168.60.0 0.0.0.255 eq 1100
  deny tcp any 192.168.60.0 0.0.0.255 eq 8080
  deny tcp any 192.168.60.0 0.0.0.255 eq 8081
  deny tcp any 192.168.60.0 0.0.0.255 eq 8082
  deny tcp any 192.168.60.0 0.0.0.255 eq 8443 
  deny tcp any 192.168.60.0 0.0.0.255 eq 8999
  deny tcp any 192.168.60.0 0.0.0.255 eq 9000
  deny tcp any 192.168.60.0 0.0.0.255 eq 9501
  deny tcp any 192.168.60.0 0.0.0.255 eq 12102
  deny tcp any 192.168.60.0 0.0.0.255 eq 12104
  deny tcp any 192.168.60.0 0.0.0.255 eq 32000 
  deny tcp any 192.168.60.0 0.0.0.255 eq 61441
  deny tcp any 192.168.60.0 0.0.0.255 eq 61445
  deny udp any 192.168.60.0 0.0.0.255 eq 69
 
 !
  !-- Explicit deny ACE for traffic sent to addresses configured within
  !-- the infrastructure address space
  !

 deny ip any 192.168.60.0 0.0.0.255
  
!
  !-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
  !-- with existing security policies and configurations
  !
  !-- Apply iACL to interfaces in the ingress direction
  !

  interface GigabitEthernet0/0
   ip access-group Infrastructure-ACL-Policy in

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration command no ip unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration command ip icmp rate-limit unreachable interval-in-ms.

Mitigation: Spoofing Protection

Unicast Reverse Path Forwarding

One of the vulnerabilities that is described in this document can be exploited by spoofed IP packets. Administrators can deploy and configure Unicast Reverse Path Forwarding (Unicast RPF) as a protection mechanism against spoofing.

Unicast RPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on Unicast RPF to provide complete spoofing protection because spoofed packets may enter the network through a Unicast RPF-enabled interface if an appropriate return route to the source IP address exists. Administrators are advised to take care to ensure that the appropriate Unicast RPF mode (loose or strict) is configured during the deployment of this feature because it can drop legitimate traffic that is transiting the network. In an enterprise environment, Unicast RPF might be enabled at the Internet edge and the internal access layer on the user-supporting Layer 3 interfaces.

Additional information is in the Unicast Reverse Path Forwarding Loose Mode Feature Guide.

For additional information about the configuration and use of Unicast RPF, reference the Understanding Unicast Reverse Path Forwarding Applied Intelligence white paper.

IP Source Guard

IP source guard (IPSG) is a security feature that restricts IP traffic on nonrouted, Layer 2 interfaces by filtering packets based on the DHCP snooping binding database and manually configured IP source bindings. Administrators can use IPSG to prevent attacks from an attacker who attempts to spoof packets by forging the source IP address and/or the MAC address. When properly deployed and configured, IPSG coupled with strict mode Unicast RPF provides the most effective means of spoofing protection for the vulnerabilities that are described in this document.

Additional information about the deployment and configuration of IPSG is in Configuring DHCP Features and IP Source Guard.

Identification: Infrastructure Access Control Lists

After the administrator applies the iACL to an interface, the show ip access-lists command will identify the packets on the following protocols/ports that have been filtered on interfaces on which the iACL is applied:

  • TCP port 80
  • TCP port 443
  • TCP port 1100
  • TCP port 8080
  • TCP port 8081
  • TCP port 8082
  • TCP port 8443
  • TCP port 8999
  • TCP port 9000
  • TCP port 9501
  • TCP port 12102
  • TCP port 12104
  • TCP port 32000
  • TCP port 61441
  • TCP port 61445
  • UDP port 69

Administrators should investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ip access-lists follows:

router#show ip access-lists Infrastructure-ACL-Policy
Extended IP access list Infrastructure-ACL-Policy
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq www
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443
    30 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 1100
    40 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8080
    50 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8081
    60 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8082
    70 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8443 (1 match)
    80 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8999
    90 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9000
    100 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9501
    110 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 12102
    120 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 12104
    130 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 32000
    140 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 61441
    150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 61445
    160 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq tftp
    170 deny tcp any 192.168.60.0 0.0.0.255 eq www (703 matches)
    180 deny tcp any 192.168.60.0 0.0.0.255 eq 443 (213 matches)
    190 deny tcp any 192.168.60.0 0.0.0.255 eq 1100 (95 matches)
    200 deny tcp any 192.168.60.0 0.0.0.255 eq 8080 (115 matches)
    210 deny tcp any 192.168.60.0 0.0.0.255 eq 8081 (119 matches)
    220 deny tcp any 192.168.60.0 0.0.0.255 eq 8082 (86 matches)
    230 deny tcp any 192.168.60.0 0.0.0.255 eq 8443 (125 matches)
    240 deny tcp any 192.168.60.0 0.0.0.255 eq 8999 (63 matches)
    250 deny tcp any 192.168.60.0 0.0.0.255 eq 9000 (3 matches)
    260 deny tcp any 192.168.60.0 0.0.0.255 eq 9501 (142 matches)
    270 deny tcp any 192.168.60.0 0.0.0.255 eq 12102 (127 matches)
    280 deny tcp any 192.168.60.0 0.0.0.255 eq 12104 (132 matches)
    290 deny tcp any 192.168.60.0 0.0.0.255 eq 32000 (125 matches)
    300 deny tcp any 192.168.60.0 0.0.0.255 eq 61441 (110 matches)
    310 deny tcp any 192.168.60.0 0.0.0.255 eq 61445 (114 matches)
    320 deny udp any 192.168.60.0 0.0.0.255 eq tftp (218 matches)
    330 deny ip any 192.168.60.0 0.0.0.255 (9 matches)
router#

In the preceding example, access list Infrastructure-ACL-Policy has dropped the following packets that are received from an untrusted host or network:

  • 703 HTTP packets on TCP port 80 (www) for ACE line 170
  • 213 SSL packets on TCP port 443 for ACE line 180
  • 95 packets on TCP port 1100 for ACE line 190
  • 115 packets on TCP port 8080 for ACE line 200
  • 119 packets on TCP port 8081 for ACE line 210
  • 86 packets on TCP port 8082 for ACE line 220
  • 125 packets on TCP port 8443 for ACE line 230
  • 63 packets on TCP port 8999 for ACE line 240
  • 3 packets on TCP port 9000 for ACE line 250
  • 142 packets on TCP port 9501 for ACE line 260
  • 127 packets on TCP port 12102 for ACE line 270
  • 132 packets on TCP port 12104 for ACE line 280
  • 125 packets on TCP port 32000 for ACE line 290
  • 110 packets on TCP port 61441 for ACE line 300
  • 114 packets on TCP port 61445 for ACE line 310
  • 218 TFTP packets on UDP port 69 for ACE line 320

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Applied Intelligence white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Applied Intelligence white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: Access List Logging

The log and log-input access control list (ACL) option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

For Cisco IOS Software, the ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by ACL logging. The logging rate-limit rate-per-second [except loglevel] command limits the impact of log generation and transmission.

The CPU impact from ACL logging can be addressed in hardware on the Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging.

For additional information about the configuration and use of ACL logging, reference the Understanding Access Control List Logging Applied Intelligence white paper.

Identification: Spoofing Protection Using Unicast Reverse Path Forwarding

With Unicast RPF properly deployed and configured throughout the network infrastructure, administrators can use the show cef interface type slot/port internal, show ip interface, show cef drop, show ip cef switching statistics feature and show ip traffic commands to identify the number of packets that Unicast RPF has dropped.

Note: Beginning with Cisco IOS Software version 12.4(20)T, the command show ip cef switching has been replaced by show ip cef switching statistics feature.

Note: The show command | begin regex and show command | include regex command modifiers are used in the following examples to minimize the amount of output that administrators will need to parse to view the desired information. Additional information about command modifiers is in the show command sections of the Cisco IOS Configuration Fundamentals Command Reference.

router#show cef interface GigabitEthernet 0/0 internal | include drop    
 
ip verify: via=rx (allow default), acl=0, drop=18, sdrop=0  
router#

Note: show cef interface type slot/port internal is a hidden command that must be fully entered at the command-line interface. Command completion is not available for it.

router#show ip interface GigabitEthernet 0/0 | begin verify      

        IP verify source reachable-via RX, allow default, allow self-ping    
        18 verification drops    
        0 suppressed verification drops  
router#      


router#show cef drop  
CEF Drop Statistics  
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj  ChkSum_Err  
RP            27           0           0          18           0           0  
router#    

router#show ip cef switching statistics feature  
IPv4 CEF input features:
Path   Feature                Drop    Consume       Punt  Punt2Host Gave route
RP PAS uRPF                     18          0          0          0          0
Total                           18          0          0          0          0      
--      CLI Output Truncated       --    
router#      

router#show ip traffic | include RPF
           18 no route, 18 unicast RPF, 0 forced drop  
router#

In the preceding show cef drop, show ip cef switching statistics feature and show ip traffic examples, Unicast RPF has dropped 18 IP packets received globally on all interfaces with Unicast RPF configured because of the inability to verify the source address of the IP packets within the Forwarding Information Base of Cisco Express Forwarding.

Cisco IOS NetFlow

Identification: Traffic Flow Identification Using NetFlow Records

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of traffic flows that may be attempts to exploit these vulnerabilities. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

router#show ip cache flow

IP packet size distribution (1779 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .323 .676 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 278544 bytes
  183 active, 3913 inactive, 364 added
  4883 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 34056 bytes
  0 active, 1024 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-WWW             16      0.0         7    40      0.0       0.0      15.7
TCP-other          126      0.0         3    40      0.1       0.0      15.4
UDP-TFTP             7      0.0         6    28      0.0       0.0      15.6
UDP-other           32      0.0         6    28      0.0       0.0      15.4
Total:             181      0.0         4    36      0.1       0.0      15.5

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Et0/0         192.168.21.36   Et0/1          192.168.60.17   11 CD3E 0045     1 
Et0/0         192.168.100.31  Et0/1          192.168.60.210  06 8F8C 044C     6 
Et0/0         192.168.100.14  Et0/1          192.168.60.121  06 DEBB 251D     3 
Et0/0         192.168.100.209 Et0/1          192.168.60.19   06 C460 1F90     3 
Et0/0         192.168.100.235 Et0/1          192.168.60.15   06 46E6 7D00     1 
Et0/0         192.168.159.166 Et0/1          192.168.90.53   11 62E2 B413    10 
Et0/0         192.168.100.164 Et0/1          192.168.60.91   06 5460 2F46     3 
Et0/0         192.168.100.83  Et0/1          192.168.60.30   06 E440 1F92     6 
Et0/0         192.168.12.204  Et0/1          192.168.162.10  11 39D3 9273    10 
Et0/0         192.168.100.211 Et0/1          192.168.60.174  06 846A 1F91     4 
Et0/0         192.168.100.112 Et0/1          192.168.60.242  06 4F39 044C     3 
Et0/0         192.168.100.147 Et0/1          192.168.60.153  06 9B55 0050    15 
Et0/0         192.168.100.188 Et0/1          192.168.60.26   06 E9AC 2327     4 
Et0/0         192.168.100.188 Et0/1          192.168.60.26   06 E9AC 2328     4 
Et0/0         192.168.194.210 Et0/1          192.168.4.64    11 85DE BE0C     5 
Et0/0         192.168.100.171 Et0/1          192.168.60.215  06 84F3 1F91     1 
Et0/0         192.168.100.121 Et0/1          192.168.60.165  06 15A0 2F48     8 
Et0/0         192.168.100.97  Et0/1          192.168.60.22   06 0951 2327     1 
Et0/0         192.168.100.221 Et0/1          192.168.60.170  06 DBCF 0050    10 
Et0/0         192.168.6.90    Et0/1          192.168.243.120 06 14E7 773D    10 
Et0/0         192.168.100.174 Et0/1          192.168.60.239  06 0414 1F91     5 
Et0/0         192.168.100.51  Et0/1          192.168.60.109  06 EF9D 251D     2 
Et0/0         192.168.78.53   Et0/1          192.168.60.37   11 07A2 0045     2 
Et0/0         192.168.164.19  Et0/1          192.168.201.180 06 FA1C 557B     5 
Et0/0         192.168.66.15   Et0/1          192.168.155.182 11 FBC6 585A     3 
Et0/0         192.168.100.208 Et0/1          192.168.60.137  06 BEC3 20FB     1 
Et0/0         192.168.100.43  Et0/1          192.168.60.70   06 5E31 01BB    14 
Et0/0         192.168.100.43  Et0/1          192.168.60.0    06 0FAA F001     1 
Et0/0         192.168.29.205  Et0/1          192.168.240.249 11 71B3 8F9C     8 
Et0/0         192.168.100.179 Et0/1          192.168.60.214  06 A2C4 F005     4 
Et0/0         192.168.89.13   Et0/1          192.168.204.26  11 1D17 2CB0    11 
router#

In the preceding example, there are multiple flows for:

  • HTTP on TCP port 80 (hex value 0050)
  • SSL on TCP port 443 (hex value 01BB)
  • TCP port 1100 (hex value 044C)
  • TCP port 8080 (hex value 1F90)
  • TCP port 8081 (hex value 1F91)
  • TCP port 8082 (hex value 1F92)
  • TCP port 8443 (hex value 20FB)
  • TCP port 8999 (hex value 2327)
  • TCP port 9000 (hex value 2328)
  • TCP port 9501 (hex value 251D)
  • TCP port 12102 (hex value 2F46)
  • TCP port 12104 (hex value 2F48)
  • TCP port 32000 (hex value 7D00)
  • TCP port 61441 (hex value F001)
  • TCP port 61445 (hex value F005)
  • TFTP on UDP port 69 (hex value 0045)

This traffic is sourced from and sent to addresses within the 192.168.60.0/24 address block, which is used for infrastructure devices. The packets in these flows may be spoofed and may indicate an attempt to exploit these vulnerabilities. Administrators are advised to compare these flows to baseline utilization for traffic sent on the above protocols/ports and also investigate the flows to determine whether they are sourced from untrusted hosts or networks. To view only the traffic flows for packets on the above ports/protocols, the command show ip cache flow | include SrcIf|__11_.*0045 will display the related UDP NetFlow records as shown here:

UDP Flows

router#show ip cache flow | include SrcIf|_11_.*0045
SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts

Et0/0         192.168.54.222  Et0/1         192.168.60.43   11 7947 0045     3 
Et0/0         192.168.247.117 Et0/1         192.168.60.169  11 45FB 0045     1 
Et0/0         192.168.250.16  Et0/1         192.168.60.79   11 66AC 0045    10 
Et0/0         192.168.121.112 Et0/1         192.168.60.36   11 6725 0045    16 
Et0/0         192.168.243.192 Et0/1         192.168.60.225  11 2B52 0045     1 
router#

To view only the traffic flows for packets on the above ports/protocols, the command show ip cache flow | include SrcIf|__06_.*(0050|01BB|044C|1F90|1F91|1F92|20FB|2327|2328|251D|2F46|2F48|7D00|F001|F005)_ will display the related TCP NetFlow records as shown here:

TCP Flows

router#show ip cache flow | include SrcIf|_06_.*(0050|01BB|044C|1F90|1F91|1F92|20FB|2327|2328|251D|2F46|2F48|7D00|F001|F005)_
SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Et0/0         192.168.100.14  Et0/1          192.168.60.121  06 DEBB 251D     3 
Et0/0         192.168.100.209 Et0/1          192.168.60.19   06 C460 1F90     3 
Et0/0         192.168.100.235 Et0/1          192.168.60.15   06 46E6 7D00     1 
Et0/0         192.168.100.164 Et0/1          192.168.60.91   06 5460 2F46     3 
Et0/0         192.168.100.83  Et0/1          192.168.60.30   06 E440 1F92     6 

Et0/0         192.168.100.211 Et0/1          192.168.60.174  06 846A 1F91     4 
Et0/0         192.168.100.112 Et0/1          192.168.60.242  06 4F39 044C     3 
Et0/0         192.168.100.147 Et0/1          192.168.60.153  06 9B55 0050    15 
Et0/0         192.168.100.188 Et0/1          192.168.60.26   06 E9AC 2327     4 
Et0/0         192.168.100.188 Et0/1          192.168.60.26   06 E9AC 2328     4 

Et0/0         192.168.100.121 Et0/1          192.168.60.165  06 15A0 2F48     8 

Et0/0         192.168.100.208 Et0/1          192.168.60.137  06 BEC3 20FB     1 
Et0/0         192.168.100.43  Et0/1          192.168.60.70   06 5E31 01BB    14 
Et0/0         192.168.100.43  Et0/1          192.168.60.0    06 0FAA F001     1 
Et0/0         192.168.100.179 Et0/1          192.168.60.214  06 A2C4 F005     4 

Et0/0         192.168.100.209 Et0/1          192.168.60.19   06 C460 1F90     3 
router#

Cisco ASA and FWSM Firewalls

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized the packets on the following protocols/ports that are sent to affected devices:

  • TCP port 80
  • TCP port 443
  • TCP port 1100
  • TCP port 8080
  • TCP port 8081
  • TCP port 8082
  • TCP port 8443
  • TCP port 8999
  • TCP port 9000
  • TCP port 9501
  • TCP port 12102
  • TCP port 12104
  • TCP port 32000
  • TCP port 61441
  • TCP port 61445
  • UDP port 69

In the following example, 192.168.60.0/24 is the IP address space that is used by the affected devices, and the host at 192.168.100.1 is considered a trusted source that requires access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.


!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable ports
!

access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 80
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 443
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 1100
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 8080
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 8081
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 8082
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 8443
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 8999
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9000
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9501
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 12102
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 12104
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 32000
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 61441
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 61445
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 69

!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!

access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 80
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 443
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 1100
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 8080
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 8081
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 8082
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 8443
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 8999
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 9000
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 9501
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 12102
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 12104
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 32000
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 61441
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 61445
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 eq 69

!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!

access-list tACL-Policy extended deny ip any any

!
!-- Apply tACL to interface(s) in the ingress direction
!

access-group tACL-Policy in interface outside

Mitigation: Spoofing Protection Using Unicast Reverse Path Forwarding

The vulnerabilities that are described in this document can be exploited by spoofed IP packets. Administrators can deploy and configure Unicast RPF as a protection mechanism against spoofing.

Unicast RPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on Unicast RPF to provide complete spoofing protection because spoofed packets may enter the network through a Unicast RPF-enabled interface if an appropriate return route to the source IP address exists. In an enterprise environment, Unicast RPF might be enabled at the Internet edge and at the internal access layer on the user-supporting Layer 3 interfaces.

For additional information about the configuration and use of Unicast RPF, reference the Cisco Security Appliance Command Reference for ip verify reverse-path and the Understanding Unicast Reverse Path Forwarding Applied Intelligence white paper.

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the following protocols/ports that have been filtered:

  • TCP port 80
  • TCP port 443
  • TCP port 1100
  • TCP port 8080
  • TCP port 8081
  • TCP port 8082
  • TCP port 8443
  • TCP port 8999
  • TCP port 9000
  • TCP port 9501
  • TCP port 12102
  • TCP port 12104
  • TCP port 32000
  • TCP port 61441
  • TCP port 61445
  • UDP port 69

Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show access-list tACL-Policy follows:

firewall#show access-list tACL-Policy
access-list tACL-Policy; 31 elements
access-list tACL-Policy line 1 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq www (hitcnt=55)
access-list tACL-Policy line 2 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq https (hitcnt=765)
access-list tACL-Policy line 3 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 1100 (hitcnt=43)
access-list tACL-Policy line 4 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 8080 (hitcnt=265)
access-list tACL-Policy line 5 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 8081 (hitcnt=18)
access-list tACL-Policy line 6 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 8082 (hitcnt=77)
access-list tACL-Policy line 7 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 8443 (hitcnt=345)
access-list tACL-Policy line 8 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 8999 (hitcnt=137)
access-list tACL-Policy line 9 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 9000 (hitcnt=17)
access-list tACL-Policy line 10 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 9501 (hitcnt=36)
access-list tACL-Policy line 11 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 12102 (hitcnt=40)
access-list tACL-Policy line 12 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 12104 (hitcnt=23)
access-list tACL-Policy line 13 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 32000 (hitcnt=109)
access-list tACL-Policy line 14 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 61441 (hitcnt=60)
access-list tACL-Policy line 15 extended permit tcp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq 61445 (hitcnt=95)
access-list tACL-Policy line 16 extended permit udp host 192.168.100.1 
192.168.60.0 255.255.255.0 eq tftp (hitcnt=4567)
access-list tACL-Policy line 17 extended deny tcp any 
192.168.60.0 255.255.255.0 eq www (hitcnt=28)
access-list tACL-Policy line 18 extended deny tcp any 
192.168.60.0 255.255.255.0 eq https (hitcnt=169)
access-list tACL-Policy line 19 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 1100 (hitcnt=93)
access-list tACL-Policy line 20 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 8080 (hitcnt=11)
access-list tACL-Policy line 21 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 8081 (hitcnt=9)
access-list tACL-Policy line 22 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 8082 (hitcnt=9)
access-list tACL-Policy line 23 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 8443 (hitcnt=34)
access-list tACL-Policy line 24 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 8999 (hitcnt=46)
access-list tACL-Policy line 25 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 9000 (hitcnt=6)
access-list tACL-Policy line 26 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 9501 (hitcnt=9)
access-list tACL-Policy line 27 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 12102 (hitcnt=11)
access-list tACL-Policy line 28 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 12104 (hitcnt=24)
access-list tACL-Policy line 29 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 32000 (hitcnt=48)
access-list tACL-Policy line 30 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 61441 (hitcnt=32)
access-list tACL-Policy line 31 extended deny tcp any 
192.168.60.0 255.255.255.0 eq 61445 (hitcnt=9)
access-list tACL-Policy line 32 extended deny udp any 
192.168.60.0 255.255.255.0 eq tftp (hitcnt=78)
access-list tACL-Policy line 33 extended deny ip any any (hitcnt=4658)
firewall#

In the preceding example, access list tACL-Policy has dropped the following packets received from an untrusted host or network:

  • 28 HTTP packets on TCP port 80 (www) for ACE line 17
  • 169 SSL packets on TCP port 443 (https) for ACE line 18
  • 93 packets on TCP port 1100 for ACE line 19
  • 11 packets on TCP port 8080 for ACE line 20
  • 9 packets on TCP port 8081 for ACE line 21
  • 9 packets on TCP port 8082 for ACE line 22
  • 34 packets on TCP port 8443 for ACE line 23
  • 46 packets on TCP port 8999 for ACE line 24
  • 6 packets on TCP port 9000 for ACE line 25
  • 9 packets on TCP port 9501 for ACE line 26
  • 11 packets on TCP port 12102 for ACE line 27
  • 24 packets on TCP port 12014 for ACE line 28
  • 48 packets on TCP port 32000 for ACE line 29
  • 32 packets on TCP port 61441 for ACE line 30
  • 9 packets on TCP port 61445 for ACE line 31
  • 78 TFTP packets on UDP port 69 (tftp) for ACE line 32

Identification: Firewall Access List Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an access control entry (ACE) that does not have the log keyword present. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

firewall#show logging | grep 106023
  Jan 12 2011 14:57:41: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.215/80 by access-group "tACL-Policy"
  Jan 12 2011 14:57:41: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/80 by access-group "tACL-Policy"
  Jan 12 2011 14:57:41: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.173/80 by access-group "tACL-Policy"
  Jan 12 2011 14:57:41: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/80 by access-group "tACL-Policy"
  Jan 12 2011 14:57:48: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/443 by access-group "tACL-Policy"
  Jan 12 2011 14:57:48: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/443 by access-group "tACL-Policy"
  Jan 12 2011 14:57:48: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/443 by access-group "tACL-Policy"
  Jan 12 2011 14:57:55: %ASA-4-106023: Deny tcp src outside:192.168.225.47/1024 
                  dst inside:192.168.60.25/1100 by access-group "tACL-Policy"
  Jan 12 2011 14:57:55: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/1100 by access-group "tACL-Policy"
  Jan 12 2011 14:57:55: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/1100 by access-group "tACL-Policy"
  Jan 12 2011 14:57:55: %ASA-4-106023: Deny tcp src outside:192.168.156.169/1024 
                  dst inside:192.168.60.25/1100 by access-group "tACL-Policy"
  Jan 12 2011 14:58:02: %ASA-4-106023: Deny tcp src outside:192.168.191.223/1024 
                  dst inside:192.168.60.103/8080 by access-group "tACL-Policy"
  Jan 12 2011 14:58:02: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.25/8080 by access-group "tACL-Policy"
  Jan 12 2011 14:58:02: %ASA-4-106023: Deny tcp src outside:192.168.1.1/1024 
                  dst inside:192.168.60.177/8080 by access-group "tACL-Policy"
firewall#

In the preceding example, the messages logged for the tACL tACL-Policy show HTTP packets for TCP port 80, SSL packets for TCP port 443, packets for TCP port 1100, and packets for TCP port 8080 sent to the address block assigned to affected devices.

Additional information about syslog messages for ASA security appliances is in Cisco ASA 5500 Series System Log Messages, 8.2. Additional information about syslog messages for the FWSM is in Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Logging System Log Messages.

For additional information about investigating incidents using syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Applied Intelligence white paper.

Identification: Spoofing Protection Using Unicast Reverse Path Forwarding

Firewall syslog message 106021 will be generated for packets denied by Unicast RPF. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106021.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

firewall#show logging | grep 106021    
        Feb 21 2010 00:15:13: %ASA-1-106021: Deny UDP reverse path check from           
                   192.168.60.1 to 192.168.60.100 on interface outside    
        Feb 21 2010 00:15:13: %ASA-1-106021: Deny UDP reverse path check from           
                   192.168.60.1 to 192.168.60.100 on interface outside   
        Feb 21 2010 00:15:13: %ASA-1-106021: Deny TCP reverse path check from           
                   192.168.60.1 to 192.168.60.100 on interface outside 

The show asp drop command can also identify the number of packets that the Unicast RPF feature has dropped, as shown in the following example:

firewall#show asp drop frame rpf-violated    
        Reverse-path verify failed                          11  
firewall#

In the preceding example, Unicast RPF has dropped 11 IP packets received on interfaces with Unicast RPF configured. Absence of output indicates that the Unicast RPF feature on the firewall has not dropped packets.

For additional information about debugging accelerated security path dropped packets or connections, reference the Cisco Security Appliance Command Reference for show asp drop.

Cisco Intrusion Prevention System

Mitigation: Cisco IPS Signature Event Actions

Administrators can use Cisco Intrusion Prevention System (IPS) appliances and services modules to provide threat detection and help prevent attempts to exploit the vulnerabilities that are described in this document. these vulnerabilities may be detected by the following signatures:

  • 32719-0: Cisco Telepresence Unauthenticated Remote Arbitrary Command Execution
  • 33859-0: Cisco TelePresence Endpoint CGI Command Injection
  • 33860-0: Cisco TelePresence Multipoint Switch Java Servlet Access
  • 33860-1: Cisco TelePresence Multipoint Switch Java Servlet Access
  • 33861-0: Cisco TelePresence Recording Server Command Execution Vulnerability

32719-0: Cisco Telepresence Unauthenticated Remote Arbitrary Command Execution

Beginning with signature update S550 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 32719/0 (Signature Name: Cisco Telepresence Unauthenticated Remote Arbitrary Command Execution). Signature 32719/0 is enabled by default, triggers a High severity event, has a signature fidelity rating (SFR) of 90, and is configured with a default event action of produce-alert.

Signature 32719/0 fires on an attempt to exploit an unauthenticated remote arbitrary command execution vulnerability in a Cisco TelePresence Endpoint sent using TCP port 8082. Firing of this signature may indicate a potential exploit of these vulnerabilities.

33859-0: Cisco TelePresence Endpoint CGI Command Injection

Beginning with signature update S550 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 33859-0 (Signature Name: Cisco TelePresence Endpoint CGI Command Injection). Signature 33859/0 is enabled by default, triggers a High severity event, has a signature fidelity rating (SFR) of 80, and is configured with a default event action of produce-alert.

Signature 33859/0 fires on an attempt to exploit an unauthenticated remote arbitrary command execution vulnerability in a Cisco TelePresence Endpoint sent using TCP port 8082. Firing of this signature may indicate a potential exploit of these vulnerabilities.

33860-0: Cisco TelePresence Multipoint Switch Java Servlet Access

Beginning with signature update S550 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 33860-0 (Signature Name: Cisco TelePresence Multipoint Switch Java Servlet Access). Signature 33860/0 is disabled by default, triggers a High severity event, has a signature fidelity rating (SFR) of 75, and is configured with a default event action of produce-alert.

Signature 33860/0 fires upon detecting access of several Java servlets within the Cisco TelePresence Multipoint Switch sent using TCP port 8080. Firing of this signature may indicate a potential exploit of these vulnerabilities.

Note: This signature may fire benignly on devices that are not Cisco TelePresence Multipoint Switches. Further investigation is required to eliminate such devices.

33860-1: Cisco TelePresence Multipoint Switch Java Servlet Access

Beginning with signature update S550 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 33860-1 (Signature Name: Cisco TelePresence Multipoint Switch Java Servlet Access). Signature 33860/1 is disabled by default, triggers a High severity event, has a signature fidelity rating (SFR) of 75, and is configured with a default event action of produce-alert.

Signature 33860/1 fires upon detecting access of several Java servlets within the Cisco TelePresence Multipoint Switch sent using TCP port 80. Firing of this signature may indicate a potential exploit of these vulnerabilities.

Note: This signature may fire benignly on devices that are not Cisco TelePresence Multipoint Switches. Further investigation is required to eliminate such devices.

33861-0: Cisco TelePresence Recording Server Command Execution Vulnerability

Beginning with signature update S550 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 33861/0 (Signature Name: Cisco TelePresence Recording Server Command Execution Vulnerability). Signature 33861/0 is enabled by default, triggers a High severity event, has a signature fidelity rating (SFR) of 90, and is configured with a default event action of produce-alert.

This Signature fires upon detecting an attempt to exploit a specific command execution vulnerability in Cisco TelePresence Recording Server. This vulnerability is further documented in CVE-2011-0382.

Signature 33861/0 is a meta signature and is composed of multiple subsignatures (Signature IDs 33861-1 through 33861-4) that all must be triggered to cause the meta signature to trigger. Each of the individual subsignatures therefore has no event action on its own and thus each is considered an Informational severity event.

Administrators can configure Cisco IPS sensors to perform an event action when an attack is detected. The configured event action performs preventive or deterrent controls to help protect against an attack that is attempting to exploit the vulnerabilities that are described in this document.

Cisco IPS sensors are most effective when deployed in inline protection mode combined with the use of an event action. Automatic Threat Prevention for Cisco IPS 6.x and greater sensors that are deployed in inline protection mode provides threat prevention against an attack that is attempting to exploit the vulnerabilities that are described in this document. Threat prevention is achieved through a default override that performs an event action for triggered signatures with a riskRatingValue greater than 90.

For additional information about the risk rating and threat rating calculation, reference Risk Rating and Threat Rating: Simplify IPS Policy Management.

Cisco Security Monitoring, Analysis, and Response System

Identification: Cisco Security Monitoring, Analysis, and Response System Incidents

The Cisco Security Monitoring, Analysis, and Response System (Cisco Security MARS) appliance can create incidents regarding events that are related to the vulnerabilities that are described in this document using IPS signatures:

  • 32719-0: Cisco Telepresence Unauthenticated Remote Arbitrary Command Execution
  • 33859-0: Cisco TelePresence Endpoint CGI Command Injection
  • 33860-0: Cisco TelePresence Multipoint Switch Java Servlet Access
  • 33860-1: Cisco TelePresence Multipoint Switch Java Servlet Access
  • 33861-0: Cisco TelePresence Recording Server Command Execution Vulnerability

After the S550 dynamic signature update has been downloaded, using the following keywords for the respective IPS signature IDs and a query type of All Matching Event Raw Messages on the Cisco Security MARS appliance will provide a report that lists the incidents created by the IPS signature.

  • NR-32719/0 for IPS signature 32719/0
  • NR-33859/0 for IPS signature 33859/0
  • NR-33860/0 for IPS signature 33860/0
  • NR-33860/1 for IPS signature 33860/1
  • NR-33861 for IPS signatures 33861/0 through 33861/4

Beginning with the 4.3.1 and 5.3.1 releases of Cisco Security MARS appliances, support for the Cisco IPS dynamic signature updates feature has been added. This feature downloads new signatures from Cisco.com or from a local web server, correctly processes and categorizes received events that match those signatures, and includes them in inspection rules and reports. These updates provide event normalization and event group mapping, and they also enable the MARS appliance to parse new signatures from the IPS devices.

Caution: If dynamic signature updates are not configured, events that match these new signatures appear as unknown event type in queries and reports. Because MARS will not include these events in inspection rules, incidents may not be created for potential threats or attacks that occur within the network.

By default, this feature is enabled but requires configuration. If it is not configured, the following Cisco Security MARS rule will be triggered:

System Rule: CS-MARS IPS Signature Update Failure

When this feature is enabled and configured, administrators can determine the current signature version downloaded by MARS by selecting Help > About and reviewing the IPS Signature Version value.

Additional information about dynamic signature updates and instructions for configuring dynamic signature updates are available for the Cisco Security MARS 4.3.1 and 5.3.1 releases.

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Revision History

Revision 1.1

2011-February-25

Updated to include information on Signature ID 33861-0.

Revision 1.0

2011-February-23

Initial public release.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information


Download this document (PDF)
View Printable Version