Cisco Applied Mitigation Bulletin

Identifying and Mitigating Exploitation of the Multiple Vulnerabilities in Cisco Voice Products

Advisory ID: cisco-amb-20110928-voice

http://tools.cisco.com/security/center/content/CiscoAppliedMitigationBulletin/cisco-amb-20110928-voice

Revision 1.0

For Public Release 2011 September 28 16:00  UTC (GMT)


Contents

Cisco Response
Device-Specific Mitigation and Identification
Additional Information
Revision History
Cisco Security Procedures
Related Information

Cisco Response

This Applied Mitigation Bulletin is a companion document to the following PSIRT Security Advisories:

  • Cisco IOS Software Session Initiation Protocol Denial of Service Vulnerabilities
  • Cisco Unified Communications Manager Session Initiation Protocol Memory Leak Vulnerability

This document provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

There are multiple vulnerabilities in Cisco IOS Software and Cisco Unified Communications Manager. The following subsection summarizes these vulnerabilities:

Session Initiation Protocol (SIP) Memory Leak Vulnerabilities: These vulnerabilities affect both Cisco IOS Software and Cisco Unified Communications Manager. These vulnerabilities can be exploited remotely without authentication and without end-user interaction. Successful exploitation of these vulnerabilities may cause the affected device to crash or result in a denial of service (DoS) condition. Repeated attempts to exploit these vulnerabilities could result in a sustained DoS condition.

The attack vectors for exploitation are through a packet that uses the following protocols and ports:

  • SIP using TCP port 5060
  • SIP Transport Layer Security (TLS) using TCP port 5061
  • SIP using UDP port 5060
  • SIP TLS using UDP port 5061 (Cisco Unified Communications Manager only)

An attacker could exploit these vulnerabilities using spoofed packets.

These vulnerabilities have been assigned the following CVE identifiers:

  • CVE-2011-0939
  • CVE-2011-2072
  • CVE-2011-3275
  • CVE-2011-2073

Vulnerability Overview

Information about vulnerable, unaffected, and fixed software is available in the PSIRT Security Advisories, which are available at the following links:

Mitigation Technique Overview

Cisco devices provide several countermeasures for these vulnerabilities. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using the following methods:

  • Infrastructure access control lists (iACLs)
  • Transit access control lists (tACLs)
  • Unicast Reverse Path Forwarding (Unicast RPF)
  • IP source guard (IPSG)

These protection mechanisms filter and drop, as well as verify the source IP address of, packets that are attempting to exploit these vulnerabilities.

The proper deployment and configuration of Unicast RPF provides an effective means of protection against attacks that use packets with spoofed source IP addresses. Unicast RPF should be deployed as close to all traffic sources as possible.

The proper deployment and configuration of IPSG provides an effective means of protection against spoofing attacks at the access layer.

Effective means of exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance and the Cisco Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers using the following methods:

  • tACL
  • Unicast RPF

These protection mechanisms filter and drop, as well as verify the source IP address of, packets that are attempting to exploit these vulnerabilities.

Effective use of Cisco Intrusion Prevention System (IPS) event actions provides visibility into and protection against attacks that attempt to exploit these vulnerabilities.

Cisco IOS NetFlow records can provide visibility into network-based exploitation attempts.

Cisco IOS Software, Cisco ASA, and FWSM firewalls can provide visibility through syslog messages and counter values displayed in the output from show commands.

The Cisco Security Monitoring, Analysis, and Response System (Cisco Security MARS) appliance can also provide visibility through incidents, queries, and event reporting

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of these vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

caution Caution:  The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Infrastructure Access Control Lists

To protect infrastructure devices and minimize the risk, impact, and effectiveness of direct infrastructure attacks, administrators are advised to deploy infrastructure access control lists (iACLs) to perform policy enforcement of traffic sent to infrastructure equipment. Administrators can construct an iACL by explicitly permitting only authorized traffic sent to infrastructure devices in accordance with existing security policies and configurations. For the maximum protection of infrastructure devices, deployed iACLs should be applied in the ingress direction on all interfaces to which an IP address has been configured. An iACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The iACL policy denies unauthorized SIP packets on TCP and UDP port 5060 and SIP-TLS on TCP and UDP port 5061 that are sent to affected devices. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 is the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8:1:100::1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic. Whenever possible, infrastructure address space should be distinct from the address space used for user and services segments. Using this addressing methodology will assist with the construction and deployment of iACLs.

Additional information about iACLs is in Protecting Your Core: Infrastructure Protection Access Control Lists.

 ip access-list extended Infrastructure-ACL-Policy
 
  !
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable TCP and UDP ports
!
permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 !
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
deny tcp any 192.168.60.0 0.0.0.255 eq 5060 deny tcp any 192.168.60.0 0.0.0.255 eq 5061 deny udp any 192.168.60.0 0.0.0.255 eq 5060 deny udp any 192.168.60.0 0.0.0.255 eq 5061 !
!-- Explicit deny ACE for traffic sent to addresses configured within
!-- the infrastructure address space
!
deny ip any 192.168.60.0 0.0.0.255 !
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!
!-- Create the corresponding IPv6 tACL
!
ipv6 access-list IPv6-Infrastructure-ACL-Policy !
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocols and ports
!
permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 !
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks to global and
!-- link local addresses
!
deny tcp any 2001:DB8:1:60::/64 eq 5060 deny tcp any 2001:DB8:1:60::/64 eq 5061 deny udp any 2001:DB8:1:60::/64 eq 5060 deny udp any 2001:DB8:1:60::/64 eq 5061 !
!-- Permit other required traffic to the infrastructure address
!-- range and allow IPv6 Neighbor Discovery packets, which
!-- include Neighbor Solicitation packets and Neighbor
!-- Advertisement packets
!
permit icmp any any nd-ns permit icmp any any nd-na !
!-- Explicit deny for all other IPv6 traffic to the global
!-- infrastructure address range
!
deny ipv6 any 2001:DB8:1:60::/64 !
!-- Permit or deny all other Layer 3 and Layer 4 traffic
!-- in accordance with existing security policies and configurations
!
!
!-- Apply tACLs to interfaces in the ingress direction
!
interface GigabitEthernet0/0 ip access-group Infrastructure-ACL-Policy in ipv6 traffic-filter IPv6-Infrastructure-ACL-Policy in

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration command no ip unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration command ip icmp rate-limit unreachable interval-in-ms.

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy transit access control lists (tACLs) to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized SIP packets on TCP and UDP port 5060 and SIP-TLS on TCP and UDP port 5061 that are sent to affected devices. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 is the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8:1:100::1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.


!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable TCP and UDP ports
!
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061
!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 5060 access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 5061 access-list 150 deny udp any 192.168.60.0 0.0.0.255 eq 5060 access-list 150 deny udp any 192.168.60.0 0.0.0.255 eq 5061 !
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
access-list 150 deny ip any any !
!-- Create the corresponding IPv6 tACL
!
ipv6 access-list IPv6-Transit-ACL-Policy !
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable TCP and UDP ports
!
permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 !
!-- The following vulnerability-specific ACEs can
!-- aid in identification of attacks to global and
!-- link local addresses
!
deny tcp any 2001:DB8:1:60::/64 eq 5060 deny tcp any 2001:DB8:1:60::/64 eq 5061 deny udp any 2001:DB8:1:60::/64 eq 5060 deny udp any 2001:DB8:1:60::/64 eq 5061 !
!-- Permit or deny all other Layer 3 and Layer 4 traffic in
!-- accordance with existing security policies and configurations
!-- and allow IPv6 Neighbor Discovery packets, which
!-- include Neighbor Solicitation packets and Neighbor
!-- Advertisement packets
!
permit icmp any any nd-ns permit icmp any any nd-na !
!-- Explicit deny for all other IPv6 traffic
!
deny ipv6 any any !
!-- Apply tACLs to interfaces in the ingress direction
!
interface GigabitEthernet0/0 ip access-group 150 in ipv6 traffic-filter IPv6-Transit-ACL-Policy in

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration command no ip unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration command ip icmp rate-limit unreachable interval-in-ms.

Mitigation: Spoofing Protection

Unicast Reverse Path Forwarding

The vulnerabilities that are described in this document can be exploited by spoofed IP packets. Administrators can deploy and configure Unicast Reverse Path Forwarding (Unicast RPF) as a protection mechanism against spoofing.

Unicast RPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on Unicast RPF to provide complete spoofing protection because spoofed packets may enter the network through a Unicast RPF-enabled interface if an appropriate return route to the source IP address exists. Administrators are advised to ensure that the appropriate Unicast RPF mode (loose or strict) is configured during the deployment of this feature because the feature can drop legitimate traffic that is transiting the network. In an enterprise environment, Unicast RPF might be enabled at the Internet edge and the internal access layer on the user-supporting Layer 3 interfaces.

Additional information is in the Unicast Reverse Path Forwarding Loose Mode Feature Guide.

For additional information about the configuration and use of Unicast RPF, reference the Understanding Unicast Reverse Path Forwarding Applied Intelligence white paper.

IP Source Guard

IP source guard (IPSG) is a security feature that restricts IP traffic on non-routed, Layer 2 interfaces by filtering packets based on the DHCP snooping binding database and manually configured IP source bindings. Administrators can use IPSG to prevent attacks from an attacker who attempts to spoof packets by forging the source IP address and/or the MAC address. When properly deployed and configured, IPSG coupled with strict mode Unicast RPF provides the most effective means of spoofing protection for the vulnerabilities that are described in this document.

Additional information about the deployment and configuration of IPSG is in Configuring DHCP Features and IP Source Guard.

Identification: Infrastructure Access Control Lists

After the administrator applies the iACL to an interface, the show ip access-lists and show ipv6 access-list commands will identify the number of SIP packets on TCP and UDP port 5060 and SIP-TLS on TCP and UDP port 5061 that have been filtered on interfaces on which the iACL is applied. Administrators should investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ip access-lists Infrastructure-ACL-Policy follows:

router#show ip access-lists Infrastructure-ACL-Policy
Extended IP access list Infrastructure-ACL-Policy
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 (60 matches)
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 (41 matches)
    30 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 (188 matches)
    40 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 (51 matches)
    50 deny tcp any 192.168.60.0 0.0.0.255 eq 5060 (9 matches)
    60 deny tcp any 192.168.60.0 0.0.0.255 eq 5061 (18 matches)
    70 deny udp any 192.168.60.0 0.0.0.255 eq 5060 (34 matches)
    80 deny udp any 192.168.60.0 0.0.0.255 eq 5061 (72 matches)
    90 deny ip any 192.168.60.0 0.0.0.255 (17 matches)
router#

In the preceding example, access list Infrastructure-ACL-Policy has dropped the following packets that are received from an untrusted host or network:

  • 9 SIP packets on TCP port 5060 for ACE line 50
  • 18 SIP packets on TCP port 5061 for ACE line 60
  • 34 SIP packets on UDP port 5060 for ACE line 70
  • 72 SIP packets on UDP port 5061 for ACE line 80
router#show ipv6 access-list IPv6-Infrastructure-ACL-Policy 
IPv6 access list IPv6-Infrastructure-ACL-Policy
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 
      (71 matches) sequence 10
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 
      (85 matches) sequence 20
    permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 
      (512 matches) sequence 30
    permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 
      (171 matches) sequence 40
    deny tcp any 2001:DB8:1:60::/64 eq 5060 (58 matches) sequence 50
    deny tcp any 2001:DB8:1:60::/64 eq 5061 (81 matches) sequence 60
    deny udp any 2001:DB8:1:60::/64 eq 5060 (216 matches) sequence 70
    deny udp any 2001:DB8:1:60::/64 eq 5061 (114 matches) sequence 80
    permit icmp any any nd-ns (80 matches) sequence 90
    permit icmp any any nd-na (80 matches) sequence 100
    deny ipv6 any 2001:DB8:1:60::/64 (5 matches) sequence 110

In the preceding example, access list IPv6-Infrastructure-ACL-Policy has dropped the following

  • 58 SIP packets on TCP port 5060 for ACE line 50
  • 81 SIP packets on TCP port 5061 for ACE line 60
  • 216 SIP packets on UDP port 5060 for ACE line 70
  • 114 SIP packets on UDP port 5061 for ACE line 80

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Applied Intelligence white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Applied Intelligence white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: Transit Access Control Lists

After the administrator applies the tACL to an interface, show ip access-lists and show ipv6 access-list commands will identify the number of SIP packets on TCP and UDP port 5060 and SIP-TLS on TCP and UDP port 5061 that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ip access-lists 150 follows:

router#show ip access-lists 150
Extended IP access list 150
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 (131 matches)
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 (71 matches)
    30 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060 (510 matches)
    40 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5061 (174 matches)
    50 deny tcp any 192.168.60.0 0.0.0.255 eq 5060 (42 matches)
    60 deny tcp any 192.168.60.0 0.0.0.255 eq 5061 (37 matches)
    70 deny udp any 192.168.60.0 0.0.0.255 eq 5060 (128 matches)
    80 deny udp any 192.168.60.0 0.0.0.255 eq 5061 (31 matches)
    90 deny ip any any (44 matches)
router#

In the preceding example, access list 150 has dropped the following packets that are received from an untrusted host or network:

  • 42 SIP packets on TCP port 5060 for ACE line 50
  • 37 SIP packets on TCP port 5061 for ACE line 60
  • 128 SIP packets on UDP port 5060 for ACE line 70
  • 31 SIP packets on UDP port 5061 for ACE line 80
router#show ipv6 access-list IPv6-Transit-ACL-Policy 
IPv6 access list IPv6-Transit-ACL-Policy
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 
      (55 matches) sequence 10
    permit tcp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 
      (38 matches) sequence 20
    permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5060 
      (210 matches) sequence 30
    permit udp host 2001:DB8:1:100::1 2001:DB8:1:60::/64 eq 5061 
      (59 matches) sequence 40
    deny tcp any 2001:DB8:1:60::/64 eq 5060 (30 matches) sequence 50
    deny tcp any 2001:DB8:1:60::/64 eq 5061 (41 matches) sequence 60
    deny udp any 2001:DB8:1:60::/64 eq 5060 (310 matches) sequence 70
    deny udp any 2001:DB8:1:60::/64 eq 5061 (131 matches) sequence 80
    permit icmp any any nd-ns (41 matches) sequence 90
    permit icmp any any nd-na (41 matches) sequence 100
    deny ipv6 any any (21 matches) sequence 110
    

In the preceding example, access list IPv6-Transit-ACL-Policy has dropped the following packets that are received from an untrusted host or network:

  • 30 SIP packets on TCP port 5060 for ACE line 50
  • 41 SIP packets on TCP port 5061 for ACE line 60
  • 310 SIP packets on UDP port 5060 for ACE line 70
  • 131 SIP packets on UDP port 5061 for ACE line 80

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Applied

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Applied Intelligence white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: Access List Logging

The log and log-input access control list (ACL) option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

For Cisco IOS Software, the ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by ACL logging. The logging rate-limit rate-per-second [except loglevel] command limits the impact of log generation and transmission.

The CPU impact from ACL logging can be addressed in hardware on the Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging.

For additional information about the configuration and use of ACL logging, reference the Understanding Access Control List Logging Applied Intelligence white paper.

Identification: Spoofing Protection Using Unicast Reverse Path Forwarding

With Unicast RPF properly deployed and configured throughout the network infrastructure, administrators can use the show cef interface type slot/port internal, show ip interface, show cef drop, show ip cef switching statistics feature and show ip traffic commands to identify the number of packets that Unicast RPF has dropped.

Note: Beginning with Cisco IOS Software version 12.4(20)T, the command show ip cef switching has been replaced by show ip cef switching statistics feature.

Note: The show command | begin regex and show command | include regex command modifiers are used in the following examples to minimize the amount of output that administrators will need to parse to view the desired information. Additional information about command modifiers is in the show command sections of the Cisco IOS Configuration Fundamentals Command Reference.

router#show cef interface GigabitEthernet 0/0 internal | include drop

  ip verify: via=rx (allow default), acl=0, drop=18, sdrop=0
router#

Note: show cef interface type slot/port internal is a hidden command that must be fully entered at the command-line interface. Command completion is not available for it.

router#show ip interface GigabitEthernet 0/0 | begin verify

  IP verify source reachable-via RX, allow default, allow self-ping
  18 verification drops
  0 suppressed verification drops
router#


router#show cef drop
CEF Drop Statistics
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj  ChkSum_Err
RP            27           0           0          18           0           0
router#

router#show ip cef switching statistics feature
IPv4 CEF input features:
Path   Feature                Drop    Consume       Punt  Punt2Host Gave route
RP PAS uRPF                     18          0          0          0          0
Total                           18          0          0          0          0
    --      CLI Output Truncated       --  
router#


router#show ip traffic | include RPF
         18 no route, 18 unicast RPF, 0 forced drop
router#

In the preceding show cef drop, show ip cef switching statistics feature and show ip traffic examples, Unicast RPF has dropped 18 IP packets that have been received globally on all interfaces with Unicast RPF configured because of the inability to verify the source address of the IP packets in the Forwarding Information Base of Cisco Express Forwarding.

Cisco IOS NetFlow

Identification: Traffic Flow Identification Using NetFlow Records

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of traffic flows that may be attempts to exploit these vulnerabilities. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

router#show ip cache flow
IP packet size distribution (90784136 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .698 .011 .001 .004 .005 .000 .004 .000 .000 .003 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .001 .256 .000 .010 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  1885 active, 63651 inactive, 59960004 added
  129803821 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  0 active, 16384 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet    11393421      2.8         1    48      3.1       0.0       1.4
TCP-FTP            236      0.0        12    66      0.0       1.8       4.8
TCP-FTPD            21      0.0     13726  1294      0.0      18.4       4.1
TCP-WWW          22282      0.0        21  1020      0.1       4.1       7.3
TCP-X              719      0.0         1    40      0.0       0.0       1.3
TCP-BGP              1      0.0         1    40      0.0       0.0      15.0
TCP-Frag         70399      0.0         1   688      0.0       0.0      22.7
TCP-other     47861004     11.8         1   211     18.9       0.0       1.3
UDP-DNS            582      0.0         4    73      0.0       3.4      15.4
UDP-NTP         287252      0.0         1    76      0.0       0.0      15.5
UDP-other       310347      0.0         2   230      0.1       0.6      15.9
ICMP             11674      0.0         3    61      0.0      19.8      15.5
IPv6INIP            15      0.0         1  1132      0.0       0.0      15.4
GRE                  4      0.0         1    48      0.0       0.0      15.3 
Total:        59957957     14.8         1   196     22.5       0.0       1.5

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.11.54   Gi0/1         192.168.60.144  06 0911 13C5     3
Gi0/1         192.168.150.161 Gi0/0         10.89.18.16     06 0016 22C2     1
Gi0/0         192.168.60.97   Gi0/1         192.168.60.228  11 2B3E 13C4     5
Gi0/0         192.168.60.17   Gi0/1         192.168.60.197  11 2B89 13C5     1
Gi0/0         10.88.222.16    Gi0/1         192.168.202.222 11 007B 007B     1
Gi0/0         192.168.12.185  Gi0/1         192.168.60.239  06 3BD7 13C4     1
Gi0/0         10.89.16.226    Gi0/1         192.168.150.160 06 12CA 0016     1
Gi0/0         192.168.40.101  Gi0/1         192.168.60.102  11 1A84 00A1     1
Gi0/0         192.168.10.64   Gi0/1         192.168.60.158  06 3931 13C5     3
Gi0/1         192.168.150.60  Gi0/0         10.89.16.226    06 0016 12CA     1
Gi0/0         192.168.60.97   Gi0/1         192.168.60.27   11 1039 13C4     5
Gi0/0         192.168.10.17   Gi0/1         192.168.60.97   06 0B40 13C5     1
Gi0/0         10.88.226.1     Gi0/1         192.168.150.22  11 007B 007B     1
Gi0/0         10.89.160.226   Gi0/1         192.168.150.60  06 4322 0016     1
router#

In the preceding example, there are multiple flows for SIP on TCP and UDP port 5060 (hex value 13C4) and SIP TLS on TCP and UDP port 5061 (hex value 13C5) .

The SIP packets on UDP port 5060 and SIP-TLS packets on UDP port 5061 are sourced from and sent to addresses within the 192.168.60.0/24 address block that is used by affected devices. The packets in the UDP flows may be spoofed and could indicate an attempt to exploit these vulnerabilities. Administrators are advised to compare these flows to baseline utilization for SIP traffic sent on UDP port 5060 and SIP-TLS traffic sent on UDP port 5061 and also investigate the flows to determine whether they are sourced from untrusted hosts or networks.

To view only the traffic flows for SIP packets on TCP port 5060 (hex value 13C4) and SIP-TLS packets on TCP port 5061 (hex value 13C5), the command show ip cache flow | include SrcIf|_06_.*(13C4|13C5)_ will display the related TCP NetFlow records as shown in the following example:

TCP Flows

router#show ip cache flow | include SrcIf|_06_.*(13C4|13C5)_
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.102.117  Gi0/1         192.168.60.136  06 4567 13C5     6
Gi0/0         192.168.18.100   Gi0/1         192.168.60.205  06 1C99 13C5    78
Gi0/0         192.168.133.70   Gi0/1         192.168.60.182  06 2487 13C4     1
router#

To view only the traffic flows for SIP packets on UDP port 5060 (hex value 13C4) and SIP-TLS packets on UDP port 5061 (hex value 13C5), the command show ip cache flow | include SrcIf|_11_.*(13C4|13C5)_ will display the related UDP NetFlow records as shown in the following example:

UDP Flows

router#show ip cache flow | include SrcIf|_11_.*(13C4|13C5)_
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.60.110   Gi0/1         192.168.60.163  11 04AA 13C4     6
Gi0/0         192.168.60.230   Gi0/1         192.168.60.20   11 189D 13C5     1
Gi0/0         192.168.60.131   Gi0/1         192.168.60.245  11 2983 13C4    18
Gi0/0         192.168.60.7     Gi0/1         192.168.60.162  11 4098 13C5     1
Gi0/0         192.168.60.86    Gi0/1         192.168.60.27   11 1089 13C4     2
router#

Identification: Traffic Flow Identification Using IPv6 NetFlow Records

Administrators can configure Cisco IOS IPv6 NetFlow on Cisco IOS routers and switches to aid in the identification of traffic flows that may be attempts to exploit the vulnerabilities that are described in this document. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

This output is from a Cisco IOS device running Cisco IOS software 12.4 mainline train. The command syntax will vary for different Cisco IOS software trains.

router#show ipv6 flow cache
IP packet size distribution (50078919 total packets):
   1-32  64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .990 .001 .008 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 475168 bytes
  8 active, 4088 inactive, 6160 added
  1092984 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33928 bytes
  16 active, 1008 inactive, 12320 added, 6160 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x11 0x16C4 0x13C4 1464
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...134::3 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::4 Gi0/1    0x3A 0x0000 0x8000 1192    
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x13C4 1597
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x11 0x1610 0x13C5 1001  
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x11 0x1634 0x13C4 1292  
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::3 Gi0/1    0x3A 0x0000 0x8000 1155
2001:DB...6A:5BA6 Gi0/0    2001:DB...146::3 Gi0/1    0x3A 0x0000 0x8000 1092
2001:DB...6A:5BA6 Gi0/0    2001:DB...144::4 Gi0/1    0x3A 0x0000 0x8000 1193  

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

In the preceding example, there are multiple IPv6 flows for SIP on TCP and UDP port 5060 (hex value 13C4) and SIP-TLS on TCP and UDP port 5061 (hex value 13C5).

The SIP packets on UDP port 5060 and SIP-TLS packets on UDP port 5061 are sourced from and sent to addresses within the 2001:DB8:1:60::/64 address block that is used by affected devices. The packets in the UDP flows may be spoofed and could indicate an attempt to exploit these vulnerabilities. Administrators are advised to compare these flows to baseline utilization for SIP traffic on UDP port 5060 and SIP-TLS traffic on UDP port 5061 and also investigate the flows to determine whether they are sourced from untrusted hosts or networks.

As shown in the following example, to view only the SIP packets on TCP port 5060 (hex value 13C4) and SIP-TLS packets on TCP port 5061 (hex value 13C5) use the show ipv6 flow cache | include SrcAddress|_06_.*(13C4|13C5)_ command to display the related NetFlow records:

TCP Flows

router#show ipv6 flow cache | include SrcIf|_06_.*(13C4|13C5)_

SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x13C4 1597
router#

As shown in the following example, to view only SIP packets on UDP port 5060 (hex value 13C4) and SIP-TLS packets on UDP port 5061 (hex value 13C5) use the show ipv6 flow cache | include SrcAddress|_11_.*(13C4|13C5)_ command to display the related NetFlow records:

UDP Flows

router#show ip cache flow | include SrcIf|_11_.*(13C4|13C5)_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x11 0x16C4 0x13C4 1464 
2001:DB...06::201 Gi0/0 2001:DB...128::3 Gi0/1 0x11 0x1610 0x13C5 1001
2001:DB...06::201 Gi0/0 2001:DB...128::4 Gi0/1 0x11 0x1634 0x13C4 1292
router#

Cisco ASA and FWSM Firewalls

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized SIP packets on TCP and UDP port 5060 and SIP-TLS on TCP and UDP port 5061 that are sent to affected devices. In the following example, 192.168.60.0/24 is the IP address space that is used by the affected devices, and the host at 192.168.100.1 is considered a trusted source that requires access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.


!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable TCP and UDP ports
!
access-list tACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq sip access-list tACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 eq 5061 access-list tACL-Policy extended permit udp host 192.168.100.1 192.168.60.0 255.255.255.0 eq sip access-list tACL-Policy extended permit udp host 192.168.100.1 192.168.60.0 255.255.255.0 eq 5061 !
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq sip access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 5061 access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 eq sip access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 eq 5061 !
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
access-list tACL-Policy extended deny ip any any !
!-- Create the corresponding IPv6 tACL
!
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8:1:100::1 2001:db8:1:60::/64 eq 5060 ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8:1:100::1 2001:db8:1:60::/64 eq 5061 ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8:1:100::1 2001:db8:1:60::/64 eq 5060 ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8:1:100::1 2001:db8:1:60::/64 eq 5061 !
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 5060 ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 5061 ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 eq 5060 ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 eq 5061 !
!-- Permit/deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
ipv6 access-list IPv6-tACL-Policy deny ip any any !
!-- Apply tACLs to interfaces in the ingress direction
!
access-group tACL-Policy in interface outside access-group IPv6-tACL-Policy in interface outside

Mitigation: Spoofing Protection using Unicast Reverse Path Forwarding

The vulnerabilities that are described in this document can be exploited by spoofed IP packets. Administrators can deploy and configure Unicast RPF as a protective mechanism against spoofing.

Unicast RPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on Unicast RPF to provide complete spoofing protection because spoofed packets may enter the network through a Unicast RPF-enabled interface if an appropriate return route to the source IP address exists. In an enterprise environment, Unicast RPF might be enabled at the Internet edge and at the internal access layer on the user-supporting Layer 3 interfaces.

For additional information about the configuration and use of Unicast RPF, reference the Cisco Security Appliance Command Reference for ip verify reverse-path and the Understanding Unicast Reverse Path Forwarding Applied Intelligence white paper.

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the number of SIP packets on TCP and UDP port 5060 and SIP-TLS on TCP and UDP port 5061 that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show access-list tACL-Policy follows:

firewall#show access-list tACL-Policy
access-list tACL-Policy; 9 elements
access-list tACL-Policy line 1 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq sip (hitcnt=31)
access-list tACL-Policy line 2 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 5061 (hitcnt=61)
access-list tACL-Policy line 3 extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq sip (hitcnt=131)
access-list tACL-Policy line 4 extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 5061 (hitcnt=57)
access-list tACL-Policy line 5 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq sip (hitcnt=8)
access-list tACL-Policy line 6 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq 5061 (hitcnt=14)
access-list tACL-Policy line 7 extended deny udp any 192.168.60.0 
     255.255.255.0 eq sip (hitcnt=30)
access-list tACL-Policy line 8 extended deny udp any 192.168.60.0 
     255.255.255.0 eq 5061 (hitcnt=13) 
access-list tACL-Policy line 9 extended deny ip any any (hitcnt=8)

firewall#

In the preceding example, access list tACL-Policy has dropped the following packets received from an untrusted host or network:

  • 8 SIP packets on TCP port 5060 for ACE line 5
  • 14 SIP packets on TCP port 5061 for ACE line 6
  • 30 SIP packets on UDP port 5060 for ACE line 7
  • 13 SIP packets on UDP port 5061 for ACE line 8
firewall#show access-list IPv6-tACL-Policy                 
ipv6 access-list IPv6-tACL-Policy; 9 elements; name hash: 0x566a4229
ipv6 access-list IPv6-tACL-Policy line 1 permit tcp host 
     2001:db8:1:100::1 2001:db8:1:60::/64 eq sip (hitcnt=59) 
ipv6 access-list IPv6-tACL-Policy line 2 permit tcp host 
     2001:db8:1:100::1 2001:db8:1:60::/64 eq 5061 (hitcnt=28) 
ipv6 access-list IPv6-tACL-Policy line 3 permit udp host 
     2001:db8:1:100::1 2001:db8:1:60::/64 eq sip (hitcnt=124) 
ipv6 access-list IPv6-tACL-Policy line 4 permit udp host 
     2001:db8:1:100::1 2001:db8:1:60::/64 eq 5061 (hitcnt=81) 
ipv6 access-list IPv6-tACL-Policy line 5 deny tcp any 
     2001:db8:1:60::/64 eq sip (hitcnt=47)
ipv6 access-list IPv6-tACL-Policy line 6 deny tcp any 
     2001:db8:1:60::/64 eq 5061 (hitcnt=33) 
ipv6 access-list IPv6-tACL-Policy line 7 deny udp any 
     2001:db8:1:60::/64 eq sip (hitcnt=216) 
ipv6 access-list IPv6-tACL-Policy line 8 deny udp any 
     2001:db8:1:60::/64 eq 5061 (hitcnt=137) 
ipv6 access-list IPv6-tACL-Policy line 9 deny ip any any (hitcnt=27)

In the preceding example, access list IPv6-tACL-Policy has dropped the following packets that are received from an untrusted host or network:

  • 47 SIP packets on TCP port 5060 for ACE line 5
  • 33 SIP packets on TCP port 5061 for ACE line 6
  • 216 SIP packets on UDP port 5060 for ACE line 7
  • 137 SIP packets on UDP port 5061 for ACE line 8

Identification: Firewall Access List Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an access control entry (ACE) that does not have the log keyword present. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

firewall#show logging | grep 106023
  Sep 28 2011 00:10:03: %ASA-4-106023: Deny udp src outside:192.0.2.18/2944 
         dst inside:192.168.60.191/5060 by access-group "tACL-Policy"
  Sep 28 2011 00:11:53: %ASA-4-106023: Deny tcp src outside:192.0.2.99/2946 
         dst inside:192.168.60.240/5061 by access-group "tACL-Policy"
  Sep 28 2011 00:12:28: %ASA-4-106023: Deny tcp src outside:192.0.2.100/2947 
         dst inside:192.168.60.115/5060 by access-group "tACL-Policy"
  Sep 28 2011 00:13:10: %ASA-4-106023: Deny udp src outside:192.0.2.88/2949 
         dst inside:192.168.60.38/5060 by access-group "tACL-Policy"
  Sep 28 2011 00:14:13: %ASA-4-106023: Deny udp src outside:192.0.2.175/2950 
         dst inside:192.168.60.250/5061 by access-group "tACL-Policy"
firewall#

In the preceding example, the messages logged for the tACL tACL-Policy show potentially spoofed SIP packets on UDP port 5060 and SIP-TLS packets on UDP port 5061 that have been sent to the address block assigned to affected devices.

Additional information about syslog messages for ASA security appliances is in Cisco ASA 5500 Series System Log Messages, 8.2. Additional information about syslog messages for the FWSM is in Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Logging System Log Messages.

For additional information about investigating incidents using syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Applied Intelligence white paper.

Identification: Spoofing Protection Using Unicast Reverse Path Forwarding

Firewall syslog message 106021 will be generated for packets denied by Unicast RPF. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106021.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series switches and Cisco 7600 Series routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

firewall#show logging | grep 106021
  Sep 28 2011 00:15:13: %ASA-1-106021: Deny UDP reverse path check from
         192.168.60.1 to 192.168.60.100 on interface outside
  Sep 28 2011 00:15:13: %ASA-1-106021: Deny UDP reverse path check from
         192.168.60.1 to 192.168.60.100 on interface outside
  Sep 28 2011 00:15:13: %ASA-1-106021: Deny UDP reverse path check from
         192.168.60.1 to 192.168.60.100 on interface outside

The show asp drop command can also identify the number of packets that the Unicast RPF feature has dropped, as shown in the following example:

firewall#show asp drop frame rpf-violated
Reverse-path verify failed 11
firewall#

In the preceding example, Unicast RPF has dropped 11 IP packets received on interfaces with Unicast RPF configured. Absence of output indicates that the Unicast RPF feature on the firewall has not dropped packets.

For additional information about debugging accelerated security path dropped packets or connections, reference the Cisco Security Appliance Command Reference for show asp drop.

Cisco Intrusion Prevention System

Mitigation: Cisco IPS Signature Event Actions

Administrators can use Cisco Intrusion Prevention System (IPS) appliances and services modules to provide threat detection and help prevent attempts to exploit the vulnerabilities that are described in this document. These vulnerabilities may be detected by the following signatures:

  • 25999-0 - Malformed SIP Packet Denial of Service
  • 32379-0 - Cisco Unified Communications Manager SIP Denial Of Service
  • 34445-0 - Cisco IOS SIP Vulnerability

25999-0 - Malformed SIP Packet Denial of Service

Beginning with signature update S490 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 25999/0 (Signature Name: Malformed SIP Packet Denial of Service). Signature 25999/0 is enabled by default, triggers a High severity event, has a signature fidelity rating (SFR) of 85, and is configured with a default event action of produce-alert.

Signature 25999/0 fires when an attempt to exploit a Session Initiation Protocol (SIP) packet processing vulnerability is detected. Firing of this signature may indicate a potential exploit of this vulnerability.

32379-0 - Cisco Unified Communications Manager SIP Denial of Service

Beginning with signature update S598 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 32379/0 (Signature Name: Cisco Unified Communications Manager SIP Denial of Service). Signature 32379/0 is enabled by default, triggers a High severity event, has a signature fidelity rating (SFR) of 90, and is configured with a default event action of produce-alert.

Signature 32379/0 fires when an attempt to exploit a Session Initiation Protocol (SIP) packet processing vulnerability over UDP is detected. Firing of this signature may indicate a potential exploit of this vulnerability.

34445-0 - Cisco IOS SIP Vulnerability

Beginning with signature update S598 for sensors running Cisco IPS version 6.x and greater, these vulnerabilities can be detected by signature 34445/0 (Signature Name: Cisco IOS SIP Vulnerability). Signature 34445/0 is enabled by default, triggers a Medium severity event, has a signature fidelity rating (SFR) of 90, and is configured with a default event action of produce-alert.

Signature 34445/0 fires upon detecting an attempt to exploit a SIP vulnerability in Cisco IOS software. Firing of this signature may indicate a potential exploit of this vulnerability.

Administrators can configure Cisco IPS sensors to perform an event action when an attack is detected. The configured event action performs preventive or deterrent controls to help protect against an attack that is attempting to exploit the vulnerabilities that are described in this document.

Exploits that use spoofed IP addresses may cause a configured event action to inadvertently deny traffic from trusted sources.

Cisco IPS sensors are most effective when deployed using inline protection mode combined with the use of an event action. Automatic Threat Prevention for Cisco IPS 6.x and greater sensors that are deployed using inline protection mode provides threat prevention against an attack that is attempting to exploit the vulnerabilities that are described in this document. Threat prevention is achieved through a default override that performs an event action for triggered signatures with a riskRatingValue greater than 90.

For additional information about the risk rating and threat rating calculation, reference Risk Rating and Threat Rating: Simplify IPS Policy Management.

Cisco Security Monitoring, Analysis, and Response System

Identification: Cisco Security Monitoring, Analysis, and Response System Incidents

The Cisco Security Monitoring, Analysis, and Response System (Cisco Security MARS) appliance can create incidents for events that are related to the vulnerabilities that are described in this document using the following IPS signatures:

  • 25999/0 (Malformed SIP Packet Denial of Service)
  • 32379/0 (Signature Name: Cisco Unified Communications Manager SIP Denial Of Service)
  • 34445/0 (Signature Name: Cisco IOS SIP Vulnerability)

After the S598 dynamic signature update has been downloaded using keyword NR-25999 for IPS signature 25999/0, NR-32379 for IPS signature 32379/0 or NR-34445 for IPS signature 34445/0 and a query type of All Matching Event Raw Messages, the Cisco Security MARS appliance will provide a report that lists the incidents created by that IPS signature.

Beginning with the 4.3.1 and 5.3.1 releases of Cisco Security MARS appliances, support for the Cisco IPS dynamic signature updates feature has been added. This feature downloads new signatures from Cisco.com or from a local web server, correctly processes and categorizes received events that match those signatures, and includes them in inspection rules and reports. These updates provide event normalization and event group mapping, and they also enable the MARS appliance to parse new signatures from the IPS devices.

caution Caution:  If dynamic signature updates are not configured, events that match these new signatures appear as unknown event type in queries and reports. Because MARS will not include these events in inspection rules, incidents may not be created for potential threats or attacks that occur within the network.

By default, this feature is enabled but requires configuration. If it is not configured, the following Cisco Security MARS rule will be triggered: System Rule:

CS-MARS IPS Signature Update Failure

When this feature is enabled and configured, administrators can determine the current signature version downloaded by MARS by selecting Help > About and reviewing the IPS Signature Version value.

Additional information about dynamic signature updates and instructions for configuring dynamic signature updates are available for the Cisco Security MARS 4.3.1 and 5.3.1 releases.

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Revision History

Revision 1.0

2011-September-28

Initial public release

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information


Download this document (PDF)
View Printable Version