Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Security Advisory

Cisco IOS Software IPS and Zone Based Firewall Vulnerabilities

Advisory ID: cisco-sa-20110928-zbfw

http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20110928-zbfw

Revision 1.2

Last Updated  2012 September 21 19:24  UTC (GMT)

For Public Release 2011 September 28 16:00  UTC (GMT)


Summary

Cisco IOS Software contains two vulnerabilities related to Cisco IOS Intrusion Prevention System (IPS) and Cisco IOS Zone-Based Firewall features. These vulnerabilities are:

  • Memory leak in Cisco IOS Software
  • Cisco IOS Software Denial of Service when processing specially crafted HTTP packets

Cisco has released free software updates that address these vulnerabilities.

Workarounds that mitigate these vulnerabilities are not available.

This advisory is posted at http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20110928-zbfw.

Note: The September 28, 2011, Cisco IOS Software Security Advisory bundled publication includes ten Cisco Security Advisories. Nine of the advisories address vulnerabilities in Cisco IOS Software, and one advisory addresses a vulnerability in Cisco Unified Communications Manager. Each advisory lists the Cisco IOS Software releases that correct the vulnerability or vulnerabilities detailed in the advisory as well as the Cisco IOS Software releases that correct all vulnerabilities in the September 2011 Bundled Publication.

Individual publication links are in "Cisco Event Response: Semiannual Cisco IOS Software Security Advisory Bundled Publication" at the following link:

http://www.cisco.com/web/about/security/intelligence/Cisco_ERP_sep11.html

Affected Products

Vulnerable Products

Cisco IOS devices running vulnerable versions of Cisco IOS Software are affected by two vulnerabilities in Cisco IOS IPS and Cisco IOS Zone-Based Firewall. The two vulnerabilities are independent of each other. Details to confirm affected configurations are provided below.

  • Memory leak in Cisco IOS Software
    A device that is configured for either Cisco IOS IPS or Cisco IOS Zone-Based Firewall (or both), may experience a memory leak under high rates of new session creation flows through the device.
    To determine if a device is configured with Cisco IOS IPS, log into the device and issue the show ip ips interfaces CLI command. If the output shows an IPS rule either in the inbound or outbound direction set, then the device is vulnerable. This example, shows a device with an IPS rule set on Interface Gigabit Ethernet 0/0 in the inbound direction:
    Router#show ip ips interfaces
        Interface Configuration
          Interface GigabitEthernet0/0
            Inbound IPS rule is example_ips_rule
            Outgoing IPS rule is not set
    Router#
    A device that is not configured for Cisco IOS IPS will return a blank line. The following example shows a device on which Cisco IOS IPS is not configured:
    Router#show ip ips interfaces
    
    Router#
    
    To determine whether a device is configured with Zone-Based Firewall, log into the device and issue the show zone security CLI command. If the output shows a member interface under a zone name, then the device is vulnerable. This example, shows a device with Zone-Based Firewall rules configured on both GigabitEthernet0/0 and GigabitEthernet0/1
    Router#show zone security
    zone self
      Description: System defined zone
    
    
    zone inside
      Description: *** Inside Network ***
      Member Interfaces:
        GigabitEthernet0/0
    
    
    zone outside
      Description: *** Outside Network ***
      Member Interfaces:
        GigabitEthernet0/1
    
    
    Router#
    Note: The device is vulnerable if configured with Zone-Based Firewall, regardless of the type of packet inspection being performed.
  • Cisco IOS Software Denial of Service when processing specially crafted HTTP packets
    A device is vulnerable if configured under the following circumstances:
    - HTTP Layer 7 Application Control and Inspection and Cisco IOS IPS are enabled.
    - HTTP Layer 7 Application Control and Inspection with match request arg regex parameter on the HTTP class map. This configuration is affected regardless if Cisco IOS IPS is enabled or not.


    The device is not vulnerable under other configurations. A summary of different configurations and their affect by this vulnerability is provided below:

    Configuration on Device
    Affected or not Affected
    Only Cisco IOS IPS enabled
    Not Affected
    HTTP Layer 4 Stateful Inspection with Cisco IOS IPS enabled
    Not Affected
    HTTP Layer 4 Stateful Inspection with Cisco IOS IPS disabled
    Not Affected
    HTTP Layer 7 Application Control and Inspection with Cisco IOS IPS enabled
    Affected
    HTTP Layer 7 Application Control and Inspection with match arg regex parameter. With or without Cisco IOS IPS enabled.
    Affected
    HTTP Layer 7 Application Control and Inspection without match arg regex parameter. With or without Cisco IOS IPS enabled.
    Not Affected

    The following example shows an affected device configured with HTTP Layer 7 Application Control and Inspection and Cisco IOS IPS enabled:

    !
    ip ips name myips
    !
    ip ips signature-category
      category all
       retired true
      category ios_ips basic
       retired false
    !
    !
    class-map type inspect match-any layer4-classmap
     match protocol http
    !
    class-map type inspect http match-any layer7-classmap
      match  request arg length gt 15
    !
    !
    policy-map type inspect http layer7-policymap
     class type inspect http layer7-classmap
      reset
      log
    policy-map type inspect layer4-policymap
     class type inspect layer4-classmap
      inspect
      service-policy http layer7-policymap
     class class-default
      drop
    !
    zone security inside
     description ** Inside Network **
    zone security outside
     description ** Outside Network **
    zone-pair security in2out source inside destination outside
     description ** Zone Pair - inside to outside **
     service-policy type inspect layer4-policymap
    !
    !
    interface GigabitEthernet0/0
     ip address 192.168.0.6 255.255.255.0
     ip ips myips in
     zone-member security inside
    !
    interface GigabitEthernet0/1
     ip address 192.168.1.1 255.255.255.0
     zone-member security outside
    !
    The following example shows an affected device configured with HTTP Layer 7 Application Control and Inspection with the match request arg regex parameter on the HTTP class map:
    !
    parameter-map type regex example
     pattern [^\x00-\x80]
    !
    class-map type inspect match-any layer4-classmap
     match protocol http
    !
    class-map type inspect http match-any layer7-classmap
     match  request arg regex example
    !
    !
    policy-map type inspect http layer7-policymap
     class type inspect http layer7-classmap
      reset
      log
    policy-map type inspect layer4-policymap
     class type inspect layer4-classmap
      inspect
      service-policy http layer7-policymap
     class class-default
      drop
    !
    zone security inside
     description ** Inside Network **
    zone security outside
     description ** Outside Network **
    zone-pair security in2out source inside destination outside
     description ** Zone Pair - inside to outside **
     service-policy type inspect layer4-policymap
    !
    interface GigabitEthernet0/0
     ip address 192.168.0.6 255.255.255.0
     zone-member security inside
    !
    interface GigabitEthernet0/1
     ip address 192.168.1.1 255.255.255.0
     zone-member security outside
    !

To determine the Cisco IOS Software release that is running on a Cisco product, administrators can log in to the device and issue the show version command to display the system banner. The system banner confirms that the device is running Cisco IOS Software by displaying text similar to "Cisco Internetwork Operating System Software" or "Cisco IOS Software." The image name displays in parentheses, followed by "Version" and the Cisco IOS Software release name. Other Cisco devices do not have the show version command or may provide different output.

The following example identifies a Cisco product that is running Cisco IOS Software Release 15.0(1)M1 with an installed image name of C3900-UNIVERSALK9-M:

Router> show version
Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.0(1)M1, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Wed 02-Dec-09 17:17 by prod_rel_team

!--- output truncated

Additional information about Cisco IOS Software release naming conventions is available in the white paper Cisco IOS and NX-OS Software Reference Guide at http://www.cisco.com/web/about/security/intelligence/ios-ref.html.

Products Confirmed Not Vulnerable

The following products are confirmed not vulnerable:

  • Cisco PIX 500 Series Firewall
  • Cisco ASA 5500 Series Adaptive Security Appliance
  • Firewall Services Module (FWSM) for Catalyst 6500 Series Switches and 7600 Series Routers
  • Virtual Firewall (VFW) application on the multiservice blade (MSB) on the Cisco XR 12000 Series Router
  • Cisco ACE Application Control Engine Module
  • Cisco IOS devices configured with legacy Cisco IOS Firewall Support
  • Cisco IOS XR Software
  • Cisco IOS XE Software
  • Cisco IPS Appliances
  • Cisco Catalyst 6500 Series ASA Services Module
  • Content Based Access Control (CBAC)

No other Cisco products are currently known to be affected by these vulnerabilities.

Details

Firewalls are networking devices that control access to the network assets of an organization. Firewalls are often positioned at the entrance points of networks. Cisco IOS Software provides a set of security features that allow the configuration of a simple or elaborate firewall policy according to particular requirements.

Cisco IOS IPS is an inline, deep-packet inspection feature that effectively mitigates a wide range of network attacks.

Memory leak in Cisco IOS Software

Devices with affected configurations may observe a memory leak under high rates of new session creation flows through the device.

Logs may indicate a message similar to " *CCE: CCE 7 tuple table entry to add not malloced." or "CCE: CCE 7 tuple table adding data to invalid hash entry." when the device experiences this memory leak.

The output of show processes memory sorted will show an increasing amount of memory being held in the "Chunk Manager" process in the "Holding" column. The following example shows the output of the show processes memory sorted CLI command:
Router#show processes memory sorted
Processor Pool Total:  930768768 Used:   90497932 Free:  840270836
      I/O Pool Total:   12582912 Used:    6138704 Free:    6444208

 PID TTY  Allocated      Freed    Holding    Getbufs    Retbufs Process
   1   0  130499156   72333476   58304964          0          0 Chunk Manager
For this particular vulnerability applying Zone-Based Policy Firewall denial of service protection does not protect against the memory leak due to Cisco Bug ID CSCtq28732 (registered customers only) .

This vulnerability is documented in Cisco bug ID CSCti79848 (registered customers only) and has been assigned Common Vulnerabilities and Exposures (CVE) ID CVE-2011-3273.

Cisco IOS Software Denial of Service when processing specially crafted HTTP packets

Devices with affected configurations may hang or crash when processing a specially crafted HTTP packets.

If the device supports and is configured with scheduler isr-watchdog then the device will reset and reload if the vulnerability is exploited, rather than just hang. For more information on the scheduler isr-watchdog command consult the Cisco IOS Configuration Fundamentals Command Reference at the following link: http://www.cisco.com/en/US/docs/ios/fundamentals/command/reference/cf_r1.html#wp1079401

This vulnerability is documented in Cisco bug ID CSCto68554 (registered customers only) and has been assigned CVE ID CVE-2011-3281.

Vulnerability Scoring Details

Cisco has provided scores for the vulnerabilities in this advisory based on the Common Vulnerability Scoring System (CVSS). The CVSS scoring in this Security Advisory is done in accordance with CVSS version 2.0.

CVSS is a standards-based scoring method that conveys vulnerability severity and helps determine urgency and priority of response.

Cisco has provided a base and temporal score. Customers can then compute environmental scores to assist in determining the impact of the vulnerability in individual networks.

Cisco has provided an FAQ to answer additional questions regarding CVSS at
http://www.cisco.com/web/about/security/intelligence/cvss-qandas.html .

Cisco has also provided a CVSS calculator to help compute the environmental impact for individual networks at
http://intellishield.cisco.com/security/alertmanager/cvss .



CSCti79848

Calculate the environmental score of CSCti79848

CVSS Base Score - 7.8

Access Vector

Access Complexity

Authentication

Confidentiality Impact

Integrity Impact

Availability Impact

Network

Low

None

None

None

Complete

CVSS Temporal Score - 6.4

Exploitability

Remediation Level

Report Confidence

Functional

Official-Fix

Confirmed




CSCto68554

Calculate the environmental score of CSCto68554

CVSS Base Score - 7.8

Access Vector

Access Complexity

Authentication

Confidentiality Impact

Integrity Impact

Availability Impact

Network

Low

None

None

None

Complete

CVSS Temporal Score - 6.4

Exploitability

Remediation Level

Report Confidence

Functional

Official-Fix

Confirmed


Impact

Successful exploitation of these vulnerabilities may result in:

  • Memory leak in Cisco IOS Software
    The device may run out of memory resulting in instability or the device crashing.
  • Cisco IOS Software Denial of Service when processing specially crafted HTTP packets
    The device may crash or hang. If the device hangs, it will have to be power cycled to recover. If the device supports and is configured with scheduler isr-watchdog then the device will reset and reload if the vulnerability is exploited.
    For more information on the scheduler isr-watchdog command consult the Cisco IOS Configuration Fundamentals Command Reference at the following link: http://www.cisco.com/en/US/docs/ios/fundamentals/command/reference/cf_r1.html#wp1079401

Software Versions and Fixes

When considering software upgrades, also consult http://www.cisco.com/go/psirt and any subsequent advisories to determine exposure and a complete upgrade solution.

In all cases, customers should exercise caution to be certain the devices to be upgraded contain sufficient memory and that current hardware and software configurations will continue to be supported properly by the new release. If the information is not clear, contact the Cisco Technical Assistance Center (TAC) or your contracted maintenance provider for assistance.

Additionally, the Cisco IOS Software Checker is available on the Cisco Security Intelligence Operations (SIO) portal at http://tools.cisco.com/security/center/selectIOSVersion.x. It provides several features for checking which Security Advisories affect specified versions of Cisco IOS Software.

Cisco IOS Software

Each row of the following Cisco IOS Software table corresponds to a Cisco IOS Software train. If a particular train is vulnerable, the earliest releases that contain the fix are listed in the First Fixed Release For This Advisory column. The First Fixed Release for All Advisories in the September 2011 Bundled Publication column lists the earliest possible releases that correct all the published vulnerabilities in the Cisco IOS Software Security Advisory bundled publication. Cisco recommends upgrading to the latest available release, where possible.

Major Release

     Availability of Repaired Releases

Affected 12.0-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

There are no affected 12.0 based releases

Affected 12.1-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

12.1E

Not Vulnerable

12.2(18)SXF17b

Affected 12.2-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

12.2

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2B

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2BC

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2BW

Not vulnerable

Not vulnerable

12.2BX

Not vulnerable

Vulnerable; first fixed in Release 12.2SB

12.2BY

Not vulnerable

Not vulnerable

12.2BZ

Not vulnerable

Not vulnerable

12.2CX

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2CY

Not vulnerable

Not vulnerable

12.2CZ

Not vulnerable

Vulnerable; first fixed in Release 12.2SB

12.2DA

Not vulnerable

Not vulnerable

12.2DD

Not vulnerable

Not vulnerable

12.2DX

Not vulnerable

Not vulnerable

12.2EU

Not vulnerable

Not vulnerable

12.2EW

Not vulnerable

Releases up to and including 12.2(20)EW4 are not vulnerable.

12.2EWA

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2EX

Not vulnerable

12.2(55)EX3

12.2EY

Not vulnerable

12.2(58)EY

12.2EZ

Not vulnerable

Vulnerable; migrate to any release in 15.0SE

12.2FX

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2FY

Not vulnerable

Vulnerable; first fixed in Release 12.2EX

12.2FZ

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2IRA

Not vulnerable

Vulnerable; migrate to any release in 12.2IRG

12.2IRB

Not vulnerable

Vulnerable; migrate to any release in 12.2IRG

12.2IRC

Not vulnerable

Vulnerable; migrate to any release in 12.2IRG

12.2IRD

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IRE

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IRF

Not vulnerable

Vulnerable; migrate to any release in 12.2IRG

12.2IRG

Not vulnerable

Not vulnerable

12.2IXA

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IXB

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IXC

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IXD

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IXE

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IXF

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IXG

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2IXH

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2JA

Not vulnerable

Not vulnerable

12.2JK

Not vulnerable

Not vulnerable

12.2MB

Not vulnerable

Not vulnerable

12.2MC

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2MRA

Not vulnerable

Vulnerable; first fixed in Release 12.2SRD

12.2MRB

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2S

Not vulnerable

Releases prior to 12.2(30)S are vulnerable; Releases 12.2(30)S and later are not vulnerable. First fixed in Release 12.2SB

12.2SB

Not vulnerable

12.2(31)SB20

12.2(33)SB10

12.2SBC

Not vulnerable

Vulnerable; first fixed in Release 12.2SB

12.2SCA

Not vulnerable

Vulnerable; first fixed in Release 12.2SCC

12.2SCB

Not vulnerable

Vulnerable; first fixed in Release 12.2SCC

12.2SCC

Not vulnerable

12.2(33)SCC7

12.2SCD

Not vulnerable

12.2(33)SCD6

12.2SCE

Not vulnerable

12.2(33)SCE1

12.2(33)SCE2

12.2SCF

Not vulnerable

Not vulnerable

12.2SE

Not vulnerable

12.2(55)SE3

12.2(58)SE

12.2SEA

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2SEB

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2SEC

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2SED

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2SEE

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2SEF

Not vulnerable

Vulnerable; first fixed in Release 12.2SE

12.2SEG

Not vulnerable

Releases prior to 12.2(25)SEG4 are vulnerable; Releases 12.2(25)SEG4 and later are not vulnerable. First fixed in Release 12.2EX

12.2SG

Not vulnerable

Releases prior to 12.2(53)SG4 are vulnerable; Releases 12.2(53)SG4 and later are not vulnerable.

12.2SGA

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2SL

Not vulnerable

Not vulnerable

12.2SM

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2SO

Not vulnerable

Not vulnerable

12.2SQ

Not vulnerable

12.2(50)SQ3

12.2SRA

Not vulnerable

Vulnerable; first fixed in Release 12.2SRD

12.2SRB

Not vulnerable

Vulnerable; first fixed in Release 12.2SRD

12.2SRC

Not vulnerable

Vulnerable; first fixed in Release 12.2SRD

12.2SRD

Not vulnerable

12.2(33)SRD6

12.2SRE

Not vulnerable

12.2(33)SRE4

12.2STE

Not vulnerable

Not vulnerable

12.2SU

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2SV

Not vulnerable

Releases prior to 12.2(29a)SV are vulnerable; Releases 12.2(29a)SV and later are not vulnerable. Migrate to any release in 12.2SVD

12.2SVA

Not vulnerable

Not vulnerable

12.2SVC

Not vulnerable

Not vulnerable

12.2SVD

Not vulnerable

Not vulnerable

12.2SVE

Not vulnerable

Not vulnerable

12.2SW

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2SX

Not vulnerable

Vulnerable; first fixed in Release 12.2SXF

12.2SXA

Not vulnerable

Vulnerable; first fixed in Release 12.2SXF

12.2SXB

Not vulnerable

Vulnerable; first fixed in Release 12.2SXF

12.2SXD

Not vulnerable

Vulnerable; first fixed in Release 12.2SXF

12.2SXE

Not vulnerable

Vulnerable; first fixed in Release 12.2SXF

12.2SXF

Not vulnerable

12.2(18)SXF17b

12.2SXH

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2SXI

Not vulnerable

12.2(33)SXI6

12.2SXJ

Not vulnerable

12.2(33)SXJ1

12.2SY

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2SZ

Not vulnerable

Vulnerable; first fixed in Release 12.2SB

12.2T

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2TPC

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2XA

Not vulnerable

Not vulnerable

12.2XB

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2XC

Not vulnerable

Not vulnerable

12.2XD

Not vulnerable

Not vulnerable

12.2XE

Not vulnerable

Not vulnerable

12.2XF

Not vulnerable

Not vulnerable

12.2XG

Not vulnerable

Not vulnerable

12.2XH

Not vulnerable

Not vulnerable

12.2XI

Not vulnerable

Not vulnerable

12.2XJ

Not vulnerable

Not vulnerable

12.2XK

Not vulnerable

Not vulnerable

12.2XL

Not vulnerable

Not vulnerable

12.2XM

Not vulnerable

Not vulnerable

12.2XN

Not vulnerable

Not vulnerable

12.2XNA

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

12.2XNB

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

12.2XNC

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

12.2XND

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

12.2XNE

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

12.2XNF

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

12.2XO

Not vulnerable

Releases prior to 12.2(54)XO are vulnerable; Releases 12.2(54)XO and later are not vulnerable.

12.2XQ

Not vulnerable

Not vulnerable

12.2XR

Not vulnerable

Not vulnerable

12.2XS

Not vulnerable

Not vulnerable

12.2XT

Not vulnerable

Not vulnerable

12.2XU

Not vulnerable

Not vulnerable

12.2XV

Not vulnerable

Not vulnerable

12.2XW

Not vulnerable

Not vulnerable

12.2YA

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2YB

Not vulnerable

Not vulnerable

12.2YC

Not vulnerable

Not vulnerable

12.2YD

Not vulnerable

Not vulnerable

12.2YE

Not vulnerable

Not vulnerable

12.2YF

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YG

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YH

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YJ

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YK

Not vulnerable

Not vulnerable

12.2YL

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YM

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2YN

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YO

Not vulnerable

Not vulnerable

12.2YP

Not vulnerable

Not vulnerable

12.2YQ

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YR

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YS

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YT

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YU

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YV

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YW

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YX

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YY

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2YZ

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2ZA

Not vulnerable

Vulnerable; first fixed in Release 12.2SXF

12.2ZB

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2ZC

Not vulnerable

Not vulnerable

12.2ZD

Not vulnerable

Not vulnerable

12.2ZE

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2ZF

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2ZG

Not vulnerable

Not vulnerable

12.2ZH

Not vulnerable

Vulnerable; first fixed in Release 12.4

12.2ZJ

Not vulnerable

Not vulnerable

12.2ZL

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2ZP

Not vulnerable

Not vulnerable

12.2ZU

Not vulnerable

Vulnerable; first fixed in Release 12.2SXH

12.2ZX

Not vulnerable

Not vulnerable

12.2ZY

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

12.2ZYA

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

Affected 12.3-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

There are no affected 12.3 based releases

Affected 12.4-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

There are no affected 12.4 based releases

Affected 15.0-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

15.0M

15.0(1)M7

15.0(1)M7

15.0MR

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

15.0MRA

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

15.0S

Not vulnerable

Cisco IOS XE devices: see Cisco IOS-XE Software Availability

15.0(1)S4

Cisco IOS XE devices: see Cisco IOS-XE Software Availability

15.0SA

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

15.0SE

Not vulnerable

Not vulnerable

15.0SG

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

15.0XA

Vulnerable; first fixed in Release 15.1T

Vulnerable; first fixed in Release 15.1T

15.0XO

See Cisco IOS-XE Software Availability

See Cisco IOS-XE Software Availability

Affected 15.1-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

15.1EY

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

15.1GC

Vulnerable; first fixed in Release 15.1T

Vulnerable; first fixed in Release 15.1T

15.1M

15.1(4)M1

15.1(4)M2; Available on 30-SEP-11

15.1MR

Not vulnerable

Vulnerable; contact your support organization per the instructions in the Obtaining Fixed Software section of this advisory.

15.1S

Not vulnerable

Cisco IOS XE devices: see Cisco IOS-XE Software Availability

15.1(2)S2

15.1(3)S

Cisco IOS XE devices: see Cisco IOS-XE Software Availability

15.1T

15.1(1)T4;Available on 09-DEC-2011

15.1(2)T4

15.1(3)T2

15.1(1)T4 on 09-DEC-2011

15.1(2)T4

15.1(3)T2

15.1XB

Vulnerable; first fixed in Release 15.1T

Vulnerable; first fixed in Release 15.1T

Affected 15.2-Based Releases

First Fixed Release for This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

There are no affected 15.2 based releases

Cisco IOS XE Software

Cisco IOS XE Software is not affected by the vulnerabilities disclosed in this document.

Cisco IOS XE Release

First Fixed Release For This Advisory

First Fixed Release for All Advisories in the September 2011 Bundled Publication

2.1.x

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

2.2.x

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

2.3.x

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

2.4.x

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

2.5.x

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

2.6.x

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

3.1.xS

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

3.1.xSG

Not vulnerable

Vulnerable; migrate to 3.2.0SG or later

3.2.xS

Not vulnerable

Vulnerable; migrate to 3.3.2S or later

3.2.xSG

Not vulnerable

Not vulnerable

3.3.xS

Not vulnerable

3.3.2S

3.4.xS

Not vulnerable

Not vulnerable

For mapping of Cisco IOS XE to Cisco IOS releases, please refer to the Cisco IOS XE 2 Release Notes, Cisco IOS XE 3S Release Notes, and Cisco IOS XE 3SG Release Notes.

Cisco IOS XR Software

Cisco IOS XR Software is not affected by the vulnerabilities disclosed in this document.

Cisco IOS XR Software is not affected by any of the vulnerabilities in the September 2011 bundled publication.



Workarounds

Workarounds that mitigate these vulnerabilities are not available.

Obtaining Fixed Software

Cisco has released free software updates that address these vulnerabilities. Prior to deploying software, customers should consult their maintenance provider or check the software for feature set compatibility and known issues specific to their environment.

Customers may only install and expect support for the feature sets they have purchased. By installing, downloading, accessing or otherwise using such software upgrades, customers agree to be bound by the terms of Cisco's software license terms found at http://www.cisco.com/en/US/docs/general/warranty/English/EU1KEN_.html , or as otherwise set forth at Cisco.com Downloads at http://www.cisco.com/public/sw-center/sw-usingswc.shtml .

Do not contact psirt@cisco.com or security-alert@cisco.com for software upgrades

Customers with Service Contracts

Customers with contracts should obtain upgraded software through their regular update channels. For most customers, this means that upgrades should be obtained through the Software Center on Cisco's worldwide website at http://www.cisco.com.

Customers Using Third-Party Support Organizations

Customers whose Cisco products are provided or maintained through prior or existing agreements with third-party support organizations, such as Cisco Partners, authorized resellers, or service providers should contact that support organization for guidance and assistance with the appropriate course of action in regards to this advisory.

The effectiveness of any workaround or fix is dependent on specific customer situations, such as product mix, network topology, traffic behavior, and organizational mission. Due to the variety of affected products and releases, customers should consult with their service provider or support organization to ensure any applied workaround or fix is the most appropriate for use in the intended network before it is deployed.

Customers Without Service Contracts

Customers who purchase direct from Cisco but do not hold a Cisco service contract, and customers who purchase through third-party vendors but are unsuccessful in obtaining fixed software through their point of sale should acquire upgrades by contacting the Cisco Technical Assistance Center (TAC). TAC contacts are as follows.

  • +1 800 553 2447 (toll free from within North America)
  • +1 408 526 7209 (toll call from anywhere in the world)
  • e-mail: tac@cisco.com

Customers should have their product serial number available and be prepared to give the URL of this notice as evidence of entitlement to a free upgrade. Free upgrades for non-contract customers must be requested through the TAC.

Refer to http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html for additional TAC contact information, including localized telephone numbers, and instructions and e-mail addresses for use in various languages.

Exploitation and Public Announcements

The Cisco PSIRT is not aware of any public announcements or malicious use of the vulnerabilities described in this advisory.

These vulnerabilities were discovered while handling customer support calls.

Status of This Notice: Final

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

A stand-alone copy or Paraphrase of the text of this document that omits the distribution URL in the following section is an uncontrolled copy, and may lack important information or contain factual errors.


Distribution

This advisory is posted on Cisco's worldwide website at:

http://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20110928-zbfw

In addition to worldwide web posting, a text version of this notice is clear-signed with the Cisco PSIRT PGP key and is posted to the following e-mail and Usenet news recipients.

  • cust-security-announce@cisco.com
  • first-teams@first.org
  • bugtraq@securityfocus.com
  • vulnwatch@vulnwatch.org
  • cisco@spot.colorado.edu
  • cisco-nsp@puck.nether.net
  • full-disclosure@lists.grok.org.uk
  • comp.dcom.sys.cisco@newsgate.cisco.com

Future updates of this advisory, if any, will be placed on Cisco's worldwide website, but may or may not be actively announced on mailing lists or newsgroups. Users concerned about this problem are encouraged to check the above URL for any updates.


Revision History

Revision 1.2

2011-September-30

Updated Cisco IOS Software table bundled publication first fixed information.

Revision 1.1

2011-September-28

Added missing information in fixed Cisco IOS Software table for releases 15.0S and 15.1S.

Revision 1.0

2011-September-28

Initial public release.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.


Download this document (PDF)
View Printable Version