Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Applied Mitigation Bulletin

Identifying and Mitigating Exploitation of Multiple Vulnerabilities in the Cisco Video Surveillance Manager

 
Threat Type:IntelliShield: Applied Mitigation Bulletin
IntelliShield ID:30093
Version:1
First Published:2013 July 24 16:01 GMT
Last Published:2013 July 24 16:01 GMT
Port: Not available
CVE:CVE-2013-3429 , CVE-2013-3430 , CVE-2013-3431
Urgency:Unlikely Use
Credibility:Confirmed
Severity:Mild Damage
 
Version Summary:Cisco Applied Mitigation Bulletin initial public release
 

Cisco Response

This Applied Mitigation Bulletin is a companion document to the PSIRT Security Advisory Multiple Vulnerabilities in the Cisco Video Surveillance Manager and provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

This document provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

The Cisco Video Surveillance Manager (VSM) contains a vulnerability when processing specially crafted IP version 4 (IPv4) and IP version 6 (IPv6) packets. This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability could allow arbitrary code execution and allow information disclosure, which enables an attacker to learn information about the affected device and network. The attack vectors for exploitation are through IPv4 and IPv6 packets using the following protocols and ports:
  • Secure Shell (SSH) using TCP port 22
  • Cisco Video Surveillance Media Server (VSMS) using TCP ports 80 and 554
  • Cisco Video Surveillance Operations Manager (VSOM) using TCP port 443
  • Cisco Video Surveillance Virtual Matrix (VSVM) using TCP ports 1066 and 8086
  • Network Time Protocol (NTP) using UDP port 123
  • UDP ports 1024–1999
  • UDP ports 6000–6999
  • UDP ports 16100–16999
  • UDP ports 18000–18999
  • UDP ports 20000–20999
  • UDP ports 55000–55999
An attacker could exploit this vulnerability using spoofed packets.

This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) identifiers CVE-2013-3429, CVE-2013-3431, and CVE-2013-3430.

Mitigation Technique Overview

Cisco devices provide several countermeasures for these vulnerabilities. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using the following methods:
  • Transit access control lists (tACLs)
  • Unicast Reverse Path Forwarding (uRPF)
  • IP source guard (IPSG)
These protection mechanisms filter and drop, as well as verify the source IP address of, packets that are attempting to exploit these vulnerabilities.

The proper deployment and configuration of uRPF provides an effective means of protection against attacks that use packets with spoofed source IP addresses. uRPF should be deployed as close to all traffic sources as possible.

Effective means of exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance, Cisco Catalyst 6500 Series ASA Services Module (ASASM), and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers using the following:
  • tACLs
  • uRPF
These protection mechanisms filter and drop, as well as verify the source IP address of, packets that are attempting to exploit these vulnerabilities.

Cisco IOS NetFlow records can provide visibility into network-based exploitation attempts.

Cisco IOS Software, Cisco ASA, Cisco ASASM, and Cisco FWSM firewalls can provide visibility through syslog messages and counter values displayed in the output from show commands.

The Cisco Security Manager can also provide visibility through incidents, queries, and event reporting.

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of these vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

Caution: The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy transit access control lists (tACLs) to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized ssh IPv4 and IPv6 packets that are sent to affected devices:
  • SSH IPv4 and IPv6 packets on TCP port 22
  • VSMS IPv4 and IPv6 packets on TCP ports 80 and 554
  • VSOM IPv4 and IPv6 packets on TCP port 443
  • VSVM IPv4 and IPv6 packets on TCP ports 1066 and 8086
  • NTP IPv4 and IPv6 packets on UDP port 123
  • Packets on UDP ports 1024–1999
  • Packets on UDP ports 6000–6999
  • Packets on UDP ports 16100–16999
  • Packets on UDP ports 18000–18999
  • Packets on UDP ports 20000–20999
  • Packets on UDP ports 55000–55999
In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.
  !
  !-- Include explicit permit statements for trusted sources that
  !-- require access on the vulnerable TCP | UDP  ports | protocols
  !
  access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 80
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 44
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 554
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 1066
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8086
access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq ntp
access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 1024 1999
access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 6000 6999
access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 16100 16999
access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 18000 18999
access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 20000 20999
access-list 150 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 55000 55999 ! !-- The following vulnerability-specific access control entries !-- (ACEs) can aid in identification of attacks ! access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 22
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 80
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 443
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 554
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 1066
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 8086
access-list 150 deny udp any 192.168.60.0 0.0.0.255 eq ntp
access-list 150 deny udp any 192.168.60.0 0.0.0.255 range 1024 1999
access-list 150 deny udp any 192.168.60.0 0.0.0.255 range 6000 6999
access-list 150 deny udp any 192.168.60.0 0.0.0.255 range 16100 16999
access-list 150 deny udp any 192.168.60.0 0.0.0.255 range 18000 18999
access-list 150 deny udp any 192.168.60.0 0.0.0.255 range 20000 20999
access-list 150 deny udp any 192.168.60.0 0.0.0.255 range 55000 55999 ! !-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance !-- with existing security policies and configurations ! !-- Explicit deny for all other IP traffic ! access-list 150 deny ip any any ! !-- Create the corresponding IPv6 tACL ! ipv6 access-list IPv6-Transit-ACL-Policy ! !-- Include explicit permit statements for trusted sources that !-- require access on the vulnerable TCP | UDP ports | protocols ! permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 22
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 80
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 443
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 554
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 1066
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 8086
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq ntp
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 1024 1999
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 6000 6999
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 16100 16999
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 18000 18999
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 20000 20999
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 55000 55999 ! !-- The following vulnerability-specific access control entries !-- (ACEs) can aid in identification of attacks to global and !-- link-local addresses ! deny tcp any 2001:DB8:1:60::/64 eq 22
deny tcp any 2001:DB8:1:60::/64 eq 80
deny tcp any 2001:DB8:1:60::/64 eq 443
deny tcp any 2001:DB8:1:60::/64 eq 554
deny tcp any 2001:DB8:1:60::/64 eq 1066
deny tcp any 2001:DB8:1:60::/64 eq 8086
deny udp any 2001:DB8:1:60::/64 eq ntp
deny udp any 2001:DB8:1:60::/64 range 1024 1999
deny udp any 2001:DB8:1:60::/64 range 6000 6999
deny udp any 2001:DB8:1:60::/64 range 16100 16999
deny udp any 2001:DB8:1:60::/64 range 18000 18999
deny udp any 2001:DB8:1:60::/64 range 20000 20999
deny udp any 2001:DB8:1:60::/64 range 55000 55999 ! !-- Permit other required traffic to the infrastructure address !-- range and allow IPv6 neighbor discovery packets, which !-- include neighbor solicitation packets and neighbor !-- advertisement packets ! permit icmp any any nd-ns permit icmp any any nd-na !
! !-- Explicit deny for all other IPv6 traffic to the global !-- infrastructure address range !

deny ipv6 any any ! ! !-- Apply tACLs to interfaces in the ingress direction ! interface GigabitEthernet0/0 ip access-group 150 in ipv6 traffic-filter IPv6-Transit-ACL-Policy in
Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration commands no ip unreachables and no ipv6 unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration commands ip icmp rate-limit unreachable interval-in-ms and ipv6 icmp error-interval interval-in-ms.

Identification: Transit Access Control Lists

After the administrator applies the tACL to an interface, show ip access-lists and show ipv6 access-list commands will identify the number of:
  • SSH IPv4 and IPv6 packets on TCP port 22
  • VSMS IPv4 and IPv6 packets on TCP ports 80 and 554
  • VSOM IPv4 and IPv6 packets on TCP port 443
  • VSVM IPv4 and IPv6 packets on TCP ports 1066 and 8086
  • NTP IPv4 and IPv6 packets on UDP port 123
  • Packets filtered on UDP ports 1024–1999
  • Packets filtered on UDP ports 6000–6999
  • Packets on UDP ports 16100–16999
  • Packets filtered on UDP ports 18000–18999
  • Packets filtered on UDP ports 20000–20999
  • Packets filtered on UDP ports 55000–55999
Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ip access-lists 150 and show ipv6 access-list IPv6-Transit-ACL-Policy follows:
router#show ip access-lists 150
Extended IP access list 150
10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22 (21 matches)
20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq www (232 matches)
30 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443 (322 matches)
40 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 554 (12 matches)
50 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 1066 (32 matches)
60 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 8086 (49 matches)
70 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq ntp (71 matches)
80 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 1024 1999 (255 matches)
90 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 6000 6999 (33 matches)
100 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 16100 16999 (159 matches)
110 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 18000 18999 (55 matches)
120 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 20000 20999 (63 matches)
130 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 range 55000 55999 (20 matches)
140 deny tcp any 192.168.60.0 0.0.0.255 eq 22 (12 matches)
150 deny tcp any 192.168.60.0 0.0.0.255 eq www (14 matches)
160 deny tcp any 192.168.60.0 0.0.0.255 eq 443 (9 matches)
170 deny tcp any 192.168.60.0 0.0.0.255 eq 554 (22 matches)
180 deny tcp any 192.168.60.0 0.0.0.255 eq 1066 (121 matches)
190 deny tcp any 192.168.60.0 0.0.0.255 eq 8086 (33 matches)
200 deny udp any 192.168.60.0 0.0.0.255 eq ntp (58 matches)
210 deny udp any 192.168.60.0 0.0.0.255 range 1024 1999 (93 matches)
220 deny udp any 192.168.60.0 0.0.0.255 range 6000 6999 (211 matches)
230 deny udp any 192.168.60.0 0.0.0.255 range 16100 16999 (8 matches)
240 deny udp any 192.168.60.0 0.0.0.255 range 18000 18999 (49 matches)
250 deny udp any 192.168.60.0 0.0.0.255 range 20000 20999 (10 matches)
260 deny udp any 192.168.60.0 0.0.0.255 range 55000 55999 (91 matches) 270 deny ip any any (533 matches) router#
In the preceding example, access list 150 has dropped the following packets received from an untrusted host or network:
  • 12 SSH packets on TCP port 22 for ACE line 14
  • 14 VSMS packets on TCP port 80 for ACE line 15
  • 9 VSOM packets on TCP port 443 for ACE line 16
  • 22 VSMS packets on TCP port 554 for ACE line 17
  • 121 VSVM packets on TCP port 1066 for ACE line 18
  • 33 VSVM packets on TCP port 8086 for ACE line 19
  • 58 NTP packets on UDP port 123 for ACE line 20
  • 93 packets on UDP port range 1024–1099 for ACE line 21
  • 211 packets on UDP port range 6000–6999 for ACE line 22
  • 8 packets on UDP port range 16100–16999 for ACE line 23
  • 49 packets on UDP port range 18000–18999 for ACE line 24
  • 10 packets on UDP port range 20000–20999 for ACE line 25
  • 91 packets on UDP port range 55000–55999 for ACE line 26
router#show ipv6 access-list IPv6-Transit-ACL-Policy 
IPv6 access list IPv6-Transit-ACL-Policy
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 22 sequence 10
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq www sequence 20
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 443 sequence 30
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 554 sequence 40
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 1066 sequence 50
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 8086 sequence 60
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq ntp sequence 70
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 1024 1999 sequence 80
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 6000 6999 sequence 90
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 16100 16999 sequence 100
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 18000 18999 sequence 110
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 20000 20999 sequence 120
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 range 55000 55999 sequence 130
deny tcp any 2001:DB8:1:60::/64 eq 22 (12 matches) sequence 140
deny tcp any 2001:DB8:1:60::/64 eq www (38 matches) sequence 150
deny tcp any 2001:DB8:1:60::/64 eq 443 (15 matches) sequence 160
deny tcp any 2001:DB8:1:60::/64 eq 554 (97 matches) sequence 170
deny tcp any 2001:DB8:1:60::/64 eq 1066 (33 matches) sequence 180
deny tcp any 2001:DB8:1:60::/64 eq 8086 (25 matches) sequence 190
deny udp any 2001:DB8:1:60::/64 eq ntp (23 matches) sequence 200
deny udp any 2001:DB8:1:60::/64 range 1024 1999 (88 matches) sequence 210
deny udp any 2001:DB8:1:60::/64 range 6000 6999 (94 matches) sequence 220
deny udp any 2001:DB8:1:60::/64 range 16100 16999 (29 matches) sequence 230
deny udp any 2001:DB8:1:60::/64 range 18000 18999 (76 matches) sequence 240
deny udp any 2001:DB8:1:60::/64 range 20000 20999 (10 matches) sequence 250
deny udp any 2001:DB8:1:60::/64 range 55000 55999 (15 matches) sequence 260 permit icmp any any nd-ns (80 matches) sequence 270 permit icmp any any nd-na (80 matches) sequence 280 deny ipv6 any any (21 matches) sequence 290
In the preceding example, access list IPv6-Transit-ACL-Policy has dropped the following packets received from an untrusted host or network:
  • 12 SSH packets on TCP port 22 for ACE line 14
  • 38 VSMS packets on TCP port 80 for ACE line 15
  • 15 VSOM packets on TCP port 443 for ACE line 16
  • 97 VSMS packets on TCP port 554 for ACE line 17
  • 33 VSVM packets on TCP port 1066 for ACE line 18
  • 25 VSVM packets on TCP port 8086 for ACE line 19
  • 23 NTP packets on UDP port 123 for ACE line 20
  • 88 UDP packets on UDP port range 1024–1099 for ACE line 21
  • 94 UDP packets on UDP port range 6000–6999 for ACE line 22
  • 29 UDP packets on UDP port range 16100–16999 for ACE line 23
  • 76 UDP packets on UDP port range 18000–18999 for ACE line 24
  • 10 UDP packets on UDP port range 20000–20999 for ACE line 25
  • 15 UDP packets on UDP port range 55000–55999 for ACE line 26
For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Cisco Security Intelligence Operations white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: Access List Logging

The log and log-input access control list (ACL) option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

For Cisco IOS Software, the ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by IPv4 ACL logging. The logging rate-limit rate-per-second [except loglevel] command limits the impact of log generation and transmission.

The CPU impact from ACL logging can be addressed in hardware on the Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging.

For additional information about the configuration and use of ACL logging, reference the Understanding Access Control List Logging Cisco Security Intelligence Operations white paper.

Mitigation: Spoofing Protection

Unicast Reverse Path Forwarding

The vulnerabilities that are described in this document can be exploited by spoofed IP packets. Administrators can deploy and configure Unicast Reverse Path Forwarding (uRPF) as a protection mechanism against spoofing.

uRPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on uRPF to provide complete spoofing protection because spoofed packets may enter the network through a uRPF-enabled interface if an appropriate return route to the source IP address exists. Administrators are advised to take care to ensure that the appropriate uRPF mode (loose or strict) is configured during the deployment of this feature because it can drop legitimate traffic that is transiting the network. In an enterprise environment, uRPF may be enabled at the Internet edge and the internal access layer on the user-supporting Layer 3 interfaces.

For additional information about the configuration and use of uRPF, reference the Understanding Unicast Reverse Path Forwarding Cisco Security Intelligence Operations white paper.

IP Source Guard

IP source guard (IPSG) is a security feature that restricts IP traffic on nonrouted, Layer 2 interfaces by filtering packets based on the DHCP snooping binding database and manually configured IP source bindings. Administrators can use IPSG to prevent attacks from an attacker who attempts to spoof packets by forging the source IP address and/or the MAC address. When properly deployed and configured, IPSG coupled with strict mode uRPF provides the most effective means of spoofing protection for the vulnerabilities that are described in this document.

Additional information about the deployment and configuration of IPSG is in Configuring DHCP Features and IP Source Guard.

Identification: Spoofing Protection Using Unicast Reverse Path Forwarding

With uRPF properly deployed and configured throughout the network infrastructure, administrators can use the show cef interface type slot/port internal, show ip interface, show cef drop, show ip cef switching statistics feature, and show ip traffic commands to identify the number of packets that uRPF has dropped.

Note: Beginning with Cisco IOS Software Release 12.4(20)T, the command show ip cef switching has been replaced by show ip cef switching statistics feature.

Note: The show command | begin regex and show command | include regex command modifiers are used in the following examples to minimize the amount of output that administrators will need to parse to view the desired information. Additional information about command modifiers is in the show command sections of the Cisco IOS Configuration Fundamentals Command Reference.
router#show cef interface GigabitEthernet 0/0 internal | include drop
  ip verify: via=rx (allow default), acl=0, drop=18, sdrop=0
  IPv6 unicast RPF: via=rx acl=None, drop=10, sdrop=0 
router#
Note: show cef interface type slot/port internal is a hidden command that must be fully entered at the command-line interface. Command completion is not available for it.
router#show cef drop
CEF Drop Statistics
Slot  Encap_fail  Unresolved Unsupported    No_route      No_adj  ChkSum_Err
RP            27           0           0          18           0           0
router#

router#show ip interface GigabitEthernet 0/0 | begin verify

  IP verify source reachable-via RX, allow default, allow self-ping
  18 verification drops
  0 suppressed verification drops
router#
router#show ipv6 interface GigabitEthernet 0/0 | section IPv6 verify

  IPv6 verify source reachable-via rx 
  0 verification drop(s) (process), 10 (CEF)
  0 suppressed verification drop(s) (process), 0 (CEF)
  --      CLI Output Truncated       --  
router#

router#show ip cef switching statistics feature

IPv4 CEF input features:
Path Feature Drop Consume Punt Punt2Host Gave route
RP PAS uRPF 18 0 0 0 0 Total 18 0 0 0 0 -- CLI Output Truncated -- router# router#show ipv6 cef switching statistics feature IPv6 CEF input features: Feature Drop Consume Punt Punt2Host Gave route RP LES Verify Unicast R 10 0 0 0 0 Total 10 0 0 0 0 -- CLI Output Truncated -- router# router#show ip traffic | include RPF 18 no route, 18 unicast RPF, 0 forced drop router# router#show ipv6 traffic | include RPF 10 RPF drops, 0 RPF suppressed, 0 forced drop router#
In the preceding show cef interface type slot/port internal, show cef drop, show ip interface type slot/port and show ipv6 interface type slot/port, show ip cef switching statistics feature and show ipv6 cef switching statistics feature, and show ip traffic and show ipv6 traffic examples, uRPF has dropped the following packets received globally on all interfaces with uRPF configured because of the inability to verify the source address of the IP packets within the forwarding information base of Cisco Express Forwarding.
  • 18 IPv4 packets
  • 10 IPv6 packets

Cisco IOS NetFlow and Cisco IOS Flexible NetFlow

Identification: IPv4 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv4 traffic flows that may be attempts to exploit these vulnerabilities. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.
router#show ip cache flow
IP packet size distribution (90784136 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .698 .011 .001 .004 .005 .000 .004 .000 .000 .003 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .001 .256 .000 .010 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  1885 active, 63651 inactive, 59960004 added
  129803821 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  0 active, 16384 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet    11393421      2.8         1    48      3.1       0.0       1.4
TCP-FTP            236      0.0        12    66      0.0       1.8       4.8
TCP-FTPD            21      0.0     13726  1294      0.0      18.4       4.1
TCP-WWW          22282      0.0        21  1020      0.1       4.1       7.3
TCP-X              719      0.0         1    40      0.0       0.0       1.3
TCP-BGP              1      0.0         1    40      0.0       0.0      15.0
TCP-Frag         70399      0.0         1   688      0.0       0.0      22.7
TCP-other     47861004     11.8         1   211     18.9       0.0       1.3
UDP-DNS            582      0.0         4    73      0.0       3.4      15.4
UDP-NTP         287252      0.0         1    76      0.0       0.0      15.5
UDP-other       310347      0.0         2   230      0.1       0.6      15.9
ICMP             11674      0.0         3    61      0.0      19.8      15.5
IPv6INIP            15      0.0         1  1132      0.0       0.0      15.4
GRE                  4      0.0         1    48      0.0       0.0      15.3 
Total:        59957957     14.8         1   196     22.5       0.0       1.5

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  11 0984 007B     1
Gi0/0         192.168.11.54   Gi0/1         192.168.60.158  11 0911 0400     3
Gi0/1         192.168.150.60  Gi0/0         10.89.16.226    06 0016 12CA     1
Gi0/0         192.168.13.97   Gi0/1         192.168.60.28   11 0B3E 1770     5
Gi0/0         192.168.10.17   Gi0/1         192.168.60.97   11 0B89 3EE4     1
Gi0/0         10.88.226.1     Gi0/1         192.168.60.22   11 007B 4650     1
Gi0/0         192.168.12.185  Gi0/1         192.168.60.239  11 0BD7 12CA     1
Gi0/0         10.89.16.226    Gi0/1         192.168.150.60  11 12CA 001A     1
router#
In the preceding example, there are multiple flows for NTP on UDP port 123 (hex value 007B), UDP port 1024 (hex value 0400), UDP port 6000 (hex value 1770), UDP port 16100, (hex value 3EE4), UDP port 18000 (hex value 4650).

This traffic is sourced from and sent to addresses within the 192.168.60.0/24 address block, which is used by affected devices. The packets in these flows may be spoofed and may indicate an attempt to exploit these vulnerabilities. Administrators are advised to compare these flows to baseline utilization for NTP traffic sent on UDP ports 123, 1024, 6000, 16100, and 18000, and also investigate the flows to determine whether they are sourced from untrusted hosts or networks.

As shown in the following example, to view only the SSH packets on TCP port 22 (hex value 0016), TCP port 80 (hex value 0050), and TCP port (hex value 01BB), use the show ip cache flow | include SrcIf|_06_.*(0016|0050|01BB)_ command to display the related Cisco NetFlow records:

TCP Flows
router#show ip cache flow | include SrcIf|_06_.*(0016|0050|01BB)_
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.12.110   Gi0/1         192.168.60.163  06 092A 0016     6
Gi0/0         192.168.11.230   Gi0/1         192.168.60.20   06 0C09 0016     1
Gi0/0         192.168.11.131   Gi0/1         192.168.60.245  06 0B66 0050    18
Gi0/0         192.168.13.7     Gi0/1         192.168.60.162  06 0914 0050     1
Gi0/0         192.168.41.86    Gi0/1         192.168.60.27   06 0B7B 01BB     2
router#
As shown in the following example, to view only the packets on UDP port 123 (hex value 007B), UDP port 1024 (hex value 0400), and UDP port 6000 (hex value 1770), use the show ip cache flow | include SrcIf|_11_.*(007B|0400|1770)_ command to display the related Cisco NetFlow records:

UDP Flows
router#show ip cache flow | include SrcIf|_11_.*(007B|0400|1770)_
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.12.110   Gi0/1         192.168.60.163  11 092A 007B     6
Gi0/0         192.168.11.230   Gi0/1         192.168.60.20   11 0C09 007B     1
Gi0/0         192.168.11.131   Gi0/1         192.168.60.245  11 0B66 0400    18
Gi0/0         192.168.13.7     Gi0/1         192.168.60.162  11 0914 1770     1
Gi0/0         192.168.41.86    Gi0/1         192.168.60.27   11 0B7B 1770     2
router#

Identification: IPv6 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv6 traffic flows that may be attempts to exploit the vulnerabilities that are described in this document. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

The following output is from a Cisco IOS device running Cisco IOS Software 12.4 mainline train. The command syntax will vary for different Cisco IOS Software trains.
router#show ipv6 flow cache

IP packet size distribution (50078919 total packets):
   1-32  64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .990 .001 .008 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 475168 bytes
  8 active, 4088 inactive, 6160 added
  1092984 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33928 bytes
  16 active, 1008 inactive, 12320 added, 6160 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x11 0x16C4 0x007B 1464
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...134::3 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::4 Gi0/1    0x3A 0x0000 0x8000 1192    
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x0016 1522
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x11 0x1610 0x1770 1001  
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x11 0x1634 0x1770 1292  
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::3 Gi0/1    0x06 0x0000 0x0016 1155
2001:DB...6A:5BA6 Gi0/0    2001:DB...146::3 Gi0/1    0x3A 0x0000 0x8000 1092
2001:DB...6A:5BA6 Gi0/0    2001:DB...144::4 Gi0/1    0x3A 0x0000 0x8000 1193 
To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

In the preceding example, there are multiple IPv6 flows for NTP on UDP port 123 (hex value 007B), SSH on TCP port 22 (hex value 0016), and UDP port 6000 (hex value 1770).

The packets on UDP port 123 and UDP port 6000 are sourced from and sent to addresses within the 2001:DB8:1:60::/64 address block that is used by affected devices. The packets in the UDP flows may be spoofed and could indicate an attempt to exploit these vulnerabilities. Administrators are advised to compare these flows to baseline utilization for traffic on UDP port 123 and UDP port 6000 and also investigate the flows to determine whether they are sourced from untrusted hosts or networks.

As shown in the following example, to view only the SSH packets on TCP port 22 (hex value 0016), TCP port 80 (hex value 0050), and TCP port (hex value 01BB), use the show ipv6 flow cache | include SrcIf|_06_.*(0016|0050|01BB)_ command to display the related Cisco NetFlow records:

TCP Flows
router#show ipv6 flow cache | include SrcIf|_06_.*(0016|0050|01BB)_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x0016 1597
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x0050 1597
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x01BB 1597
router#
As shown in the following example, to view only the NTP packets on UDP port 123 (hex value 007B), UDP port 1024 (hex value 0400), and UDP port 6000 (hex value 1770), use the show ipv6 flow cache | include SrcIf|_11_.*(007B|0400|1770)_ command to display the related Cisco NetFlow records:

UDP Flows
router#show ip cache flow | include SrcIf|_11_.*(007B|0400|1770)_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x11 0x16C4 0x007B 1464 
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x11 0x1610 0x0400 1001 
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x11 0x1634 0x1770 1292 
router#

Identification: IPv4 Traffic Flow Identification Using Cisco Flexible NetFlow

Introduced in Cisco IOS Software Releases 12.2(31)SB2 and 12.4(9)T, Cisco IOS Flexible NetFlow improves original Cisco NetFlow by adding the capability to customize the traffic analysis parameters for the administrator's specific requirements. Original Cisco NetFlow uses a fixed seven tuples of IP information to identify a flow, whereas Cisco IOS Flexible NetFlow allows the flow to be user defined. It facilitates the creation of more complex configurations for traffic analysis and data export by using reusable configuration components.

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv4 flows based on source IPv4 address, as defined by the match ipv4 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv4 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.
!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv4
 match ipv4 source address
 collect ipv4 protocol
 collect ipv4 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv4
 record FLOW-RECORD-ipv4
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
 ip flow monitor FLOW-MONITOR-ipv4 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv4 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                1

  Flows added:                                   9181
  Flows aged:                                    9175
    - Active timeout      (  1800 secs)          9000
    - Inactive timeout    (    15 secs)           175
    - Event aged                                    0
    - Watermark aged                                0
    - Emergency aged                                0

IPV4 SRC ADDR   ipv4 dst addr   trns src port trns dst port intf input intf output pkts   ip prot
=============== =============== ============= ============= ========== =========== ====== =======
 192.168.10.201  192.168.60.102          1456            22      Gi0/0       Gi0/1   1128      6
 192.168.11.54   192.168.60.158           123           123      Gi0/0       Gi0/1   2212     17
 192.168.150.60    10.89.16.226          2567           443      Gi0/0       Gi0/1     13      6
 192.168.13.97    192.168.60.28          3451            22      Gi0/0       Gi0/1      1      6
 192.168.10.17    192.168.60.97          4231          1770      Gi0/0       Gi0/1    146     17
   10.88.226.1   192.168.202.22          2678           443      Gi0/0       Gi0/1  10567      6
  10.89.16.226   192.168.150.60          3562            80      Gi0/0       Gi0/1  30012      6
To only view the SSH packets on TCP port 22, use the show flow monitor FLOW-MONITOR-ipv4 cache format table | include IPV4 DST ADDR |_(22)_.*_6_ command to display the related NetFlow records.

For more information about Cisco IOS Flexible NetFlow, refer to Flexible Netflow Configuration Guide, Cisco IOS Release 15M&T and Cisco IOS Flexible NetFlow Configuration Guide, Release 12.4T.

Identification: IPv6 Traffic Flow Identification Using Cisco IOS Flexible NetFlow

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv6 flows based on the source IPv6 address, as defined by the match ipv6 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv6 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.
!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv6
 match ipv6 source address
 collect ipv6 protocol
 collect ipv6 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv6
 record FLOW-RECORD-ipv6
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
  ipv6 flow monitor FLOW-MONITOR-ipv6 input

The Cisco IOS Flexible NetFlow flow output is as follows:

 

router#show flow monitor FLOW-MONITOR-ipv6 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                2

  Flows added:                                   539
  Flows aged:                                    532
    - Active timeout      (  1800 secs)          350
    - Inactive timeout    (    15 secs)          182
    - Event aged                                   0
    - Watermark aged                               0
    - Emergency aged                               0

IPV6 SRC ADDR     ipv6 dst addr     trns src port trns dst port intf input intf output pkts ip prot
================= ================= ============= ============= ========== =========== ==== =======
2001:DB...06::201  2001:DB...28::20           123           123      Gi0/0       Gi0/0   17      17
2001:DB...06::201 2001:DB...28::20           1265            22      Gi0/0       Gi0/0 1237       6
2001:DB...06::201  2001:DB...28::20          1441           443      Gi0/0       Gi0/0 2346       6
2001:DB...06::201  2001:DB...28::20          1890            22      Gi0/0       Gi0/0 5009       6
2001:DB...06::201  2001:DB...28::20          2856          5060      Gi0/0       Gi0/0  486      17
2001:DB...06::201  2001:DB...28::20          3012            53      Gi0/0       Gi0/0 1016      17
2001:DB...06::201  2001:DB...28::20          2477            53      Gi0/0       Gi0/0 1563      17
To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

To view only the SSH on TCP port 22, use the show flow monitor FLOW-MONITOR-ipv6 cache format table | include IPV6 DST ADDR|_(22)_.*_6_ command to display the related Cisco IOS Flexible NetFlow records.

Cisco ASA, Cisco ASASM, and Cisco FWSM Firewalls

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized packets that are sent to affected devices:
  • SSH IPv4 and IPv6 packets on TCP port 22
  • VSMS IPv4 and IPv6 packets on TCP ports 80 and 554
  • VSOM IPv4 and IPv6 packets on TCP port 443
  • VSVM IPv4 and IPv6 packets on TCP ports 1066 and 8086
  • NTP IPv4 and IPv6 packets on UDP port 123
  • Packets on UDP ports 1024–1999
  • Packets on UDP ports 6000–6999
  • Packets on UDP ports 16100–16999
  • Packets on UDP ports 18000–18999
  • Packets on UDP ports 20000–20999
  • Packets on UDP ports 55000–55999
In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.
!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable  TCP | UDP  ports | protocols
!
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 22
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 80
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 443
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 554
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 1066
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 8086
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 123
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 range 1024 1999
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 range 6000 6999
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 range 16100 16999
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 range 18000 18999
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 range 20000 20999
access-list tACL-Policy extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 range 55000 55999
!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 22
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 80
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 443
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 554
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 1066
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 8086
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 eq 123
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 range 1024 1999
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 range 6000 6999
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 range 16100 16999
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 range 18000 18999
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 range 20000 20999
access-list tACL-Policy extended deny udp any 192.168.60.0 255.255.255.0 range 55000 55999
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
access-list tACL-Policy extended deny ip any any
!
!-- Create the corresponding IPv6 tACL
!
!-- Include explicit permit statements for trusted sources that
!-- require access on the vulnerable  TCP | UDP  ports | protocols
!
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 22
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 80
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 443
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 554
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 1066
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 8086
ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 123
ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1
          2001:db8:1:60::/64 range 1024 1999
ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1
          2001:db8:1:60::/64 range 6000 6999
ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1
          2001:db8:1:60::/64 range 16100 16999
ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1
          2001:db8:1:60::/64 range 18000 18999
ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1
          2001:db8:1:60::/64 range 20000 20999
ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1
          2001:db8:1:60::/64 range 55000 55999
!
!--  The following vulnerability-specific access control entries
!--  (ACEs) can aid in identification of attacks
!
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 22
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 80
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 443
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 554
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 1066
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 8086
ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 eq 123
ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 range 1024 1999
ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 range 6000 6999
ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 range 16100 16999
ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 range 18000 18999
ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 range 20000 20999
ipv6 access-list IPv6-tACL-Policy deny udp any 2001:db8:1:60::/64 range 55000 55999
!
!--  Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!--  with existing security policies and configurations
!
!--  Explicit deny for all other IP traffic
!
ipv6 access-list IPv6-tACL-Policy deny ip any any
!
!--  Apply tACLs to interfaces in the ingress direction
!
access-group tACL-Policy in interface outside
access-group IPv6-tACL-Policy in interface outside

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the number of packets that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show access-list tACL-Policy and show access-list IPv6-tACL-Policy follows:
firewall#show access-list tACL-Policy
access-list tACL-Policy line 1 extended permit tcp host 192.168.100.1 
          192.168.60.0 255.255.255.0 eq ssh (hitcnt=0) 0xed1065dd 
access-list tACL-Policy line 2 extended permit tcp host 192.168.100.1 
          192.168.60.0 255.255.255.0 eq www (hitcnt=0) 0x22aaee1d 
access-list tACL-Policy line 3 extended permit tcp host 192.168.100.1 
          192.168.60.0 255.255.255.0 eq https (hitcnt=0) 0x31d6aea3 
access-list tACL-Policy line 4 extended permit tcp host 192.168.100.1 
          192.168.60.0 255.255.255.0 eq rtsp (hitcnt=0) 0x63da74df 
access-list tACL-Policy line 5 extended permit tcp host 192.168.100.1 
          192.168.60.0 255.255.255.0 eq 1066 (hitcnt=0) 0x26c96c34 
access-list tACL-Policy line 6 extended permit tcp host 192.168.100.1 
          192.168.60.0 255.255.255.0 eq 8086 (hitcnt=0) 0x090719ee 
access-list tACL-Policy line 7 extended permit udp host 192.168.100.1 
          192.168.60.0 255.255.255.0 eq ntp (hitcnt=0) 0x78708a59 
access-list tACL-Policy line 8 extended permit udp host 192.168.100.1 
          192.168.60.0 255.255.255.0 range 1024 1999 (hitcnt=0) 0x37587597 
access-list tACL-Policy line 9 extended permit udp host 192.168.100.1 
          192.168.60.0 255.255.255.0 range 6000 6999 (hitcnt=0) 0x81c8fdda 
access-list tACL-Policy line 10 extended permit udp host 192.168.100.1 
          192.168.60.0 255.255.255.0 range 16100 16999 (hitcnt=0) 0xd49298bb 
access-list tACL-Policy line 11 extended permit udp host 192.168.100.1 
          192.168.60.0 255.255.255.0 range 18000 18999 (hitcnt=0) 0x3634dbeb 
access-list tACL-Policy line 12 extended permit udp host 192.168.100.1 
          192.168.60.0 255.255.255.0 range 20000 20999 (hitcnt=0) 0xdb4a4026 
access-list tACL-Policy line 13 extended permit udp host 192.168.100.1 
          192.168.60.0 255.255.255.0 range 55000 55999 (hitcnt=0) 0xa267094e 
access-list tACL-Policy line 14 extended deny tcp any 192.168.60.0  
          255.255.255.0 eq ssh (hitcnt=12) 0x641e0b4e 
access-list tACL-Policy line 15 extended deny tcp any 192.168.60.0  
          255.255.255.0 eq www (hitcnt=43) 0x1c132dc0 
access-list tACL-Policy line 16 extended deny tcp any 192.168.60.0  
          255.255.255.0 eq https (hitcnt=54) 0x992592c4 
access-list tACL-Policy line 17 extended deny tcp any 192.168.60.0  
          255.255.255.0 eq rtsp (hitcnt=32) 0x6fef18d4 
access-list tACL-Policy line 18 extended deny tcp any 192.168.60.0  
          255.255.255.0 eq 1066 (hitcnt=76) 0xf6d3da61 
access-list tACL-Policy line 19 extended deny tcp any 192.168.60.0  
          255.255.255.0 eq 8086 (hitcnt=87) 0x300f96d0 
access-list tACL-Policy line 20 extended deny udp any 192.168.60.0  
          255.255.255.0 eq ntp (hitcnt=54) 0x92a29788 
access-list tACL-Policy line 21 extended deny udp any 192.168.60.0  
          255.255.255.0 range 1024 1999 (hitcnt=21) 0x0bbd3439 
access-list tACL-Policy line 22 extended deny udp any 192.168.60.0  
          255.255.255.0 range 6000 6999 (hitcnt=89) 0xc71dc0d5 
access-list tACL-Policy line 23 extended deny udp any 192.168.60.0  
          255.255.255.0 range 16100 16999 (hitcnt=22) 0x50a3f5bd 
access-list tACL-Policy line 24 extended deny udp any 192.168.60.0  
          255.255.255.0 range 18000 18999 (hitcnt=12) 0x36abaa23 
access-list tACL-Policy line 25 extended deny udp any 192.168.60.0  
          255.255.255.0 range 20000 20999 (hitcnt=12) 0xec77d990 
access-list tACL-Policy line 26 extended deny udp any 192.168.60.0  
          255.255.255.0 range 55000 55999 (hitcnt=53) 0xd3041ba6 
access-list tACL-Policy line 27 extended deny ip any any (hitcnt=639) 0xfb7b3a57 
In the preceding example, access list tACL-Policy has dropped the following packets received from an untrusted host or network:
  • 12 SSH packets on TCP port 22 for ACE line 14
  • 43 VSMS packets on TCP port 80 for ACE line 15
  • 54 VSOM packets on TCP port 443 for ACE line 16
  • 32 VSMS packets on TCP port 554 for ACE line 17
  • 76 VSVM packets on TCP port 1066 for ACE line 18
  • 87 VSVM packets on TCP port 8086 for ACE line 19
  • 54 NTP packets on UDP port 123 for ACE line 20
  • 211 packets on UDP port range 1024–1099 for ACE line 21
  • 89 packets on UDP port range 6000–6009 for ACE line 22
  • 22 packets on UDP port range 161000–16999 for ACE line 23
  • 12 packets on UDP port range 18000–18999 for ACE line 24
  • 12 packets on UDP port range 20000–20999 for ACE line 25
  • 53 packets on UDP port range 55000–55999 for ACE line 26
firewall#show access-list IPv6-tACL-Policy                 
ipv6 access-list IPv6-tACL-Policy; 27 elements; name hash: 0x566a4229
ipv6 access-list IPv6-tACL-Policy line 1 permit tcp host 2001:db8::100:1
      2001:db8:1:60::/64 eq ssh (hitcnt=0) 0xcd5dc697 
ipv6 access-list IPv6-tACL-Policy line 2 permit tcp host 2001:db8::100:1
      2001:db8:1:60::/64 eq www (hitcnt=0) 0xefd0a39e 
ipv6 access-list IPv6-tACL-Policy line 3 permit tcp host 2001:db8::100:1
      2001:db8:1:60::/64 eq https (hitcnt=0) 0x7e70f8fc 
ipv6 access-list IPv6-tACL-Policy line 4 permit tcp host 2001:db8::100:1
      2001:db8:1:60::/64 eq rtsp (hitcnt=0) 0x0dddc752 
ipv6 access-list IPv6-tACL-Policy line 5 permit tcp host 2001:db8::100:1
      2001:db8:1:60::/64 eq 1066 (hitcnt=0) 0xdff50a3e 
ipv6 access-list IPv6-tACL-Policy line 6 permit tcp host 2001:db8::100:1
      2001:db8:1:60::/64 eq 8086 (hitcnt=0) 0xa8fb3866 
ipv6 access-list IPv6-tACL-Policy line 7 permit udp host 2001:db8::100:1
      2001:db8:1:60::/64 eq ntp (hitcnt=0) 0xa280450c 
ipv6 access-list IPv6-tACL-Policy line 8 permit udp host 2001:db8::100:1
      2001:db8:1:60::/64 range 1024 1999 (hitcnt=0) 0x1885ac1c 
ipv6 access-list IPv6-tACL-Policy line 9 permit udp host 2001:db8::100:1
      2001:db8:1:60::/64 range 6000 6999 (hitcnt=0) 0xac3af30f 
ipv6 access-list IPv6-tACL-Policy line 10 permit udp host 2001:db8::100:1
      2001:db8:1:60::/64 range 16100 16999 (hitcnt=0) 0xc0f8a01a 
ipv6 access-list IPv6-tACL-Policy line 11 permit udp host 2001:db8::100:1
      2001:db8:1:60::/64 range 18000 18999 (hitcnt=0) 0x191d4ecc 
ipv6 access-list IPv6-tACL-Policy line 12 permit udp host 2001:db8::100:1
      2001:db8:1:60::/64 range 20000 20999 (hitcnt=0) 0xf872ee86 
ipv6 access-list IPv6-tACL-Policy line 13 permit udp host 2001:db8::100:1
      2001:db8:1:60::/64 range 55000 55999 (hitcnt=0) 0xf3b02511 
ipv6 access-list IPv6-tACL-Policy line 14 deny tcp any 2001:db8:1:60::/64
       eq ssh (hitcnt=12) 0x4e953dfe 
ipv6 access-list IPv6-tACL-Policy line 15 deny tcp any 2001:db8:1:60::/64
      eq www (hitcnt=43) 0x68a1721d 
ipv6 access-list IPv6-tACL-Policy line 16 deny tcp any 2001:db8:1:60::/64
      eq https (hitcnt=54) 0x3bd72116 
ipv6 access-list IPv6-tACL-Policy line 17 deny tcp any 2001:db8:1:60::/64
      eq rtsp (hitcnt=32) 0x65f7c96f 
ipv6 access-list IPv6-tACL-Policy line 18 deny tcp any 2001:db8:1:60::/64
      eq 1066 (hitcnt=76) 0xbad3a01e 
ipv6 access-list IPv6-tACL-Policy line 19 deny tcp any 2001:db8:1:60::/64
      eq 8086 (hitcnt=87) 0x42ad6174 
ipv6 access-list IPv6-tACL-Policy line 20 deny udp any 2001:db8:1:60::/64
      eq ntp (hitcnt=54) 0xec42313f 
ipv6 access-list IPv6-tACL-Policy line 21 deny udp any 2001:db8:1:60::/64
      range 1024 1999 (hitcnt=211) 0xece1bbe6 
ipv6 access-list IPv6-tACL-Policy line 22 deny udp any 2001:db8:1:60::/64
      range 6000 6999 (hitcnt=89) 0xeb692e71 
ipv6 access-list IPv6-tACL-Policy line 23 deny udp any 2001:db8:1:60::/64
      range 16100 16999 (hitcnt=22) 0xc634e4bc 
ipv6 access-list IPv6-tACL-Policy line 24 deny udp any 2001:db8:1:60::/64
      range 18000 18999 (hitcnt=12) 0x6746462b 
ipv6 access-list IPv6-tACL-Policy line 25 deny udp any 2001:db8:1:60::/64
      range 20000 20999 (hitcnt=12) 0x8f5b5954 
ipv6 access-list IPv6-tACL-Policy line 26 deny udp any 2001:db8:1:60::/64
      range 55000 55999 (hitcnt=53) 0xa678e66e 
ipv6 access-list IPv6-tACL-Policy line 27 deny ip any any (hitcnt=889) 0xa6445d5d
In the preceding example, access list IPv6-tACL-Policy has dropped the following packets received from an untrusted host or network:
  • 12 SSH packets on TCP port 22 for ACE line 14
  • 43 VSMS packets on TCP port 80 for ACE line 15
  • 54 VSOM packets on TCP port 443 for ACE line 16
  • 32 VSMS packets on TCP port 554 for ACE line 17
  • 76 VSVM packets on TCP port 1066 for ACE line 18
  • 87 VSVM packets on TCP port 8086 for ACE line 19
  • 54 NTP packets on UDP port 123 for ACE line 20
  • 211 packets on UDP port range 1024–1099 for ACE line 21
  • 89 packets on UDP port range 6000–6009 for ACE line 22
  • 22 packets on UDP port range 161000–16999 for ACE line 23
  • 12 packets on UDP port range 18000–18999 for ACE line 24
  • 12 packets on UDP port range 20000–20999 for ACE line 25
  • 53 packets on UDP port range 55000–55999 for ACE line 26
In addition, syslog message 106023 can provide valuable information, which includes the source and destination IP address, the source and destination port numbers, and the IP protocol for the denied packet.

Identification: Firewall Access List Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an access control entry (ACE) that does not have the log keyword present. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the Cisco Catalyst 6500 Series ASA Services Module is in Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.
firewall#show logging | grep 106023
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.18/2944 
         dst inside:192.168.60.191/6000 by access-group "tACL-Policy"
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.200/2945 
         dst inside:192.168.60.33/6000 by access-group "tACL-Policy"
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.99/2946 
         dst inside:192.168.60.240/6000 by access-group "tACL-Policy"
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.100/2947 
         dst inside:192.168.60.115/6000 by access-group "tACL-Policy"
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.88/2949 
         dst inside:192.168.60.38/6000 by access-group "tACL-Policy"
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.175/2950 
         dst inside:192.168.60.250/6000 by access-group "tACL-Policy"
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:2001:db8:2::2:172/2951
         dst inside:2001:db8:1:60::23/6000 by access-group "IPv6-tACL-Policy"
  Jul 22 2013 00:15:13: %ASA-4-106023: Deny udp src outside:2001:db8:d::a85e:172/2952
         dst inside:2001:db8:1:60::134/6000 by access-group "IPv6-tACL-Policy"
firewall#
In the preceding example, the messages logged for the tACL tACL-Policy and IPv6-tACL-Policy show potentially spoofed packets for UDP port 6000 sent to the address block assigned to affected devices.

Additional information about syslog messages for Cisco ASA Series Adaptive Security Appliances is in Cisco ASA 5500 Series System Log Messages, 8.2. Additional information about syslog messages for Cisco Catalyst 6500 Series ASA Services Module is in the Analyzing Syslog Messages section of the Cisco ASASM CLI Configuration Guide. Additional information about syslog messages for the Cisco FWSM is in Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Logging System Log Messages.

For additional information about investigating incidents using syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Mitigation: Spoofing Protection Using Unicast Reverse Path Forwarding

The vulnerabilities that are described in this document can be exploited by spoofed IP packets. Administrators can deploy and configure uRPF as a protection mechanism against spoofing.

uRPF is configured at the interface level and can detect and drop packets that lack a verifiable source IP address. Administrators should not rely on uRPF to provide complete spoofing protection because spoofed packets may enter the network through a uRPF-enabled interface if an appropriate return route to the source IP address exists. In an enterprise environment, uRPF may be enabled at the Internet edge and at the internal access layer on the user-supporting Layer 3 interfaces.

For additional information about the configuration and use of uRPF, reference the Cisco Security Appliance Command Reference for ip verify reverse-path and the Understanding Unicast Reverse Path Forwarding Cisco Security Intelligence Operations white paper.

Identification: Spoofing Protection Using Unicast Reverse Path Forwarding

Firewall syslog message 106021 will be generated for packets denied by uRPF. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106021.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog for the Cisco Catalyst 6500 Series ASA Services Module is in Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.
firewall#show logging | grep 106021
  Jul 22 2013 00:15:13: %ASA-1-106021: Deny UDP reverse path check from
         192.168.60.1 to 192.168.60.100 on interface outside
  Jul 22 2013 00:15:13: %ASA-1-106021: Deny UDP reverse path check from
         192.168.60.1 to 192.168.60.100 on interface outside
  Jul 22 2013 00:15:13: %ASA-1-106021: Deny TCP reverse path check from
         192.168.60.1 to 192.168.60.100 on interface outside
The show asp drop command can also identify the number of packets that the uRPF feature has dropped, as shown in the following example:
firewall#show asp drop frame rpf-violated
  Reverse-path verify failed                          11
firewall#
In the preceding example, uRPF has dropped 11 IP packets received on interfaces with uRPF configured. Absence of output indicates that the uRPF feature on the firewall has not dropped packets.

For additional information about debugging accelerated security path dropped packets or connections, reference the Cisco Security Appliance Command Reference for show asp drop.

Cisco Security Manager

Identification: Cisco Security Manager

Cisco Security Manager, Event Viewer
Beginning in software version 4.0, Cisco Security Manager can collect syslogs from Cisco firewalls and Cisco IPS devices and provides the Event Viewer, which can query for events that are related to the vulnerabilities that are described in this document.

Using the following filters in the Firewall Denied Events predefined view in the Event Viewer provides all captured Cisco firewall access list deny syslog messages that could indicate potential attempts to exploit the vulnerabilities that are described in this document.
  • Use the Destination event filter-to-filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Use the Destination Service event filter-to-filter objects that contain TCP ports 22, 80, 443, 1066, and 8086; and UDP ports 123, 1024–1099, 6000–6999, 16100–16999, 18000–18999, 20000–20999, and 55000–55999
An Event Type ID filter can be used with the Firewall Denied Events predefined view in the Event Viewer to filter the syslog IDs shown in the following list to provide all captured Cisco firewall deny syslog messages that could indicate potential attempts to exploit the vulnerabilities that are described in this document:
  • ASA-4-106023 (ACL deny)
For more information about Cisco Security Manager Events, refer to the Filtering and Querying Events section of the Cisco Security Manager User Guide.
Cisco Security Manager Report Manager
Also in the Report Manager, the Top Services report can be used with the following configuration to generate a report of events that indicate potential attempts to exploit the vulnerabilities that are described in this document:
  • Use the Destination IP network filter to filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Set an action of Deny on the Criteria settings page
For more information about Cisco Security Manager IPS Event Reporting refer to the Understanding IPS Top Reports section of the Cisco Security Manager User Guide.

Identification: Event Management System Partner Events

Cisco works with industry-leading Security Information and Event Management (SIEM) companies through the Cisco Developer Network. This partnership helps Cisco deliver validated and tested SIEM systems that address business concerns such as long-term log archiving and forensics, heterogeneous event correlation, and advanced compliance reporting. Security Information and Event Management partner products can be leveraged to collect events from Cisco devices and then query the collected events for the incidents created by a Cisco IPS signature or deny syslog messages from firewalls that could indicate potential attempts to exploit the vulnerabilities that are described in this document. The queries can be made by Syslog ID as shown in the following list:
  • ASA-4-106023 (ACL deny)
For more information about SIEM partners, refer to the Security Management System website.

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information

 
Alert History
 
Initial Release


Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
CiscoCisco Video Surveillance Operations Manager Software 3.0 .0 | 3.1 .0, .1 | 4.0 .0 | 4.1 .0, .1 | 4.2 .0

Associated Products:
N/A




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield