Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Applied Mitigation Bulletin

Mitigation of the Cisco UCS Director Default Credentials Vulnerability

 
Threat Type:IntelliShield: Applied Mitigation Bulletin
IntelliShield ID:32757
Version:1
First Published:2014 February 19 16:02 GMT
Last Published:2014 February 19 16:02 GMT
Port: Not available
CVE:CVE-2014-0709
Urgency:Unlikely Use
Credibility:Confirmed
Severity:Moderate Damage
Related Resources:
View related Security Advisory
 
 
Version Summary:Cisco Applied Mitigation Bulletin initial public release
 

Cisco Response

This Applied Mitigation Bulletin is a companion document to the PSIRT Security Advisory Cisco UCS Director Default Credentials Vulnerability and provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

A vulnerability in Cisco Unified Computing System (UCS) Director could allow an unauthenticated, remote attacker to take complete control of the affected device. The vulnerability is due to a default root user account created during installation. The vulnerability uses SSH IPv4 and IPv6 packets and does not require the interaction of trusted users.

The attack vector for exploitation is through SSH using TCP port 22 over IPv4 and IPv6 packets.

This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) identifier CVE-2014-0709.

Mitigation Technique Overview

Cisco devices provide several countermeasures for this vulnerability. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using Infrastructure Access Control Lists (iACL). This protection mechanism filters and drops packets that are attempting to exploit this vulnerability.

Effective exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance, Cisco Catalyst 6500 Series ASA Services Module (ASASM), and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers using Transit Access Control Lists (tACL). This protection mechanism filters and drops packets that are attempting to exploit this vulnerability.

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of these vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

Caution:The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Infrastructure Access Control Lists

To protect infrastructure devices and minimize the risk, impact, and effectiveness of direct infrastructure attacks, administrators are advised to deploy iACLs to perform policy enforcement of traffic sent to infrastructure equipment. Administrators can construct an iACL by explicitly permitting only authorized traffic sent to infrastructure devices in accordance with existing security policies and configurations. For the maximum protection of infrastructure devices, deployed iACLs should be applied in the ingress direction on all interfaces to which an IP address has been configured. An iACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The iACL policy denies unauthorized IPv4 and IPv6 packets on TCP port 22 that are sent to affected devices. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic. Whenever possible, infrastructure address space should be distinct from the address space used for user and services segments. Using this addressing methodology will assist with the construction and deployment of iACLs.

For additional information about iACLs, see Protecting Your Core: Infrastructure Protection Access Control Lists.

ip access-list extended Infrastructure-ACL-Policy 
  !
  !-- Include explicit permit statements for trusted sources that
  !-- require access on the vulnerable TCP port
  !
  permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22
  !
  !-- The following vulnerability-specific access control entry
  !-- (ACE) can aid in identification of attacks
  !
  deny tcp any 192.168.60.0 0.0.0.255 eq 22
  !
  !-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
  !-- with existing security policies and configurations
  !
  !-- Explicit deny for all other IP traffic
  !
  deny ip any 192.168.60.0 0.0.0.255
  !
!
!-- Create the corresponding IPv6 tACL
!
ipv6 access-list IPv6-Infrastructure-ACL-Policy
  !
  !-- Include explicit permit statements for trusted sources that
  !-- require access on the vulnerable TCP port
  !
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 22
  !
  !-- The following vulnerability-specific ACE can
  !-- aid in identification of attacks to global and
  !-- link-local addresses
  !
  deny tcp any 2001:DB8:1:60::/64 eq 22
  !
  !-- Permit or deny all other Layer 3 and Layer 4 traffic in
  !-- accordance with existing security policies and configurations
  !-- and allow IPv6 neighbor discovery packets, which
  !-- include neighbor solicitation packets and neighbor
  !-- advertisement packets
  !
  permit icmp any any nd-ns
  permit icmp any any nd-na
  !
  !-- Explicit deny for all other IPv6 traffic
  !
  deny ipv6 any 2001:DB8:1:60::/64
  !
  !
  !-- Apply tACLs to interface in the ingress direction
  !
interface GigabitEthernet0/0
 ip access-group Infrastructure-ACL-Policy in 
 ipv6 traffic-filter IPv6-Infrastructure-ACL-Policy in 

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration commands no ip unreachables and no ipv6 unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration commands ip icmp rate-limit unreachable interval-in-ms and ipv6 icmp error-interval interval-in-ms.

For information about how to use the Cisco IOS Software command line interface to gauge the effectiveness of the iACL, see the Cisco Security Intelligence Operations white paper Identifying the Effectiveness of Security Mitigations Using Cisco IOS Software.

Cisco ASA, Cisco ASASM, and Cisco FWSM Firewalls

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against this vulnerability when the attack originates from a trusted source address.

The tACL policy denies unauthorized IPv4 and IPv6 packets on and that are sent to affected devices. In the following example, 192.168.60.0/242001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.

  !
  !-- Include explicit permit statements for trusted sources
  !-- that require access on the vulnerable TCP port
  !
  access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 0.0.0.255 eq 22
  !
  !-- The following vulnerability-specific access control entry
  !-- (ACE) can aid in identification of attacks
  !
  access-list tACL-Policy extended deny tcp any 192.168.60.0 0.0.0.255 eq 22
  !
  !-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
  !-- with existing security policies and configurations
  !
  !-- Explicit deny for all other IP traffic
  !
  access-list tACL-Policy extended deny ip any 192.168.60.0 0.0.0.255
  !
!
!-- Create the corresponding IPv6 tACL
!
  !
  !-- Include explicit permit statements for trusted sources that
  !-- require access on the vulnerable TCP port
  !
  ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1 
     2001:DB8:1:60::/64 eq 22
  !
  !-- The following vulnerability-specific ACE can
  !-- aid in identification of attacks
  !
  ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:DB8:1:60::/64 eq 22
  !
  !-- Permit or deny all other Layer 3 and Layer 4 traffic in
  !-- accordance with existing security policies and configurations
  !
  !
  !-- Explicit deny for all other IPv6 traffic
  !
  ipv6 access-list IPv6-tACL-Policy deny ip any any
  !
  !
  !-- Apply tACLs to interfaces in the ingress direction
  !
  access-group tACL-Policy in interface outside
  access-group IPv6-tACL-Policy in interface outside

For information about using the Cisco firewall command-line interface to gauge the effectiveness of tACLs, see the Cisco Security Intelligence Operations white paper Identification of Security Exploits with Cisco ASA, Cisco ASASM, and Cisco FWSM Firewalls.

Starting in Cisco ASA Software Release 9.0, ACLs (namely unified ACLs) support IPv4 and IPv6 addresses. A mix of IPv4 and IPv6 addresses can be specified for the source and destination of the ACL. The any4 and any6 keywords were added to represent IPv4-only and IPv6-only traffic, respectively.

The IPv4 and IPv6 access list entries (ACEs) presented in the IPv4 and IPv6 ACLs of this section could also be incorporated in one unified ACL.

For more information about unified ACLs, refer to the Adding an Extended Access List section of the Cisco ASA configuration guide.

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information

 
Alert History
 

Alert History

Initial Release


Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
CiscoCisco Unified Computing System Director 3.4 Base | 4.0 Base

Associated Products:
N/A




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield