Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Applied Mitigation Bulletin

Cisco Applied Mitigation Bulletin: Microsoft Security Bulletin Release for December 2011

 
Threat Type:IntelliShield: Applied Mitigation Bulletin
IntelliShield ID:24744
Version:3
First Published:2011 December 13 19:41 GMT
Last Published:2011 December 21 15:13 GMT
Port: Not available
CVE:CVE-2011-1508 , CVE-2011-1983 , CVE-2011-1992 , CVE-2011-2010 , CVE-2011-2018 , CVE-2011-2019 , CVE-2011-3396 , CVE-2011-3397 , CVE-2011-3400 , CVE-2011-3401 , CVE-2011-3402 , CVE-2011-3403 , CVE-2011-3404 , CVE-2011-3406 , CVE-2011-3408 , CVE-2011-3410 , CVE-2011-3411 , CVE-2011-3412 , CVE-2011-3413
Urgency:Possible use
Credibility:Confirmed
Severity:Moderate Damage
 
 
Version Summary:

IPS signature event data from Cisco Remote Management Services is available for IPS signatures from December 20, 2011.

 

Contents

Introduction
Device-Specific Mitigation and Identification
Additional Information
Cisco Security Procedures
Related Information

Introduction

Microsoft announced 13 security bulletins that address 19 vulnerabilities as part of the monthly security bulletin release on December 13, 2011. A summary of these bulletins is on the Microsoft website at http://technet.microsoft.com/en-us/security/bulletin/ms11-dec. This document provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

The vulnerabilities that have a client software attack vector, can be exploited locally on the vulnerable device, require user interaction, can be exploited using web-based attacks (these include but are not limited to cross-site scripting, phishing, and web-based e-mail threats) or e-mail attachments, and files stored on network shares are in the following list:

The vulnerabilities that have a network mitigation are in the following list. Cisco devices provide several countermeasures for the vulnerabilities that have a network attack vector, which will be discussed in detail later in this document.

Information about affected and unaffected products is available in the respective Microsoft advisories and the Cisco IntelliShield alerts that are referenced in Cisco Event Response: Microsoft Security Bulletin Release for December 2011.

In addition, multiple Cisco products use Microsoft operating systems as their base operating system. Cisco products that may be affected by the vulnerabilities described in the referenced Microsoft advisories are detailed in the "Associated Products" table in the "Product Sets" section.

Vulnerability Characteristics

MS11-090, Cumulative Security Update of ActiveX Kill Bits (2618451): This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) identifier CVE-2011-3397. This vulnerability can be exploited remotely without authentication and requires user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation of this vulnerability is through HTTP packets that typically use TCP port 80 but may also use TCP ports 3128, 8000, 8010, 8080, 8888, and 24326.

The Cisco ASA 5500 Series Adaptive Security Appliance, Cisco Catalyst 6500 Series ASA Services Module (ASASM) and Cisco Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers provide protection for potential attempts to exploit this vulnerability. For configuration and use information see the Preventing ActiveX Exploits with Cisco Firewall Application Layer Protocol Inspection Cisco Security white paper.

The Cisco ACE Application Control Engine Appliance and Module provide protection for potential attempts to exploit this vulnerability. For configuration and use information see the Preventing ActiveX Exploits with Cisco Application Control Engine Application Layer Protocol Inspection Cisco Security white paper.

Cross-site scripting and phishing could also be used to exploit this vulnerability. For additional information about cross-site scripting attacks and the methods used to exploit this vulnerability, refer to the Cisco Applied Mitigation Bulletin Understanding Cross-Site Scripting (XSS) Threat Vectors.

MS11-092, Vulnerability in Windows Media Could Allow Remote Code Execution (2648048): This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) identifier CVE-2011-3401. This vulnerability can be exploited remotely with authentication and requires user interaction. Successful exploitation of this vulnerability may allow arbitrary code execution. The attack vector for exploitation of this vulnerability is through HTTP packets that typically use TCP port 80 but may also use TCP ports 3128, 8000, 8010, 8080, 8888, and 24326.

MS11-094, Vulnerabilities in Microsoft PowerPoint Could Allow Remote Code Execution (2639142): This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) identifier CVE-2011-3396. This vulnerability can be exploited remotely without authentication and requires user interaction. Successful exploitation of the vulnerability that is associated with CVE-2011-3396 may allow arbitrary code execution. The attack vector for exploitation of CVE-2011-3396 is through SMB using TCP port 139 and TCP 445 packets.

MS11-095, Vulnerability in Active Directory Could Allow Remote Code Execution (2640045 ): This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) identifier CVE-2011-3406. This vulnerability can be exploited remotely with authentication and with user interaction. Successful exploitation of the vulnerability that is associated with CVE-2011-3406 may allow remote code execution. The attack vector for exploitation of CVE-2011-3406 is through Lightweight Directory Access Protocol (LDAP) packets using TCP port 389, LDAP over Transport Layer Security (TLS)/SSL packets using TCP port 636, Microsoft Global Catalog packets using TCP port 3268 or Microsoft Global Catalog with LDAP/SSL packets using TCP port 3269.

MS11-099, Cumulative Security Update for Internet Explorer (2618444): These vulnerabilities have been assigned Common Vulnerabilities and Exposures (CVE) identifiers CVE-2011-1992 and CVE-2011-2019. These vulnerabilities can be exploited remotely without authentication and require user interaction.

Successful exploitation of the vulnerability that is associated with CVE-2011-1992 could allow an attacker to view content from another domain or Internet Explorer zone. The attack vector for exploitation of CVE-2011-1992 is through HTTP packets that typically use TCP port 80 but may also use TCP ports 3128, 8000, 8010, 8080, 8888, and 24326.

Cross-site scripting and phishing could also be used to exploit this vulnerability. For additional information about cross-site scripting attacks and the methods used to exploit this vulnerability, refer to the Cisco Applied Mitigation Bulletin Understanding Cross-Site Scripting (XSS) Threat Vectors.

Successful exploitation of the vulnerability that is associated with CVE-2011-2019 may result in an attacker gaining the privileges of the logged in user. The attack vector for exploitation of CVE-2011-2019 is through SMB using TCP port 139 and TCP port 445 packets.

Information about vulnerable, unaffected, and fixed software is available in the Microsoft Security Bulletin Summary for December 2011, which is available at the following link: http://www.microsoft.com/technet/security/bulletin/ms11-dec.mspx

Mitigation Technique Overview

The vulnerabilities that have a client software attack vector, can be exploited locally on the vulnerable device, require user interaction, or can be exploited using web-based attacks (these include but are not limited to cross-site scripting, phishing, and web-based e-mail threats) or e-mail attachments, and files stored on network shares are in the following list:

These vulnerabilities are mitigated most successfully at the endpoint through software updates, user education, desktop administration best practices, and endpoint protection software such as Host Intrusion Prevention System (HIPS) or antivirus products.

The vulnerabilities that have a network mitigation are in the following list. Cisco devices provide several countermeasures for these vulnerabilities. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using transit access control lists (tACLs).

This protection mechanism filters and drops packets that are attempting to exploit the vulnerabilities that have a network attack vector.

Effective means of exploit prevention can also be provided by Cisco ASA 5500 Series Adaptive Security Appliance, Cisco Catalyst 6500 Series ASA Services Module (ASASM), and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers using the following methods:

  • tACLs
  • Application layer protocol inspection

These protection mechanisms filter and drop packets that are attempting to exploit the vulnerabilities that have a network attack vector.

Effective exploit prevention can also be provided by the Cisco ACE Application Control Engine Appliance and Module using application protocol inspection.

Cisco IOS NetFlow records can provide visibility into network-based exploitation attempts.

Cisco IOS Software, Cisco ASA, Cisco ASASM, Cisco FWSM firewalls, and Cisco ACE Application Control Engine Appliance and Module can provide visibility through syslog messages and counter values displayed in the output from show commands.

Effective use of Cisco Intrusion Prevention System (IPS) event actions provides visibility into and protection against attacks that attempt to exploit these vulnerabilities as discussed later in this document.

The Cisco Security Manager can also provide visibility through incidents, queries, and event reporting.

 

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of these vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

Caution: The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Transit Access Control Lists

For MS11-094, MS11-095 and MS11-099, to protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy transit access control lists (tACLs) to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized IPv4 and IPv6 SMB packets on TCP port 139 and 445 and LDAP and Secure LDAP packets on TCP ports 389, 636, 3268 and 3269 that are sent to affected devices. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is available in Transit Access Control Lists: Filtering at Your Edge.

!-- Include explicit permit statements for trusted
!-- sources that require access on the vulnerable
!-- ports for MS11-094 and MS11-099
!
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 139
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 445
!
!-- Include explicit permit statements for trusted
!-- sources that require access on the vulnerable
!-- ports for MS11-095
!
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 389
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 636
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 3268
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 3269
!
!-- The following vulnerability-specific access control entries (ACEs) 
!-- can aid in identification of attacks against MS11-089 and MS11-094
!
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 139
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 445
!
!-- The following vulnerability-specific ACEs can
!-- aid in identification of attacks against MS11-095
!
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 389
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 636
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 3268
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 3269
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
access-list 150 deny ip any any
!
!-- Create the corresponding IPv6 tACL
!
ipv6  access-list IPv6-Transit-ACL-Policy
  !  
  !-- Include explicit permit statements for trusted sources
  !-- that require access on the vulnerable protocols and ports
  !
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 139
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 445
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 389
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 636
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 3268
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 3269
  !
  !-- The following vulnerability-specific ACEs can 
  !-- aid in identification of attacks to global and
  !-- link-local addresses
  !
  deny tcp any 2001:DB8:1:60::/64 eq 139
  deny tcp any 2001:DB8:1:60::/64 eq 445
  deny tcp any 2001:DB8:1:60::/64 eq 389
  deny tcp any 2001:DB8:1:60::/64 eq 636
  deny tcp any 2001:DB8:1:60::/64 eq 3268
  deny tcp any 2001:DB8:1:60::/64 eq 3269
  !
  !-- Permit or deny all other Layer 3 and Layer 4 traffic in 
  !-- accordance with existing security policies and configurations
  !-- and allow IPv6 neighbor discovery packets, which
  !-- include neighbor solicitation packets and neighbor
  !-- advertisement packets
  !
  permit icmp any any nd-ns
  permit icmp any any nd-na
  ! 
!-- Explicit deny for all other IPv6 traffic !

deny ipv6 any any ! ! !-- Apply tACLs to interfaces in the ingress direction ! interface GigabitEthernet0/0 ip access-group 150 in ipv6 traffic-filter IPv6-Transit-ACL-Policy in

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration commands no ip unreachables and no ipv6 unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration commands ip icmp rate-limit unreachable interval-in-ms and ipv6 icmp error-interval interval-in-ms.

Identification: Transit Access Control Lists

After the administrator applies the tACL to an interface, show ip access-lists and show ipv6 access-list commands will identify the number of IPv4 and IPv6 SMB packets on TCP port 139 and 445 and LDAP and Secure LDAP packets on TCP ports 389, 636, 3268 and 3269 that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ip access-lists 150 and show ipv6 access-list IPv6-Transit-ACL-Policy follows:

router#show ip access-lists 150
Extended IP access list 150
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 139
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 445
    30 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 389
    40 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 636
    50 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 3268
    60 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 3269
    70 deny tcp any 192.168.60.0 0.0.0.255 eq 139 (14 matches)
    80 deny tcp any 192.168.60.0 0.0.0.255 eq 445 (28 matches)
    90 deny tcp any 192.168.60.0 0.0.0.255 eq 389 (19 matches)
    100 deny tcp any 192.168.60.0 0.0.0.255 eq 636 (8 matches)
    110 deny tcp any 192.168.60.0 0.0.0.255 eq 3268 (7 matches)
    120 deny tcp any 192.168.60.0 0.0.0.255 eq 3269 (11 matches)
    130 deny ip any any
router#

In the preceding example, access list 150 has dropped the following packets received from an untrusted host or network:

  • 14 SMB packets on TCP port 139 for ACE line 70
  • 28 SMB packets on TCP port 445 for ACE line 80
  • 19 LDAP packets on TCP port 389 for ACE line 90
  • 8 Secure LDAP packets on TCP port 636 for ACE line 100
  • 7 LDAP packets on TCP port 3268 for ACE line 110
  • 11 Secure LDAP packets on TCP port 3269 for ACE line 120
router#show ipv6 access-list IPv6-Transit-ACL-Policy 
IPv6 access list IPv6-Transit-ACL-Policy
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 139 (55 matches) sequence 10
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 445 (38 matches) sequence 20
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 389 (210 matches) sequence 30
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 636 (59 matches) sequence 40
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 3268 (10 matches) sequence 50
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 3269 (9 matches) sequence 60
    deny tcp any 2001:DB8:1:60::/64 eq 139 (30 matches) sequence 70
    deny tcp any 2001:DB8:1:60::/64 eq 445 (51 matches) sequence 80
    deny udp any 2001:DB8:1:60::/64 eq 389 (21 matches) sequence 90
    deny udp any 2001:DB8:1:60::/64 eq 389 (18 matches) sequence 100
    deny udp any 2001:DB8:1:60::/64 eq 3268 (17 matches) sequence 110
    deny udp any 2001:DB8:1:60::/64 eq 3269 (16 matches) sequence 120
    permit icmp any any nd-ns (41 matches) sequence 130
    permit icmp any any nd-na (41 matches) sequence 140
    deny ipv6 any any (21 matches) sequence 150

In the preceding example, access list IPv6-Transit-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 30 SMB packets on TCP port 139 for ACE line 70
  • 51 SMB packets on TCP port 445 for ACE line 80
  • 21 LDAP packets on TCP port 389 for ACE line 90
  • 18 Secure LDAP packets on TCP port 636 for ACE line 100
  • 17 LDAP packets on TCP port 3268 for ACE line 110
  • 16 Secure LDAP packets on TCP port 3269 for ACE line 120

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Cisco Security white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: Access List Logging

The log and log-input access control list (ACL) option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

For Cisco IOS Software, the ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by IPv4 ACL logging. The logging rate-limit rate-per-second [except loglevel] command limits the impact of log generation and transmission.

The CPU impact from ACL logging can be addressed in hardware on the Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging.

For additional information about the configuration and use of ACL logging, reference the Understanding Access Control List Logging Cisco Security white paper.

Cisco IOS NetFlow and Cisco IOS Flexible NetFlow

Identification: IPv4 Traffic Flow Identification Using Cisco IOS NetFlow

For MS11-094, MS11-095 and MS11-099, administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv4 traffic flows that may be attempts to exploit the vulnerabilities described in this document that have a network attack vector. Administrators are advised to investigate flows to determine whether they are attempts to exploit the vulnerabilities or whether they are legitimate traffic flows.

router#show ip cache flow
IP packet size distribution (90784136 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .698 .011 .001 .004 .005 .000 .004 .000 .000 .003 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .001 .256 .000 .010 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  1885 active, 63651 inactive, 59960004 added
  129803821 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  0 active, 16384 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet    11393421      2.8         1    48      3.1       0.0       1.4
TCP-FTP            236      0.0        12    66      0.0       1.8       4.8
TCP-FTPD            21      0.0     13726  1294      0.0      18.4       4.1
TCP-WWW          22282      0.0        21  1020      0.1       4.1       7.3
TCP-X              719      0.0         1    40      0.0       0.0       1.3
TCP-BGP              1      0.0         1    40      0.0       0.0      15.0
TCP-Frag         70399      0.0         1   688      0.0       0.0      22.7
TCP-other     47861004     11.8         1   211     18.9       0.0       1.3
UDP-DNS            582      0.0         4    73      0.0       3.4      15.4
UDP-NTP         287252      0.0         1    76      0.0       0.0      15.5
UDP-other       310347      0.0         2   230      0.1       0.6      15.9
ICMP             11674      0.0         3    61      0.0      19.8      15.5
IPv6INIP            15      0.0         1  1132      0.0       0.0      15.4
GRE                  4      0.0         1    48      0.0       0.0      15.3 
Total:        59957957     14.8         1   196     22.5       0.0       1.5

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  06 A984 0CC4    21
Gi0/0         192.168.11.54   Gi0/1         192.168.60.158  11 0911 00A1     3
Gi0/1         192.168.150.60  Gi0/0         10.89.16.226    06 AA16 0CC5    11
Gi0/0         192.168.13.97   Gi0/1         192.168.60.28   06 B33E 008B     5
Gi0/0         192.168.10.17   Gi0/1         192.168.60.97   06 2789 0185     9
Gi0/0         192.168.13.97   Gi0/1         192.168.60.28   06 DB3E 027C    25
Gi0/0         192.168.10.17   Gi0/1         192.168.60.97   06 5B89 01BD     8
Gi0/0         10.88.226.1     Gi0/1         192.168.202.22  11 007B 007B     1
Gi0/0         192.168.12.185  Gi0/1         192.168.60.239  11 0BD7 00A1     1
Gi0/0         10.89.16.226    Gi0/1         192.168.150.60  06 18CA 008B    10

In the preceding example, there are multiple flows for SMB on TCP ports 139 (hex value 008B) and 445 (hex value 01BD) and LDAP and Secure LDAP on TCP ports 389 (hex value 0185), 636 (hex value 027C), 3268 (hex value 0CC4) and 3269 (hex value 0CC5).

As shown in the following example, to view only the traffic flows for SMB packets on TCP port 139 (hex value 008B) and 445 (hex value 01BD) and LDAP and Secure LDAP packets on TCP ports 389 (hex value 0185), 636 (hex value 027C), 3268 (hex value 0CC4) and 3269 (hex value 0CC5), use the show ip cache flow | include SrcIf|_06_.*(008B|01BD|0185|027C|0CC4|0CC5)_ command to display the related Cisco NetFlow records:

TCP Flows

router#show ip cache flow | include SrcIf|_06_.*(008B|01BD|0185|027C|0CC4|0CC5)_
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.12.110   Gi0/1         192.168.60.163  06 882A 0185     6
Gi0/0         192.168.11.230   Gi0/1         192.168.60.20   06 5A09 0CC4    11
Gi0/0         192.168.11.131   Gi0/1         192.168.60.245  06 4166 008B    18
Gi0/0         192.168.13.7     Gi0/1         192.168.60.162  06 9914 027C     1
Gi0/0         192.168.41.86    Gi0/1         192.168.60.27   06 ED7B 01BD    22

Identification: IPv6 Traffic Flow Identification Using Cisco IOS NetFlow

For MS11-094, MS11-095 and MS11-099, administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv6 traffic flows that may be attempts to exploit the vulnerabilities that are described in this document. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

The following output is from a Cisco IOS device running Cisco IOS Software 12.4 mainline train. The command syntax will vary for different Cisco IOS Software trains.

router#show ipv6 flow cache

IP packet size distribution (50078919 total packets):
   1-32  64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .990 .001 .008 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 475168 bytes
  8 active, 4088 inactive, 6160 added
  1092984 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33928 bytes
  16 active, 1008 inactive, 12320 added, 6160 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x06 0x16C4 0x0185 1464
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...134::3 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::4 Gi0/1    0x3A 0x0000 0x8000 1192    
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x180A 0x0CC5 1597
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x06 0x1510 0x027C 1001  
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x06 0x1484 0x008B 1292  
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x06 0x1610 0x01BD 1001  
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x06 0x1634 0x008B 1292  
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x06 0x1796 0x027C 1001
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x06 0x1682 0x008B 1292  
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::3 Gi0/1    0x3A 0x0000 0x8000 1155
2001:DB...6A:5BA6 Gi0/0    2001:DB...146::3 Gi0/1    0x3A 0x0000 0x8000 1092
2001:DB...6A:5BA6 Gi0/0    2001:DB...144::4 Gi0/1    0x3A 0x0000 0x8000 1193 

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

In the preceding example, there are multiple IPv6 flows for SMB on TCP ports 139 (hex value 008B) and port 445 (hex value 01BD) and LDAP and Secure LDAP on TCP ports 389 (hex value 0185), 636 (hex value 027C), 3268 (hex value 0CC4) and 3269 (hex value 0CC5).

As shown in the following example, to view only the SMB packets on TCP ports 139 (hex value 008B) and 445 (hex value 01BD) and LDAP and Secure LDAP on TCP ports 389 (hex value 0185), 636 (hex value 027C), 3268 (hex value 0CC4) and 3269 (hex value 0CC5), use the show ipv6 flow cache | include SrcIf|_06_.*(008B|01BD|0185|027C|0CC4|0CC5)_ command to display the related Cisco NetFlow records:

TCP Flows

router#show ipv6 flow cache | include SrcIf|_06_.*(008B|01BD|0185|027C|0CC4|0CC5)_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x1776 0x0185  384
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x10A0 0x01BD   97
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x122A 0x027C  662
router#

Identification: IPv4 Traffic Flow Identification Using Cisco IOS Flexible NetFlow

Introduced in Cisco IOS Software Releases 12.2(31)SB2 and 12.4(9)T, Cisco IOS Flexible NetFlow improves original Cisco NetFlow by adding the capability to customize the traffic analysis parameters for the administrator's specific requirements. Original Cisco NetFlow uses a fixed seven tuples of IP information to identify a flow, whereas Cisco IOS Flexible NetFlow allows the flow to be user defined. It facilitates the creation of more complex configurations for traffic analysis and data export by using reusable configuration components.

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv4 flows based on source IPv4 address, as defined by the match ipv4 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv4 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.

!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv4
 match ipv4 source address
 collect ipv4 protocol
 collect ipv4 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv4
 record FLOW-RECORD-ipv4
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
 ip flow monitor FLOW-MONITOR-ipv4 input

The Cisco IOS Flexible NetFlow flow output is a follows:

router#show flow monitor FLOW-MONITOR-ipv4 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                1

  Flows added:                                   9181
  Flows aged:                                    9175
    - Active timeout      (  1800 secs)          9000
    - Inactive timeout    (    15 secs)           175
    - Event aged                                    0
    - Watermark aged                                0
    - Emergency aged                                0

IPV4 SRC ADDR  ipv4 dst addr  trns src port trns dst port intf input intf output pkts ip prot
============== ============== ============= ============= ========== =========== ==== =======
192.168.10.201 192.168.60.102          1456           389      Gi0/0       Gi0/1 1928      6
 192.168.11.54 192.168.60.158           123           139      Gi0/0       Gi0/1  222      6
192.168.150.60   10.89.16.226          2567            53      Gi0/0       Gi0/1   13     17
 192.168.13.97  192.168.60.28          3451           636      Gi0/0       Gi0/1    1      6
 192.168.10.17  192.168.60.97          4231          3269      Gi0/0       Gi0/1  146      6
   10.88.226.1 192.168.202.22          2678           445      Gi0/0       Gi0/1  567      6
  10.89.16.226 192.168.150.60          3562           161      Gi0/0       Gi0/1 30012    17

To view only the SMB packets on TCP ports 139 and 445 and LDAP and Secure LDAP packets on TCP ports 389, 636, 3268 and 3269, use the show flow monitor FLOW-MONITOR-ipv4 cache format table | include IPV4 DST ADDR |_6_.*(139|445|389|636|3268|3269)_ command to display the related NetFlow records.

For more information about Cisco IOS Flexible NetFlow, refer to Flexible Netflow Configuration Guide, Cisco IOS Release 15.1M&T and Cisco IOS Flexible NetFlow Configuration Guide, Release 12.4T.

Identification: IPv6 Traffic Flow Identification Using Cisco IOS Flexible NetFlow

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv6 flows based on the source IPv6 address, as defined by the match ipv6 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv6 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.
!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv6
 match ipv6 source address
 collect ipv6 protocol
 collect ipv6 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv6
 record FLOW-RECORD-ipv6
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
  ipv6 flow monitor FLOW-MONITOR-ipv6 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv6 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                2

  Flows added:                                   539
  Flows aged:                                    532
    - Active timeout      (  1800 secs)          350
    - Inactive timeout    (    15 secs)          182
    - Event aged                                   0
    - Watermark aged                               0
    - Emergency aged                               0

IPV6 SRC ADDR      ipv6 dst addr    trns src port trns dst port intf input intf output pkts ip prot
=================  ================ ============= ============= ========== =========== ==== =======
2001:DB...06::201  2001:DB...28::20         123           123      Gi0/0        Gi0/0   17      17
2001:DB...06::201  2001:DB...28::20        1265           139      Gi0/0        Gi0/0 1237       6
2001:DB...06::201  2001:DB...28::20        1441           445      Gi0/0        Gi0/0 2346       6
2001:DB...06::201  2001:DB...28::20        1890          3268      Gi0/0        Gi0/0 5009       6
2001:DB...06::201  2001:DB...28::20        2856          5060      Gi0/0        Gi0/0  486      17
2001:DB...06::201  2001:DB...28::20        3012            53      Gi0/0        Gi0/0 1016      17
2001:DB...06::201  2001:DB...28::20        2477            53      Gi0/0        Gi0/0 1563      17

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

To view only the SMB packets on TCP ports 139 and 445 and LDAP and Secure LDAP packets on TCP ports 389, 636, 3268 and 3269, use the show flow monitor FLOW-MONITOR-ipv6 cache format table | include IPV6 DST ADDR|_6_.*(139|445|389|636|3268|3269)_ command to display the related Cisco IOS Flexible NetFlow records.

Cisco ASA, Cisco ASASM, and Cisco FWSM Firewalls

Mitigation: Transit Access Control Lists

For MS11-094, MS11-095 and MS11-099, to protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized IPv4 and IPv6 SMB packets on TCP port 139 and 445 and LDAP and Secure LDAP packets on TCP ports 389, 636, 3268 and 3269 that are sent to affected devices. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 is the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.

!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocols and ports
!
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 139
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 445
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 389
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 636
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 3268
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 3269
!
!-- The following vulnerability-specific ACEs
!-- can aid in identification of attacks
!
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 139
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 445
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 389
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 636
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 3268
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 3269
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
access-list tACL-Policy extended deny ip any any
!
!-- Create the corresponding IPv6 tACL
!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocols and ports
!
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 139
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 445
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 389
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 636
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 3268
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 3269
!
!--  The following vulnerability-specific access control entries
!--  (ACEs) can aid in identification of attacks
!
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 139
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 445
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 389
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 636
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 3268
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 3269
!
!--  Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!--  with existing security policies and configurations
!
!--  Explicit deny for all other IP traffic
!
ipv6 access-list IPv6-tACL-Policy deny ip any any
!
!--  Apply tACLs to interfaces in the ingress direction
!
access-group tACL-Policy in interface outside
access-group IPv6-tACL-Policy in interface outside

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the number of IPv4 and IPv6 SMB packets on TCP ports 139 and 445 and LDAP packets on TCP ports 389, 636, 3268 and 3269 that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show access-list tACL-Policy and show access-list IPv6-tACL-Policy follows:

firewall#show access-list tACL-Policy
access-list tACL-Policy; 13 elements; name hash: 0x3452703d
access-list tACL-Policy line 1 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq netbios-ssn (hitcnt=15)
access-list tACL-Policy line 2 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 445 (hitcnt=16)
access-list tACL-Policy line 3 extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq ldap (hitcnt=42)
access-list tACL-Policy line 4 extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq ldaps (hitcnt=27)
access-list tACL-Policy line 5 extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 3268 (hitcnt=37)
access-list tACL-Policy line 6 extended permit udp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 3269 (hitcnt=24)
access-list tACL-Policy line 7 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq netbios-ssn (hitcnt=16)
access-list tACL-Policy line 8 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq 445 (hitcnt=22)
access-list tACL-Policy line 9 extended deny udp any 192.168.60.0 
     255.255.255.0 eq ldap (hitcnt=18)
access-list tACL-Policy line 10 extended deny udp any 192.168.60.0 
     255.255.255.0 eq ldaps (hitcnt=3) 
access-list tACL-Policy line 11 extended deny udp any 192.168.60.0 
     255.255.255.0 eq 3268 (hitcnt=19) 
access-list tACL-Policy line 12 extended deny udp any 192.168.60.0 
     255.255.255.0 eq 3269 (hitcnt=11) 
access-list tACL-Policy line 13 extended deny ip any any (hitcnt=8)

In the preceding example, access list tACL-Policy has dropped the following packets received from an untrusted host or network:

  • 16 SMB packets on TCP port 139 for ACE line 7
  • 22 SMB packets on TCP port 445 for ACE line 8
  • 18 LDAP packets on TCP port 389 for ACE line 9
  • 3 Secure LDAP packets on TCP port 636 for ACE line 10
  • 19 LDAP packets on TCP port 3268 for ACE line 11
  • 11 Secure LDAP packets on TCP port 3269 for ACE line 12
firewall#show access-list IPv6-tACL-Policy                 
ipv6 access-list IPv6-tACL-Policy; 13 elements; name hash: 0x566a4229
ipv6 access-list IPv6-tACL-Policy line 1 permit tcp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq netbios-ssn (hitcnt=56) 
ipv6 access-list IPv6-tACL-Policy line 2 permit tcp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq 445 (hitcnt=43) 
ipv6 access-list IPv6-tACL-Policy line 3 permit udp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq ldap (hitcnt=24) 
ipv6 access-list IPv6-tACL-Policy line 4 permit udp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq ldaps (hitcnt=8) 
ipv6 access-list IPv6-tACL-Policy line 5 permit udp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq 3268 (hitcnt=16) 
ipv6 access-list IPv6-tACL-Policy line 6 permit udp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq 3269 (hitcnt=7) 
ipv6 access-list IPv6-tACL-Policy line 7 deny tcp any 
     2001:db8:1:60::/64 eq netbios-ssn (hitcnt=27)
ipv6 access-list IPv6-tACL-Policy line 8 deny tcp any 
     2001:db8:1:60::/64 eq 445 (hitcnt=13) 
ipv6 access-list IPv6-tACL-Policy line 9 deny udp any 
     2001:db8:1:60::/64 eq ldap (hitcnt=21) 
ipv6 access-list IPv6-tACL-Policy line 10 deny udp any 
     2001:db8:1:60::/64 eq ldaps (hitcnt=17) 
ipv6 access-list IPv6-tACL-Policy line 11 deny udp any 
     2001:db8:1:60::/64 eq 3268 (hitcnt=7) 
ipv6 access-list IPv6-tACL-Policy line 12 deny udp any 
     2001:db8:1:60::/64 eq 3269 (hitcnt=12) 
ipv6 access-list IPv6-tACL-Policy line 13 deny ip any any (hitcnt=27)

In the preceding example, access list IPv6-tACL-Policy has dropped the following packets received from an untrusted host or network:

  • 27 SMB packets on TCP port 139 for ACE line 7
  • 13 SMB packets on TCP port 445 for ACE line 8
  • 21 LDAP packets on TCP port 389 for ACE line 9
  • 17 Secure LDAP packets on TCP port 636 for ACE line 10
  • 7 LDAP packets on TCP port 3268 for ACE line 11
  • 12 Secure LDAP packets on TCP port 3269 for ACE line 12

In addition, syslog message 106023 can provide valuable information, which includes the source and destination IP address, the source and destination port numbers, and the IP protocol for the denied packet.

Identification: Firewall Access List Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an access control entry (ACE) that does not have the log keyword present. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the Cisco Catalyst 6500 Series ASA Services Module is in Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

firewall#show logging | grep 106023
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.18/6789 
         dst inside:192.168.60.191/3268 by access-group "tACL-Policy"
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.200/6790 
         dst inside:192.168.60.33/139 by access-group "tACL-Policy"
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.99/6791 
         dst inside:192.168.60.240/636 by access-group "tACL-Policy"
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.100/6792 
         dst inside:192.168.60.115/139 by access-group "tACL-Policy"
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.88/6793 
         dst inside:192.168.60.38/445 by access-group "tACL-Policy"
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.175/6794 
         dst inside:192.168.60.250/3268 by access-group "tACL-Policy"
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:2001:db8:2::2:172/6795
         dst inside:2001:db8:1:60::23/445 by access-group "IPv6-tACL-Policy"
  Dec 13 2011 00:15:13: %ASA-4-106023: Deny tcp src outside:2001:db8:d::a85e:172/6796
         dst inside:2001:db8:1:60::134/139 by access-group "IPv6-tACL-Policy"
firewall#

In the preceding example, the messages logged for the tACL tACL-Policy show SMB packets for TCP ports 139 and 445 and LDAP and Secure LDAP packets for TCP ports 389, 636, 3268 and 3269 sent to the address block assigned to affected devices.

Additional information about syslog messages for Cisco ASA Series Adaptive Security Appliances is in Cisco ASA 5500 Series System Log Messages, 8.2. Additional information about syslog messages for Cisco Catalyst 6500 Series ASA Services Module is in the Analyzing Syslog Messages section of the Cisco ASASM CLI Configuration Guide. Additional information about syslog messages for the Cisco FWSM is in Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Logging System Log Messages.

For additional information about investigating incidents using syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security white paper.

Mitigation: Application Layer Protocol Inspection

Application layer protocol inspection is available beginning in software release 7.2(1) for the Cisco ASA 5500 Series Adaptive Security Appliance, software release 8.5 for the Cisco Catalyst 6500 Series ASA Services Module, and in software release 4.0(1) for the Cisco Firewall Services Module. This advanced security feature performs deep packet inspection of traffic that transits the firewall. Administrators may construct an inspection policy for applications that require special handling through the configuration of inspection class maps and inspection policy maps, which are applied by means of a global or interface service policy.

Additional information about application layer protocol inspection is in the Configuring Application Layer Protocol Inspection section of the Cisco ASA 5500 Series Configuration Guide using the CLI, 8.2 and the Configuring Application Inspection section of the Cisco Catalyst 6500 Series ASA Services Module CLI Configuration Guide, 8.5.

Caution: Application layer protocol inspection will decrease firewall performance. Administrators are advised to test performance impact in a lab environment before this feature is deployed in production environments.

HTTP Application Inspection

For MS11-090 and MS11-092, by using the HTTP inspection engine on the Cisco ASA 5500 Series Adaptive Security Appliances, Cisco 6500 Series ASA Services Modules, and the Cisco Firewall Services Module, administrators can configure regular expressions (regexes) for pattern matching and construct inspection class maps and inspection policy maps. These methods can help protect against specific vulnerabilities, such as the one described in this document, and other threats that may be associated with HTTP traffic. The following HTTP application inspection configuration uses the Cisco Modular Policy Framework (MPF) to create a policy for inspection of traffic on TCP ports 80, 3128, 8000, 8010, 8080, 8888, and 24326, which are the default ports for the Cisco IPS #WEBPORTS variable. The HTTP application inspection policy will drop connections where the HTTP response body contains any of the regexes that are configured to match the ActiveX control that is associated with these vulnerabilities.

Caution: The configured regexes can match text strings at any location in the body of an HTML response. Care should be taken to ensure that legitimate business applications that use matching text strings without calling the ActiveX control are not affected. Additional information about regex syntax is in Creating a Regular Expression.

Additional information about ActiveX exploits and mitigations that leverage Cisco firewall technologies is available in the Preventing ActiveX Exploits with Cisco Firewall Application Layer Protocol Inspection Cisco Security white paper.

!
!-- Configure regexes for the ActiveX Class ID 
!-- "33FDA1EA-80DF-11d2-B263-00A0C90D6111" and 
!-- "476c391c-3e0d-11d2-b948-00c04fa32195" that
!-- are associated with these vulnerabilities
!
!-- Configure regexes that look for a combination of 
!-- the .dvr-ms file extension and the malicious library
!-- file encdec.dll that is typically used to exploit
!-- the vulnerability associated with MS11-092
! 
regex MS11-090_1 "33[Ff][Dd][Aa]1[Ee][Aa][-]80[Dd][Ff}[-]
                  11[Dd]2[-][Bb]263[-]00[Aa]0[Cc]90[Dd]6111"
regex MS11-090_2 "476[Cc]391[Cc][-]3[Ee]0[Dd][-]11[Dd]
                  2[-][Bb]948[-]00[Cc]04[Ff][Aa]32195"
regex MS11-092_1 ".+\x2e[Dd][Vv][Rr][-][Mm][Ss].*
                  [Ee][Nn][Cc][Dd][Ee][Cc]\x2e[Dd][Ll][Ll]"
regex MS11-092_2 "[Ee][Nn][Cc][Dd][Ee][Cc]\x2e[Dd][Ll][Ll]
                  .+\x2e[Dd][Vv][Rr][-][Mm][Ss]"
! 
!-- Configure a regex class to match on the regular  
!-- expressions that are configured above
!
class-map type regex match-any MS11-090_regex_class
 match regex MS11-090_1
 match regex MS11-090_2

class-map type regex match-any MS11-092_regex_class
 match regex MS11-092_1
 match regex MS11-092_2
!
!-- Configure an object group for the default ports that 
!-- are used by the Cisco IPS #WEBPORTS variable, which 
!-- are TCP ports 80 (www), 3128, 8000, 8010, 8080, 8888, 
!-- and 24326
!
object-group service WEBPORTS tcp
 port-object eq www 
 port-object eq 3128 
 port-object eq 8000 
 port-object eq 8010 
 port-object eq 8080 
 port-object eq 8888 
 port-object eq 24326 
!
!-- Configure an access list that uses the WEBPORTS object 
!-- group, which will be used to match TCP packets that 
!-- are destined to the #WEBPORTS variable that is used 
!-- by a Cisco IPS device
!
access-list Webports_ACL extended permit tcp any any object-group WEBPORTS 
!
!-- Configure a class that uses the above-configured
!-- access list to match TCP packets that are destined
!-- to the ports that are used by the Cisco IPS #WEBPORTS
!-- variable
!
class-map Webports_Class
 match access-list Webports_ACL
!
!-- Configure an HTTP application inspection policy that  
!-- identifies, drops, and logs connections that contain   
!-- the regexes that are configured above
! 
policy-map type inspect http MS_Dec_2011_policy
 parameters
!
!-- "body-match-maximum" indicates the maximum number of 
!-- characters in the body of an HTTP message that
!-- should be searched in a body match. The default value is
!-- 200 bytes. A large number such as shown here may have an
!-- impact on system performance.  Administrators are advised
!-- to test performance impact in a lab environment before 
!-- this command is deployed in production environments
!
  body-match-maximum 1380
 match response body regex class MS11-090_regex_class
  drop-connection log
 match response body regex class MS11-092_regex_class    
  drop-connection log  
!
!-- Add the above-configured "Webports_Class" that matches 
!-- TCP packets that are destined to the default ports  
!-- that are used by the Cisco IPS #WEBPORTS variable to  
!-- the default policy "global_policy" and use it to 
!-- inspect HTTP traffic that transits the firewall
! 
policy-map global_policy
 class Webports_Class
  inspect http MS_Dec_2011_policy 
!
!-- By default, the policy "global_policy" is applied 
!-- globally, which results in the inspection of 
!-- traffic that enters the firewall from all interfaces 
!
service-policy global_policy global

For additional information about the configuration and use of object groups, reference the Cisco ASA 5500 Series Configuration Guide using the CLI, 8.2 for Configuring Object Groups and the Configuring Objects and Access Lists section of the Cisco Catalyst 6500 Series ASA Services Module CLI Configuration Guide, 8.5.

Additional information about HTTP application inspection and the MPF is in the HTTP Inspection Overview section of the Cisco ASA 5500 Series Configuration Guide using the CLI, 8.2.

Identification: Application Layer Protocol Inspection

Firewall syslog message 415007 will be generated when an HTTP message body matches a user-defined regular expression. The syslog message will identify the corresponding HTTP class and HTTP policy and indicate the action applied to the HTTP connection. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 415007.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog for the Cisco Catalyst 6500 Series ASA Services Module is in Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate attempts to exploit these vulnerabilities. Administrators can use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

HTTP Application Inspection

firewall#show logging | grep 415007
Dec 13 2011 14:35:54: %ASA-5-415007: HTTP - matched Class 22: MS11-090_regex_class in policy-map MS_Dec_2011_policy, Body matched - Dropping connection from outside:192.0.2.63/2130 to inside:192.168.60.85/80 Dec 13 2011 14:35:55: %ASA-5-415007: HTTP - matched Class 20: MS11-092_regex_class in policy-map MS_Dec_2011_policy, Body matched - Dropping connection from inside:192.168.60.86/2133 to outside:192.0.2.63/80

With HTTP application inspection enabled, the show service-policy inspect protocol command will identify the number of HTTP packets that are inspected and dropped by this feature. The following example shows output for show service-policy inspect http:

firewall# show service-policy inspect http
Global policy: 
  Service-policy: global_policy
    Class-map: inspection_default
    Class-map: Webports_Class
      Inspect: http MS_Dec_2011_policy, packet 5025, drop 20, reset-drop 0
       protocol violations
          packet 0        
       match response body regex class MS11-090_regex_class
         drop-connection log, packet 13
       match response body regex class MS11-092_regex_class
         drop-connection log, packet 7

In the preceding example, 5025 HTTP packets have been inspected and 20 HTTP packets have been dropped.

Cisco ACE

Mitigation: Application Protocol Inspection

Application protocol inspection is available for the Cisco ACE Application Control Engine Appliance and Module. This advanced security feature performs deep packet inspection of traffic that transits the Cisco ACE device. Administrators can construct an inspection policy for applications that require special handling through the configuration of inspection class maps and inspection policy maps, which are applied via a global or interface service policy.

Additional information about application protocol inspection is in the Configuring Application Protocol Inspection section of the Cisco ACE 4700 Series Appliance Security Configuration Guide.

HTTP Deep Packet Inspection

To conduct HTTP deep packet inspection for MS11-090 and MS11-092, administrators can configure regular expressions (regexes) for pattern matching and construct inspection class maps and inspection policy maps. These methods can help protect against specific vulnerabilities, such as the one described in this document, and other threats that may be associated with HTTP traffic. The following HTTP application protocol inspection configuration inspects traffic on TCP ports 80, 3128, 8000, 8010, 8080, 8888, and 24326, which are the default ports for the Cisco IPS #WEBPORTS variable. The HTTP application protocol inspection policy will drop connections where the HTTP content contains any of the regexes that are configured to match the ActiveX control that is associated with these vulnerabilities.

Caution: The configured regexes can match text strings at any location in the content of an HTML packet. Care should be taken to ensure that legitimate business applications that use matching text strings without calling the ActiveX control are not affected.

Additional information about ActiveX exploits and mitigations that leverage the Cisco ACE Application Control Engine Appliance and Module is available in the Preventing ActiveX Exploits with Cisco Application Control Engine Application Layer Protocol Inspection Cisco Security white paper.

    
! 
!-- Configure an HTTP application inspection class that
!-- looks for HTTP packets that contain the regexes for the
!-- ActiveX Class ID 
!-- "33FDA1EA-80DF-11d2-B263-00A0C90D6111" 
!-- and ActiveX Class ID
!-- "476c391c-3e0d-11d2-b948-00c04fa32195" 
!-- that are associated with these vulnerabilities
! 
!-- Configure an HTTP application inspection class that
!-- looks for HTTP packets that contain a combination of
!-- the .dvr-ms file extension and the malicious library 
!-- file encdec.dll that is typically used to exploit
!-- this vulnerability
! 
class-map type http inspect match-any MS11-090_class
  match content ".*33[Ff][Dd][Aa]1[Ee][Aa][-]80[Dd][Ff}[-]
                 11[Dd]2[-][Bb]263[-]00[Aa]0[Cc]90[Dd]611.*"
  match content ".*476[Cc]391[Cc][-]3[Ee]0[Dd][-]11[Dd]
                2[-][Bb]948[-]00[Cc]04[Ff][Aa]32195.*"

class-map type http inspect match-any MS11-092_class
2 match content ".*.+\x2e[Dd][Vv][Rr][-][Mm][Ss].* [Ee][Nn][Cc][Dd][Ee][Cc]\x2e[Dd][Ll][Ll].*"
3 match content ".*[Ee][Nn][Cc][Dd][Ee][Cc]\x2e[Dd][Ll][Ll].* .+\x2e[Dd][Vv][Rr][-][Mm][Ss].*" ! !-- Configure an HTTP application inspection policy that !-- identifies, resets, and logs connections that contain !-- the regexes that are configured above ! policy-map type inspect http all-match MS_Dec_2011 class MS11-090_class reset log class MS11-092_class
reset log ! !-- Configure an access list that matches TCP packets !-- that are destined to the #WEBPORTS variable that is !-- used by a Cisco IPS device ! access-list WEBPORTS line 8 extended permit tcp any any eq www access-list WEBPORTS line 16 extended permit tcp any any eq 3128 access-list WEBPORTS line 24 extended permit tcp any any eq 8000 access-list WEBPORTS line 32 extended permit tcp any any eq 8010 access-list WEBPORTS line 40 extended permit tcp any any eq 8080 access-list WEBPORTS line 48 extended permit tcp any any eq 8888 access-list WEBPORTS line 56 extended permit tcp any any eq 24326 ! !-- Configure a Layer 4 class that uses the above-configured !-- access list to match TCP packets that are destined !-- to the ports that are used by the Cisco IPS #WEBPORTS !-- variable ! class-map match-all L4_http_class match access-list WEBPORTS ! !-- Configure a Layer 4 policy that applies the HTTP application !-- inspection policy configured above to TCP packets that !-- are destined to the ports that are used by the Cisco IPS !-- #WEBPORTS variable ! policy-map multi-match L4_MS_Dec_2011 class L4_http_class inspect http policy MS_Dec_2011 ! !-- Apply the configuration globally across all interfaces, !-- which results in the inspection of all traffic that enters !-- the ACE ! service-policy input L4_MS_Dec_2011

Identification: Application Protocol Inspection

HTTP Deep Packet Inspection

Cisco ACE Application Control Engine syslog message 415007 will be generated when an HTTP message body matches a user-defined regular expression. The syslog message will identify the corresponding HTTP class and HTTP policy and indicate the action applied to the HTTP connection. Additional information about this syslog message is in Cisco ACE 4700 Series Appliance System Message Guide - System Message 415007.

ACE/Admin# show logging | include 415007
Dec 13 2011 15:26:43: %ACE-5-415007: HTTP - matched ms11-090 in policy-map L4_MS_Dec_2011, Body matched - Resetting connection from vlan130:192.0.2.94/1776 to vlan206:192.168.60.63/80 Connection 0x3a Dec 13 2011 15:30:33: %ACE-5-415007: HTTP - matched ms11-092 in policy-map L4_MS_Dec_2011, Body matched - Resetting connection from vlan206:192.168.60.63/80 to vlan130:192.0.2.94/1778 Connection 0x3c

When HTTP deep packet inspection is enabled, the show service-policy policyname detail command will identify the number of HTTP connections that are inspected and dropped by this feature. The following example shows output for show service-policy L4_MS_Dec_2011 detail:

ACE/Admin# show service-policy L4_MS_Dec_2011 detail

Status     : ACTIVE
Description: -----------------------------------------
Context Global Policy: service-policy: L4_MS_Dec_2011 class: L4_http_class inspect http: L7 inspect policy : MS_Dec_2011 Url Logging: DISABLED curr conns : 0 , hit count : 1 dropped conns : 0 client pkt count : 3 , client byte count: 589 server pkt count : 3 , server byte count: 547 conn-rate-limit : 0 , drop-count : 0 bandwidth-rate-limit : 0 , drop-count : 0 L4 policy stats: Total Req/Resp: 4 , Total Allowed: 2 Total Dropped : 2 , Total Logged : 0 L7 Inspect policy : MS_Dec_2011 class/match : MS11-092_class Inspect action : reset log Total Inspected : 2 , Total Matched: 1 Total Dropped OnError: 0 class/match : MS11-090_class Inspect action : reset log Total Inspected : 2 , Total Matched: 1 Total Dropped OnError: 0

In the preceding example, 4 HTTP connections have been inspected and 2 HTTP connections have been dropped.

Additional information about HTTP Deep Packet Inspection and Application Protocol Inspection is in the Configuring Application Protocol Inspection section of the Cisco ACE 4700 Series Appliance Security Configuration Guide.

Cisco Intrusion Prevention System

Mitigation: Cisco IPS Signature Event Actions

Administrators can use the Cisco IPS appliances and services modules to provide threat detection and help prevent attempts to exploit several of the vulnerabilities described in this document. The following table provides an overview of CVE identifiers and the respective Cisco IPS signatures that will trigger events on potential attempts to exploit these vulnerabilities.

CVE ID Signature Release Signature ID Signature Name Enabled Severity Fidelity* Notes
CVE-2011-1992 S612 39647/0 MS Internet Explorer 8 XSS Yes Medium 90
CVE-2011-2019 S559 31419/0 Microsoft Office Insecure Library Loading Vulnerability No High 90
CVE-2011-3397 S612 40466/0 Microsoft Internet Explorer HTML behavior Remote Code Execution Yes High 80
CVE-2011-3410 S612 40406/0 Microsoft Publisher Out-Bounds Array Index Vulnerability Yes High 90
CVE-2011-3411 S612 40386/0 Microsoft Publisher Invalid Pointer Vulnerability Yes High 90
CVE-2011-3412 S612 40446/0 Microsoft Windows Publisher Memory Corruption Yes High 80
CVE-2011-3401 S612 40526/0 Windows Media Player DVR-MS Memory Corruption Vulnerability Yes High 90
CVE-2011-3400 S612 40366/0 Microsoft OLE Handling Code Injection Yes High 90
CVE-2011-3396 S559 31419/0 Microsoft Office Insecure Library Loading Vulnerability No High 90
CVE-2011-3413 S612 40486/0 Microsoft Powerpoint Remote Code Execution Yes High 90
CVE-2011-3403 S612 40426/0 Microsoft OLE Handling Code Injection Yes High 90
CVE-2011-1983 S612 40506/0 Microsoft Word Remote Code Execution Yes High 90

* Fidelity is also referred to as Signature Fidelity Rating (SFR) and is the relative measure of the accuracy of the signature (predefined). The value ranges from 0 through 100 and is set by Cisco Systems, Inc.

Administrators can configure Cisco IPS sensors to perform an event action when an attack is detected. The configured event action performs preventive or deterrent controls to help protect against an attack that is attempting to exploit the vulnerabilities listed in the preceding table.

Cisco IPS sensors are most effective when deployed in inline protection mode combined with the use of an event action. Automatic Threat Prevention for Cisco IPS 7.x and 6.x sensors that are deployed in inline protection mode provides threat prevention against an attack that is attempting to exploit the vulnerability that is described in this document. Threat prevention is achieved through a default override that performs an event action for triggered signatures with a riskRatingValue greater than 90.

For additional information about the risk rating and threat rating calculation, reference Risk Rating and Threat Rating: Simplify IPS Policy Management.

Cisco IPS Signature Event Data

The following data has been compiled through remote monitoring services provided by the Cisco Remote Management Services team from a sample group of Cisco IPS sensors running Cisco IPS Signature Update version S612 or greater. The purpose of this data is to provide visibility into attempts to exploit the vulnerabilities released as part of the Microsoft December Security Update released on December 13th, 2011. This data was gathered from events triggered on December 20, 2011.

CVE ID Signature ID Percentage of Sensors Reporting the Signature Percentage of Sensors Reporting the Signature Among Top Ten Most-Seen Events
CVE-2011-1992 39647/0 0 0
CVE-2011-2019 31419/0 0 0
CVE-2011-3397 40446/0 0 0
CVE-2011-3410 40406/0 0 0
CVE-2011-3411 40386/0 0 0
CVE-2011-3412 40446/0 0 0
CVE-2011-3401 40526/0 0 0
CVE-2011-3400 40366/0 0 0
CVE-2011-3413 40486/0 0 0
CVE-2011-3403 40426/0 0 0
CVE-2011-1983 40506/0 0 0

Cisco Security Manager

Identification: Cisco Security Manager

Cisco Security Manager, Event Viewer

Beginning in software version 4.0, Cisco Security Manager can collect syslogs from Cisco firewalls and Cisco IPS devices and provides the Event Viewer, which can query for events that are related to the vulnerabilities that are described in this document.

Using the IPS Alert Events predefined view in the Event Viewer, the user can enter the following search strings in the event filter to return all captured events related to the following Cisco IPS signatures:

  • 39647/0
  • 31419/0
  • 40466/0
  • 40406/0
  • 40386/0
  • 40446/0
  • 40526/0
  • 40366/0
  • 40486/0
  • 40426/0
  • 40506/0

Using the following filters in the Firewall Denied Events predefined view in the Event Viewer provides all captured Cisco firewall access list deny syslog messages that could indicate potential attempts to exploit the vulnerabilities that are described in this document.

  • Use the Destination event filter to filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Use the Destination Service event filter to filter objects that contain TCP ports:
    • 139
    • 445
    • 389
    • 636
    • 3268
    • 3269
    • 80
    • 3128
    • 8000
    • 8010
    • 8080
    • 8888
    • 24326

An Event Type ID filter can be used with the Firewall Denied Events predefined view in the Event Viewer to filter the syslog IDs shown in the following list to provide all captured Cisco firewall deny syslog messages that could indicate potential attempts to exploit the vulnerabilities that are described in this document:

  • ASA-4-106023 (ACL deny)
  • ASA-4-415007 (HTTP inspection)

For more information about Cisco Security Manager Events, refer to the Filtering and Querying Events section of the Cisco Security Manager User Guide.

Cisco Security Manager Report Manager

Beginning in software version 4.1, Cisco Security Manager supports the Report Manager, the Cisco IPS event reporting feature. This feature allows an administrator to define reports based on Cisco IPS events of interest. Reports can be scheduled or users can run ad hoc reports as required.

Using the Report Manger, the user can define an IPS Top Signatures report for Cisco IPS devices of interest based on time-range and signature characteristics. When the Signature ID is set to one of the following:

  • 39647/0
  • 31419/0
  • 40466/0
  • 40406/0
  • 40386/0
  • 40446/0
  • 40526/0
  • 40366/0
  • 40486/0
  • 40426/0
  • 40506/0

Cisco Security Manager will generate a comprehensive report that ranks the count of the alerts fired for the signature of interest compared to the total sum of all signature alerts shown in the report.

Also in the Report Manager, the Top Services report can be used with the following configuration to generate a report of events that indicate potential attempts to exploit the vulnerabilities that are described in this document:

  • Use the Destination IP network filter to filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Set an action of Deny on the Criteria settings page

For more information about Cisco Security Manager IPS Event Reporting refer to the Understanding IPS Top Reports section of the Cisco Security Manager User Guide.

Identification: Event Management System Partner Events

Cisco works with industry-leading Security Information and Event Management (SIEM) companies through the Cisco Developer Network. This partnership helps Cisco deliver validated and pretested SIEM systems that address business concerns such as long-term log archiving and forensics, heterogeneous event correlation, and advanced compliance reporting. Security Information and Event Management partner products can be leveraged to collect events from Cisco devices and then query the collected events for the incidents created by a Cisco IPS signature or deny syslog messages from firewalls that could indicate potential attempts to exploit the vulnerabilities that are described in this document. The queries can be made by Sig ID and Syslog ID as shown in the following list:

  • 39647/0 MS Internet Explorer 8 XSS
  • 31419/0 Microsoft Office Insecure Library Loading Vulnerability
  • 40466/0 Microsoft Internet Explorer HTML behavior Remote Code Execution
  • 40406/0 Microsoft Publisher Out-Bounds Array Index Vulnerability
  • 40386/0 Microsoft Publisher Invalid Pointer Vulnerability
  • 40446/0 Microsoft Windows Publisher Memory Corruption
  • 40526/0 Windows Media Player DVR-MS Memory Corruption Vulnerability
  • 40366/0 Microsoft OLE Handling Code Injection
  • 40486/0 Microsoft Powerpoint Remote Code Execution
  • 40426/0 Microsoft Excel Record Memory Corruption Vulnerability
  • 40506/0 Microsoft Word Remote Code Execution
  • ASA-4-106023 (ACL deny)
  • ASA-4-415007 (HTTP inspection)

For more information about SIEM partners, refer to the Security Management System website.

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Cisco Security Procedures

Complete information about reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco is available on Cisco.com at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This web page includes instructions for press inquiries regarding Cisco Security Advisories. All Cisco Security Advisories are available at http://www.cisco.com/go/psirt.

Related Information

Vulnerability Characteristics

Mitigation Technique Overview

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of <this vulnerability | these vulnerabilities>. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

Caution:The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information

 
Alert History
 

Version 1, December 13, 2011, 2:41 PM: This initial version of the Cisco Applied Mitigation Bulletin addresses the Microsoft Security Bulletin Release for December 2011.



Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
Microsoft, Inc.Excel Original Release Base | 95 Base | 98 Base | 97 Base, SR1, SR2 | 2000 Base, SP1, SP2, SP3 | 2002 (XP) Base, SP1, SP2, SP3 | 2003 Base, SP1, SP2, SP3 | 2007 Base, SP1, SP2 | 2010 (32-bit edition) Base | 2010 (64-bit edition) Base
Microsoft, Inc.Internet Explorer 6.0 Base, SP1, SP2 | 7.0 Base | 8.0 Base | 9.0 Base
Microsoft, Inc.Microsoft Office Compatibility Pack for Word, Excel, and PowerPoint 2007 File Formats Original Release Base, SP1, SP2
Microsoft, Inc.Microsoft Office Publisher 99 Base | 2000 Base, SP1, SP2, SP3 | 2002 Base, SP1, SP2, SP3 | 2003 Base, SP1, SP2, SP3 | 2007 Base, SP1, SP2, SP3 | 2010 Base (32-bit Edition), Base (64-bit Edition)
Microsoft, Inc.Office for Mac 98 Base | 2001 Base | 2004 Base | X Base | 2008 Base | 2011 Base
Microsoft, Inc.PowerPoint Original Release Base | 97 Base | 98 Base | 2000 Base, SP1, SP2, SP3 | 2000 (Chinese Edition) Base | 2002 Base, SP1, SP2, SP3 | 2003 Base, SP1, SP2, SP3 | 2007 Base, SP1, SP2, SP3 | 2010 Base, SP1
Microsoft, Inc.Windows 7 for 32-bit systems Base, SP1 | for x64-based systems Base, SP1
Microsoft, Inc.Windows Server 2003 Datacenter Edition Base, SP1, SP2 | Datacenter Edition, 64-bit (Itanium) Base, SP1, SP2 | Datacenter Edition x64 (AMD/EM64T) Base, SP1, SP2 | Enterprise Edition Base, SP1, SP2 | Enterprise Edition, 64-bit (Itanium) Base, SP1, SP2 | Enterprise Edition x64 (AMD/EM64T) Base, SP1, SP2 | Standard Edition Base, SP1, SP2 | Standard Edition, 64-bit (Itanium) Base, SP1, SP2 | Standard Edition x64 (AMD/EM64T) Base, SP1, SP2 | Web Edition Base, SP1, SP2
Microsoft, Inc.Windows Server 2008 Datacenter Edition Base, SP1, SP2 | Datacenter Edition, 64-bit Base, SP1, SP2 | Itanium-Based Systems Edition Base, SP1, SP2 | Enterprise Edition Base, SP1, SP2 | Enterprise Edition, 64-bit Base, SP1, SP2 | Essential Business Server Standard Base, SP1, SP2 | Essential Business Server Premium Base, SP1, SP2 | Essential Business Server Premium, 64-bit Base, SP1, SP2 | Standard Edition Base, SP1, SP2 | Standard Edition, 64-bit Base, SP1, SP2 | Web Server Base, SP1, SP2 | Web Server, 64-bit Base, SP1, SP2
Microsoft, Inc.Windows Server 2008 R2 x64-Based Systems Edition Base, SP1 | Itanium-Based Systems Edition Base, SP1
Microsoft, Inc.Windows Vista Home Basic Base, SP1, SP2 | Home Premium Base, SP1, SP2 | Business Base, SP1, SP2 | Enterprise Base, SP1, SP2 | Ultimate Base, SP1, SP2 | Home Basic x64 Edition Base, SP1, SP2 | Home Premium x64 Edition Base, SP1, SP2 | Business x64 Edition Base, SP1, SP2 | Enterprise x64 Edition Base, SP1, SP2 | Ultimate x64 Edition Base, SP1, SP2
Microsoft, Inc.Windows XP Home Edition Base, SP1, SP2, SP3 | Professional Edition Base, SP1, SP2, SP3 | Professional Edition, 64-bit (Itanium) Base, 2003 (itanium 2), SP1, SP2 | Professional x64 (AMD/EM64T) Base, SP1, SP2 | Tablet PC Edition Base, 2005 | Media Center Edition Base, 2005
Microsoft, Inc.Windows XP Home Original Release Base, SP1, SP1a
Microsoft, Inc.Windows XP Professional Original Release Base, SP1, SP1a

Associated Products:
CiscoCisco Broadband Troubleshooter Original Release Base | 3.1 Base | 3.2 Base
CiscoCisco Building Broadband Service Manager (BBSM) Original Release Base | 2.5 .1 | 3.0 Base | 4.0 Base, .1 | 4.2 Base | 4.3 Base | 4.4 Base | 4.5 Base | 5.0 Base | 5.1 Base | 5.2 Base
CiscoCisco CNS Network Registrar 2.5 Base | 3.0 Base | 3.5 Base, .1 | 5.0 Base | 5.5 Base, .13 | 6.0 .5, .5.2, .5.3, .5.4 | 6.1 Base, .1, .1.1, .1.2, .1.3, .1.4
CiscoCisco Collaboration Server Dynamic Content Adapter (DCA) Original Release Base | 1.0 Base | 2.0 Base, (1)_SR2
CiscoCisco Computer Telephony Integration (CTI) Option 4.7 (0)_SR1, (0)_SR2, (0)_SR3, (0)_SR4 | 5.1 (0)_SR1, (0)_SR2, (0)_SR3 | 6.0 (0)_SR1, (0)_SR2, (0)_SR3, (0)_SR4, (0)_SR5 | 7.0 (0)_SR1, (0)_SR2 | 7.1 (2), (3), (4), (5)
CiscoCisco Conference Connection 1.1 (3), (3)spA | 1.2 Base, (1), (2), (2)SR1, (2)SR2
CiscoCisco E-mail Manager Original Release Base | 4.0 Base, .5i, .6 | 5.0 Base, (0)_SR1, (0)_SR3, (0)_SR4, (0)_SR5, (0)_SR6, (0)_SR7
CiscoCisco Emergency Responder 1.1 Base, (3), (4) | 1.2 Base, (1), (1)SR1, (2), (2)sr1, (3)a, (3)SR1, (3a)SR2 | 1.3 Base, (1a), (2)
CiscoCisco Intelligent Contact Manager (ICM) Original Release Base | 4.6 (2)_SR1, (2)_SR2, (2)_SR3, (2)_SR4, (2)_SR5, (2)_SR6 | 5.0 (0), (0)_SR2, (0)_SR3, (0)_SR4, (0)_SR5, (0)_SR7, (0)_SR8, (0)_SR9, (0)_SR10, (0)_SR11, (0)_SR12, (0)_SR13 | 6.0 (0)_SR1, (0)_SR2, (0)_SR3, (0)_SR4, (0)_SR5, (0)_SR6, (0)_SR7, (0)_SR8, (0)_SR9, (0)_SR10 | 7.0 (0)_SR1, (0)_SR2, (0)_SR3, (0)_SR4 | 7.1 (2), (3), (4), (5)
CiscoCisco Unified Contact Center Enterprise Edition Base, 4.6.2, 5.0, 6.0, 7.0, 7.1, 7.1.1, 7.1.3 | Express Edition Base, 2.0, 2.0.2, 2.1, 2.1.1a, 2.1.2, 2.1.3, 2.2, 2.2.1, 2.2.2, 2.2.3b, 2.2.3b_spE, 3.0, 3.0.2, 3.0.3a_spA, 3.0.3a_spB, 3.0.3a_spC, 3.0.3a_spD, 3.1, 3.1(1)_SR1, 3.1(1)_SR2, 3.1(2)_SR1, 3.1(2)_SR2, 3.1(2)_SR3, 3.1(2)_SR4, 3.1(3)_SR2, 3.1(3)_SR3, 3.1(3)_SR4, 3.1(3)_SR5, 3.5, 3.5.1, 3.5(1)_SR1, 3.5(2)_SR1, 3.5(3), 3.5(3)_SR1, 3.5(3)_SR2, 3.5(3)_SR3, 3.5(4)_SR1, 3.5(4)_SR2, 4.0, 4.0(1)_SR1, 4.0(4)_SR1, 4.0(5)_SR1, 4.1, 4.1(1)_SR1, 4.5, 4.5(2)_SR1, 4.5(2)_SR2, 5.0(1)_SR1 | Hosted Edition Base, 4.6.2, 5.0, 6.0, 7.0, 7.1, 7.1.1, 7.1.3
CiscoCisco Unified IP IVR 2.0 .2 | 2.1 .1a, .2, .3 | 2.2 (5), .1, .2, .3b, .3b_spE, .5, .4 | 3.0 .1_spB, .2, .3a_spA, .3a_spB, .3a_spC, .3a_spD | 3.1 (1)_SR2, (2)_SR1, (2)_SR2, (2)_SR3, (3)_SR1, (3)_SR2, (3)_SR3, (3)_SR4, (3)_SR5 | 3.5 (1)_SR1, (1)_SR2, (1)_SR3, (2)_SR1, (3)_SR1, (3)_SR2, (3)_SR3, (4)_SR1, (4)_SR2, .1, .3 | 4.0 (1)_SR1, (4)_SR1 | 4.1 (1)_SR1 | 4.5 (2)_SR1, (2)_SR2 | 5.0 (1)_SR1
CiscoCisco IP Interoperability and Collaboration System (IPICS) 1.0 (1.1)
CiscoCisco IP Queue Manager 2.2 Base
CiscoCisco IP/VC 3540 Application Server Module 3.2 .0.1, .138 | 3.5 .0.8
CiscoCisco IP/VC 3540 Rate Matching Module 3.0 .9
CiscoCisco Media Blender Original Release Base | 3.0 Base | 4.0 Base | 5.0 Base, (0)_SR1, (0)_SR2
CiscoCisco Networking Services for Active Directory Original Release Base
CiscoCisco Outbound Option Original Release Base
CiscoCisco Personal Assistant 1.0 Base, (1) | 1.1 Base | 1.3 Base, .1, .2, .3, .4 | 1.4 Base, .2, .3, .4, .5, .6
CiscoCisco Remote Monitoring Suite Option 1.0 Base | 2.0 Base, (0)_SR1
CiscoCisco Secure Access Control Server (ACS) for Windows 2.6 Base | 2.6.3.2 Base | 2.6.4 Base | 2.6.4.4 Base | 3.0 Base | 3.0.1 Base | 3.0.1.40 Base | 3.0.2 Base | 3.0.3 Base | 3.0.3.6 Base | 3.0.4 Base | 3.1.1 Base | 3.1.1.27 Base | 3.1.2 Base | 3.2 Base | 3.2.1 Base | 3.2.3 Base | 3.3.1 Base | 3.3.2.2 Base | 3.3.1.16 Base | 3.3.3.11 Base | 4.0 Base | 4.0.1 Base | 4.0.1.27 Base | 4.1.1.23 Base
CiscoCisco Secure Access Control Server Solution Engine (ACSE) 3.1 Base, .1 | 3.2 Base, .1.20, .2.5, .3 | 3.3 Base, .1, .1.16, .2.2, .3, .4, .4.12 | 4.0 Base, .1, .1.42, .1.44, .1.49 | 4.1 Base, .1.23, .1.23.3, .3, .3.12
CiscoCisco Secure User Registration Tool (URT) Original Release Base | 1.2 Base, .1 | 2.0 Base, .7, .8 | 2.5 Base, .1, .2, .3, .4, .5
CiscoCisco SN 5420 Storage Router 1.1 Base, .3, .4, .5, .7, .8 | 2.1 .1, .2
CiscoCisco SN 5428-2 Storage Router 3.2 .1, .2 | 3.3 .1, .2 | 3.4 .1 | 3.5 Base, .1, .2, .3, .4
CiscoCisco Trailhead Original Release Base | 4.0 Base
CiscoCisco Unified Communications Manager Original Release Base | 1.0 Base | 2.0 Base | 3.0 Base | 3.0.3(a) Base | 3.1 Base, .1, .2, .3a | 3.1(1) Base | 3.1(2) Base | 3.1(2)SR3 Base | 3.1(3) Base | 3.1(3)SR2 Base | 3.1(3)SR4 Base | 3.2 Base | 3.2(3)SR3 Base | 3.3 Base | 3.3(2)SPc Base | 3.3(3) Base | 3.3(3)ES61 Base | 3.3(3)SR3 Base | 3.3(3)SR4a Base | 3.3(3a) Base | 3.3(4) Base | 3.3(4)ES25 Base | 3.3(4)SR2 Base | 3.3(4c) Base | 3.3(5) Base | 3.3(5)ES24 Base | 3.3(5)SR1 Base | 3.3(5)SR1a Base | 3.3(5)SR2 Base | 3.3(5)SR2a Base | 3.3(5)SR3 Base | 3.3(59) Base | 3.3(61) Base | 3.3(63) Base | 3.3(64) Base | 3.3(65) Base | 3.3(66) Base | 3.3(67.5) Base | 3.3(68.1) Base | 3.3(71.0) Base | 3.3(74.0) Base | 3.3(78) Base | 3.3(76) Base | 4.0 .1, .2 | 4.0(2a)ES40 Base | 4.0(2a)ES56 Base | 4.0(2a)SR2b Base | 4.0(2a)SR2c Base | 4.1 Base | 4.1(2) Base | 4.1(2)ES33 Base | 4.1(2)ES50 Base | 4.1(2)SR1 Base | 4.1(3) Base | 4.1(3)ES Base | 4.1(3)ES07 Base | 4.1(3)ES24 Base | 4.1(3)SR Base | 4.1(3)SR1 Base | 4.1(3)SR2 Base | 4.1(3)SR3 Base | 4.1(3)SR3b Base | 4.1(3)SR3c Base | 4.1(3)SR4 Base | 4.1(3)SR4b Base | 4.1(3)SR4d Base | 4.1(3)SR5 Base | 4.1(4) Base | 4.1(9) Base | 4.1(17) Base | 4.1(19) Base | 4.1(22) Base | 4.1(23) Base | 4.1(25) Base | 4.1(26) Base | 4.1(27.7) Base | 4.1(28.2) Base | 4.1(30.4) Base | 4.1(36) Base | 4.1(39) Base | 4.2(1) Base | 4.2(1)SR1b Base | 4.2(1.02) Base | 4.2(1.05.3) Base | 4.2(1.06) Base | 4.2(1.07) Base | 4.2(3) Base | 4.2(3)SR1 Base | 4.2(3)SR2 Base | 4.2(3.08) Base | 4.2(3.2.3) Base | 4.2(3.3) Base | 4.2(3.13) Base | 4.3(1) Base | 4.3(1)SR Base | 4.3(1.57) Base
CiscoCisco Unified Customer Voice Portal (CVP) 3.0 (0), (0)SR1, (0)SR2 | 3.1 (0), (0)SR1, (0)SR2 | 4.0 (0), (1), (1)SR1, (2)
CiscoCisco Unified MeetingPlace 4.3 Base | 5.3 Base | 5.2 Base | 5.4 Base | 6.0 Base
CiscoCisco Unified MeetingPlace Express 1.1 Base | 1.2 Base | 2.0 Base
CiscoCisco Unity Original Release Base | 2.0 Base | 2.1 Base | 2.2 Base | 2.3 Base | 2.4 Base | 2.46 Base | 3.0 Base, .1 | 3.1 Base, .2, .3, .5, .6 | 3.2 Base | 3.3 Base | 4.0 Base, .1, .2, .3, .3b, .4, .5 | 4.1 Base, .1 | 4.2 Base, .1, .1 ES27 | 5.0 (1) | 7.0 (2)
CiscoCisco Unity Express 1.0.2 Base | 1.1.1 Base | 1.1.2 Base | 2.0.1 Base | 2.0.2 Base | 2.1.1 Base | 2.1.2 Base | 2.1.3 Base | 2.2.0 Base | 2.2.1 Base | 2.2.2 Base | 2.3.0 Base | 2.3.1 Base
CiscoCisco Wireless Control System (WCS) Software 1.0 Base | 2.0 Base, 44.14, 44.24 | 2.2 .0, .111.0 | 3.0 Base, .101.0, .105.0 | 3.1 Base, .20.0, .33.0, .35.0 | 3.2 Base, .23.0, .25.0, .40.0, .51.0, .64.0 | 4.0 Base, .1.0, .43.0, .66.0, .81.0, .87.0, .96.0, .97.0 | 4.1 Base, .83.0
CiscoCiscoWorks IP Telephony Environment Monitor (ITEM) 1.3 Base | 1.4 Base | 2.0 Base
CiscoCiscoWorks LAN Management Solution (LMS) 1.3 Base | 2.2 Base | 2.5 Base | 2.6 Base
CiscoCiscoWorks QoS Policy Manager (QPM) 2.0 Base, .1, .2, .3 | 2.1 .2 | 3.0 Base, .1 | 3.1 Base | 3.2 Base, .1, .2, .3
CiscoCiscoWorks Routed WAN Management Solution (RWAN) 1.0 Base | 1.1 Base | 1.2 Base | 1.3 Base, .1
CiscoCiscoWorks Small Network Management Solution (SNMS) 1.0 Base | 1.5 Base
CiscoCiscoWorks VPN/Security Management Solution (VMS) 1.0 Base | 2.0 Base | 2.1 Base | 2.2 Base | 2.3 Base
CiscoCisco Collaboration Server 3.0 Base | 3.01 Base | 3.02 Base | 4.0 Base | 5.0 Base
CiscoCisco DOCSIS CPE Configurator 1.0 Base | 1.1 Base | 2.0 Base
CiscoCisco Unified IP Interactive Voice Response (IVR) 2.0 Base | 2.1 Base
CiscoCisco Service Control Engine (SCE) 3.0 Base | 3.1 Base
CiscoCisco Transport Manager Original Release Base | 2.0 Base | 2.1 Base | 2.2 Base, .1 | 3.0 Base, .1, .2 | 3.1 Base | 3.2 Base | 4.0 Base | 4.1 Base, .4, .6, .6.6.1 | 4.6 Base | 4.7 Base | 5.0 Base, .0.867.2, .1.873.2, .2, .2.92.1, .2.99.1, .2.105.1, .2.110.1 | 6.0 Base, .0.405.1, .0.407.1, .0.412.1 | 7.0 Base, .0.370.1, .0.372.1, .0.377.1, .0.389.1, .0.400.1, .395.1 | 7.2 Base, .0.199.1




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield