Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Applied Mitigation Bulletin

Identifying and Mitigating Exploitation of the Cisco ASA-CX and Cisco PRSM Log Retention Denial of Service Vulnerability

 
Threat Type:IntelliShield: Applied Mitigation Bulletin
IntelliShield ID:26840
Version:2
First Published:2012 September 12 16:00 GMT
Last Published:2012 September 13 16:08 GMT
Port: Not available
CVE:CVE-2012-4629
Urgency:Unlikely Use
Credibility:Confirmed
Severity:Moderate Damage
Related Resources:
View related Security Advisory
 
 
Version Summary:This version of the Cisco Applied Mitigation Bulletin has been updated to correct a formatting issue.
 

Cisco Response

This Applied Mitigation Bulletin is a companion document to the PSIRT Security Advisory Cisco ASA-CX and Cisco PRSM Log Retention Denial of Service Vulnerability and provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

Cisco ASA-CX Context-Aware Security appliance and Cisco Prime Security Manager (PRSM) contain a denial of service (DoS) vulnerability in versions prior to 9.0.2-103. Successful exploitation of this vulnerability on the Cisco ASA-CX could cause the device to stop processing user traffic and prevent management access to the Cisco ASA-CX. Successful exploitation of this vulnerability on the Cisco PRSM could cause the software to become unresponsive and unavailable.

The vulnerability is documented in Cisco bug ID CSCub70603 (registered customers only) for Cisco ASA-CX Context-Aware Security and Cisco Prime Security Manager and has been assigned Common Vulnerabilities and Exposures (CVE) ID CVE-2012-4629.

Mitigation Technique Overview

Cisco devices provide several countermeasures for this vulnerability. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using infrastructure access control lists (iACLs). This protection mechanism filters and drops packets that are attempting to exploit this vulnerability.

Effective exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance, Cisco Catalyst 6500 Series ASA Services Module (ASASM), and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers, when an ASA without the CX services module is protecting an ASA CX with a services module.

Cisco IOS NetFlow records can provide visibility into network-based exploitation attempts.

Cisco IOS Software, Cisco ASA, Cisco ASASM, and Cisco FWSM firewalls can provide visibility through syslog messages and counter values displayed in the output from show commands.

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of this vulnerability. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

Caution: The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Infrastructure Access Control Lists

To protect infrastructure devices, and minimize the risk, impact, and effectiveness of direct infrastructure attacks, administrators are advised to deploy infrastructure access control lists (iACLs) to perform policy enforcement of traffic sent to infrastructure equipment. Administrators can construct an iACL by explicitly permitting only authorized traffic sent to infrastructure devices in accordance with existing security policies and configurations. For the maximum protection of infrastructure devices, deployed iACLs should be applied in the ingress direction on all interfaces to which an IP address has been configured. An iACL workaround cannot provide complete protection against this vulnerability when the attack originates from a trusted source address.

The iACL policy below denies unauthorized IPv4 and IPv6 packets on TCP ports 22, TCP 443, UDP port 3799, and ICMP echo requests that are sent to affected ASA-CX management interfaces, and additionally TCP Port 446 and UDP port 514 requests that are sent to affected PRSM server management interfaces. In the following example, 192.168.60.0/24 is the network where the ASA-CX management interface resides, 192.168.60.6/32 is the PRSM server management interface. 2001:DB8:1:60::/64 represents the IPv6 address space that is used by the affected ASA-CX management interface and PRSM Server management interface, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic. Whenever possible, infrastructure address space should be distinct from the address space used for user and services segments. Using this addressing methodology will assist with the construction and deployment of iACLs.

Additional information about iACLs is in Protecting Your Core: Infrastructure Protection Access Control Lists.

ip access-list extended Infrastructure-ACL-Policy
!
!-- Include explicit permit statements for trusted sources
!-- that require access to the management port on the ASA-CX
!

permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22
permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443
permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 3799
permit icmp host 192.168.100.1 192.168.60.0 0.0.0.255 8
!
!-- Include additional permit statements for trusted sources
!-- that require access on the PRSM server
!

permit tcp host 192.168.100.1 host 192.168.60.6 eq 4466
permit udp host 192.168.100.1 host 192.168.60.6 eq 514
!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!

deny tcp any 192.168.60.0 0.0.0.255 eq 22
deny tcp any 192.168.60.0 0.0.0.255 eq 443
deny udp any 192.168.60.0 0.0.0.255 eq 3799
deny icmp any 192.168.60.0 0.0.0.255 8
deny tcp any host 192.168.60.6 eq 4466
deny udp any host 192.168.60.6 eq 514
!
!-- Explicit deny ACE for traffic sent to addresses configured within
!-- the infrastructure address space
!

deny ip any 192.168.60.0 0.0.0.255
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!

!
!-- Create the corresponding IPv6 tACL
!

ipv6 access-list IPv6-Infrastructure-ACL-Policy
!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocol and port
!

permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 22 permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 443
permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 4466
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 3799
permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 514
permit icmp6 host 2001:DB8::100:1 2001:DB8:1:60::/64
!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks to global and
!-- link-local addresses
!

deny tcp any 2001:DB8:1:60::/64 eq 22
deny tcp any 2001:DB8:1:60::/64 eq 443
deny tcp any 2001:DB8:1:60::/64 eq 4466
deny udp any 2001:DB8:1:60::/64 eq 3799
deny udp any 2001:DB8:1:60::/64 eq 514
!
!-- Permit other required traffic to the infrastructure address
!-- range and allow IPv6 neighbor discovery packets, which
!-- include neighbor solicitation packets and neighbor
!-- advertisement packets
!

permit icmp any any nd-ns
permit icmp any any nd-na
!
!-- Explicit deny for all other IPv6 traffic to the global
!-- infrastructure address range
!

deny ipv6 any 2001:DB8:1:60::/64
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic
!-- in accordance with existing security policies and configurations
!

!
!-- Apply tACLs to interfaces in the ingress direction
!

interface GigabitEthernet0/0
ip access-group Infrastructure-ACL-Policy in
ipv6 traffic-filter IPv6-Infrastructure-ACL-Policy in

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration commands no ip unreachables and no ipv6 unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration commands ip icmp rate-limit unreachable interval-in-ms and ipv6 icmp error-interval interval-in-ms.

Identification: Infrastructure Access Control Lists

After the administrator applies the iACL to an interface, the show ip access-lists and show ipv6 access-list commands will identify the number of IPv4 and IPv6 packets that have been filtered on interfaces on which the iACL is applied. Administrators should investigate filtered packets to determine whether they are attempts to exploit this vulnerability. Example output for show ip access-lists Infrastructure-ACL-Policy and show ipv6 access-list IPv6-Infrastructure-ACL-Policy follows:

router#show ip access-lists Infrastructure-ACL-Policy
Extended IP access list Infrastructure-ACL-Policy
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22 (60 matches)
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443 (38 matches)
    30 permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 3799 (47 matches)
    40 permit icmp host 192.168.100.1 192.168.60.0 0.0.0.255 8 (60 matches)
    50 permit tcp host 192.168.100.1 host 192.168.60.6 eq 4466 (45 matches)
    60 permit udp host 192.168.100.1 host 192.168.60.6 eq 514 (46 matches)
    70 deny tcp any 192.168.60.0 0.0.0.255 eq 22 (9 matches)
    80 deny tcp any 192.168.60.0 0.0.0.255 eq 443 (27 matches)
    90 deny udp any 192.168.60.0 0.0.0.255 eq 3799(13 matches)
    100 deny icmp any 192.168.60.0 0.0.0.255 8 (55 matches)
    110 deny tcp any host 192.168.60.6 eq 4466(11 matches)
    120 deny udp any host 192.168.60.6 eq 514 (12 matches)
    130 deny ip any 192.168.60.0 0.0.0.255 (17 matches)
router#

In the preceding example, access list Infrastructure-ACL-Policy has dropped

  • 9 SSH packets on TCP port 22 for access control list entry (ACE) line 70.
  • 27 HTTPS packets on TCP port 443 for access control list entry (ACE) line 80.
  • 13 packets on UDP port 3799 for access control list entry (ACE) line 90.
  • 55 ICMP packets for access control list entry (ACE) line 100.
  • 11 TCP packets on TCP port 4466 for access control list entry (ACE) line 110.
  • 12 SYSLOG packets on UDP port 514 for access control list entry (ACE) line 120.
router#show ipv6 access-list IPv6-Infrastructure-ACL-Policy 
IPv6 access list IPv6-Infrastructure-ACL-Policy
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 22 (71 matches) sequence 10
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 443 (71 matches) sequence 20
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 4466 (71 matches) sequence 30
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 3799 (71 matches) sequence 40
    permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 514 (71 matches) sequence 50
    permit icmp6 any 2001:DB8:1:60::/64 (71 matches) sequence 60
    deny tcp any 2001:DB8:1:60::/64 eq 22 (9 matches) sequence 70
    deny tcp any 2001:DB8:1:60::/64 eq 443 (27 matches) sequence 80
    deny tcp any 2001:DB8:1:60::/64 eq 4466 (13 matches) sequence 90
    deny udp any 2001:DB8:1:60::/64 eq 3799 (55 matches) sequence 100
    deny udp any 2001:DB8:1:60::/64 eq 514 (12 matches) sequence 101
    permit icmp any any nd-ns (80 matches) sequence 102
    permit icmp any any nd-na (80 matches) sequence 103
    deny ipv6 any 2001:DB8:1:60::/64 (5 matches) sequence 104

In the preceding example, access list IPv6-Infrastructure-ACL-Policy has dropped

  • 9 SSH packets on TCP port 22 for access control list entry (ACE) Line 70.
  • 27 HTTPS packets on TCP port 443 for access control list entry (ACE) Line 80.
  • 13 packets on TCP port 4466 for access control list entry (ACE) line 90.
  • 55 TCP packets on UDP port 3799 for access control list entry (ACE) line 100.
  • 12 SYSLOG packets on UDP port 514 for access control list entry (ACE) line 101.

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Cisco Security Intelligence Operations white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Cisco IOS NetFlow and Cisco IOS Flexible NetFlow

Identification: IPv4 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv4 traffic flows that may be attempts to exploit this vulnerability. Administrators are advised to investigate flows to determine whether they are attempts to exploit this vulnerability or whether they are legitimate traffic flows.

router#show ip cache flow
IP packet size distribution (90784136 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .698 .011 .001 .004 .005 .000 .004 .000 .000 .003 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .001 .256 .000 .010 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  1885 active, 63651 inactive, 59960004 added
  129803821 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  0 active, 16384 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet    11393421      2.8         1    48      3.1       0.0       1.4
TCP-FTP            236      0.0        12    66      0.0       1.8       4.8
TCP-FTPD            21      0.0     13726  1294      0.0      18.4       4.1
TCP-WWW          22282      0.0        21  1020      0.1       4.1       7.3
TCP-X              719      0.0         1    40      0.0       0.0       1.3
TCP-BGP              1      0.0         1    40      0.0       0.0      15.0
TCP-Frag         70399      0.0         1   688      0.0       0.0      22.7
TCP-other     47861004     11.8         1   211     18.9       0.0       1.3
UDP-DNS            582      0.0         4    73      0.0       3.4      15.4
UDP-NTP         287252      0.0         1    76      0.0       0.0      15.5
UDP-other       310347      0.0         2   230      0.1       0.6      15.9
ICMP             11674      0.0         3    61      0.0      19.8      15.5
IPv6INIP            15      0.0         1  1132      0.0       0.0      15.4
GRE                  4      0.0         1    48      0.0       0.0      15.3 
Total:        59957957     14.8         1   196     22.5       0.0       1.5

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  01 0984 0800     9
Gi0/0         192.168.11.54   Gi0/1         192.168.60.158  01 0911 0000     4
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  06 0984 0016     1
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  06 0984 01BB     1
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  11 0984 0ED7     1
Gi0/0         192.168.11.54   Gi0/1         192.168.60.158  06 0911 0016     3
Gi0/1         192.168.150.60  Gi0/0         10.89.16.226    06 0016 12CA     1
Gi0/0         10.89.16.226    Gi0/1         192.168.150.60  06 12CA 0016     1
router#

In the preceding example, there are multiple flows for SSH on TCP port 22 (hex value 0016), HTTPS on TCP port 443(hex value 01BB), UDP port 3799(hex value 0ED7) as well as ICMP echo requests and echo replies (hex values 0800 and 0000) respectively.

As shown in the following example, to view only the SSH packets on TCP port 22 (hex value 0016), and the TCP port 4466 packets (hex value 1172) , use the show ip cache flow | include SrcIf|_06_.*(0016|1172)_ command to display the related Cisco NetFlow records:

TCP Flows
router#show ip cache flow | include SrcIf|_06_.*(0016|1172)
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  06 0984 0016     1
Gi0/0         192.168.11.54   Gi0/1         192.168.60.158  06 0911 0016     3
Gi0/0 192.168.10.201 Gi0/1 192.168.60.102 06 0984 1172 1
Gi0/0 192.168.11.54 Gi0/1 192.168.60.158 06 0911 1172 3
router#

Identification: IPv6 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv6 traffic flows that may be attempts to exploit the vulnerability that is described in this document. Administrators are advised to investigate flows to determine whether they are attempts to exploit this vulnerability or whether they are legitimate traffic flows.

The following output is from a Cisco IOS device running Cisco IOS Software 12.4 mainline train. The command syntax will vary for different Cisco IOS Software trains.

router#show ipv6 flow cache

IP packet size distribution (50078919 total packets):
   1-32  64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .990 .001 .008 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 475168 bytes
  8 active, 4088 inactive, 6160 added
  1092984 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33928 bytes
  16 active, 1008 inactive, 12320 added, 6160 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added>
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Go0/1    0x06 0x16C4 0x0016 1464
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x11 0x0000 0x0ED7 1168
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x0016 1597
2001:DB...06::201 Gi0/0    2001:DB...28::20 Go0/1    0x06 0x16C4 0x1172 1466
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::3 Gi0/1    0x3A 0x0000 0x8000 1155

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

In the preceding example, there are multiple IPv6 flows for SSH on TCP port 22 (hex value 0016), UDP port 3799 (hex value 0ED7), TCP on port 4466 (hex value 1172) .

As shown in the following example, to view only the SSH packets on TCP port 22 (hex value 0016), use the show ipv6 flow cache | include SrcIf|_06_.*0016_ command to display the related Cisco NetFlow records:

TCP Flows

router#show ipv6 flow cache | include SrcIf|_06_.*0016_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x06 0x16C4 0x0016 1464 
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x0016 1597
router#

Identification: IPv4 Traffic Flow Identification Using Cisco Flexible NetFlow

Introduced in Cisco IOS Software Releases 12.2(31)SB2 and 12.4(9)T, Cisco IOS Flexible NetFlow improves original Cisco NetFlow by adding the capability to customize the traffic analysis parameters for the administrator's specific requirements. Original Cisco NetFlow uses a fixed seven tuples of IP information to identify a flow, whereas Cisco IOS Flexible NetFlow allows the flow to be user defined. It facilitates the creation of more complex configurations for traffic analysis and data export by using reusable configuration components.

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv4 flows based on source IPv4 address, as defined by the match ipv4 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv4 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.

!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv4
 match ipv4 source address
 collect ipv4 protocol
 collect ipv4 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv4
 record FLOW-RECORD-ipv4
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
 ip flow monitor FLOW-MONITOR-ipv4 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv4 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                1

  Flows added:                                   9181
  Flows aged:                                    9175
    - Active timeout      (  1800 secs)          9000
    - Inactive timeout    (    15 secs)           175
    - Event aged                                    0
    - Watermark aged                                0
    - Emergency aged                                0

IPV4 SRC ADDR  ipv4 dst addr  trns src port  trns dst port  intf input intf output pkts  ip prot
============== ============== =============  =============  ========== =========== ===== =======
192.168.10.201 192.168.60.102          1456             22       Gi0/0       Gi0/1 10128 6
192.168.10.201 192.168.60.102          1316            443       Gi0/0       Gi0/1 1898  6
192.168.10.201 192.168.60.102          1456           4466       Gi0/0       Gi0/1 1128  6
192.168.10.17  192.168.60.97           4231            514       Gi0/0       Gi0/1 14606 17
192.168.10.17  192.168.60.97           4231           3799       Gi0/0       Gi0/1 10223 17
10.88.226.1    192.168.202.22          2678             53       Gi0/0       Gi0/1 10567 17  
10.89.16.226   192.168.150.60          3562             80       Gi0/0       Gi0/1 30012 6

To view only the SSH packets on TCP port 22, use the show flow monitor FLOW-MONITOR-ipv4 cache format table | include IPV4 DST ADDR |_22_.*_6_ command to display the related NetFlow records.

For more information about Cisco IOS Flexible NetFlow, refer to Flexible Netflow Configuration Guide, Cisco IOS Release 15.1M&T and Cisco IOS Flexible NetFlow Configuration Guide, Release 12.4T.

Identification: IPv6 Traffic Flow Identification Using Cisco IOS Flexible NetFlow

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv6 flows based on the source IPv6 address, as defined by the match ipv6 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv6 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.
!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv6
 match ipv6 source address
 collect ipv6 protocol
 collect ipv6 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv6
 record FLOW-RECORD-ipv6
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
  ipv6 flow monitor FLOW-MONITOR-ipv6 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv6 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                2

  Flows added:                                   539
  Flows aged:                                    532
    - Active timeout      (  1800 secs)          350
    - Inactive timeout    (    15 secs)          182
    - Event aged                                   0
    - Watermark aged                               0
    - Emergency aged                               0

IPV6 SRC ADDR     ipv6 dst addr    trns src port trns dst port intf input intf output pkts ip prot
================= ================ ============= ============= ========== =========== ==== =======
2001:DB...06::201 2001:DB...28::20           123           123      Gi0/0       Gi0/0   17      17
2001:DB...06::201 2001:DB...28::20          1265            22      Gi0/0       Gi0/0 1237       6
2001:DB...06::201 2001:DB...28::20          1890           443      Gi0/0       Gi0/0 5009       6
2001:DB...06::201 2001:DB...28::20          1043          4466      Gi0/0       Gi0/0  501       6
2001:DB...06::201 2001:DB...28::20          2044          3799      Gi0/0       Gi0/0 4522      17
2001:DB...06::201 2001:DB...28::20          2856           514      Gi0/0       Gi0/0  486      17

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

To view only the SSH packets on TCP port 22, use the show flow monitor FLOW-MONITOR-ipv6 cache format table | include IPV6 DST ADDR|_22_.*_6_ command to display the related Cisco IOS Flexible NetFlow records.

Cisco ASA, Cisco ASASM, and Cisco FWSM Firewalls

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against this vulnerability when the attack originates from a trusted source address.

The tACL policy denies unauthorized SSH packets on TCP ports 22, TCP 443, UDP port 3799, and ICMP echo requests that are sent to affected ASA-CX management interfaces, and additionally TCP Port 446 and UDP port 514 requests that are sent to affected PRSM server management interfaces. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.

!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocol and port
!
access-list tACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 22
access-list tACL-Policy extended permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 443
access-list tACL-Policy extended permit udp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 3799
access-list tACL-Policy extended permit icmp host 192.168.100.1 192.168.60.0 0.0.0.255 8
access-list tACL-Policy extended permit tcp host 192.168.100.1 host 192.168.60.6 eq 4466
access-list tACL-Policy extended permit udp host 192.168.100.1 host 192.168.60.6 eq 514
!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
access-list tACL-Policy extended deny tcp any 192.168.60.0 0.0.0.255 eq 22
access-list tACL-Policy extended deny tcp any 192.168.60.0 0.0.0.255 eq 443
access-list tACL-Policy extended deny udp any 192.168.60.0 0.0.0.255 eq 3799
access-list tACL-Policy extended deny tcp any host 192.168.60.6 eq 4466
access-list tACL-Policy extended deny udp any host 192.168.60.6 eq 514
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations

access-list tACL-Policy extended permit icmp any any nd-ns
access-list tACL-Policy extended permit icmp any any nd-na
!
!-- Explicit deny for all other IP traffic
!
access-list tACL-Policy extended deny ip any any
access-group tACL-Policy in interface outside
access-group IPv6-tACL-Policy in interface outside
!
!-- Create the corresponding IPv6 tACL
!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocols and ports
!
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 22 ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 443 ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 4466 ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 3799 ipv6 access-list IPv6-tACL-Policy permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 514 ipv6 access-list IPv6-tACL-Policy permit icmp6 host 2001:DB8::100:1 2001:DB8:1:60::/64 !
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:DB8:1:60::/64 eq 22 ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:DB8:1:60::/64 eq 443 ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:DB8:1:60::/64 eq 4466 ipv6 access-list IPv6-tACL-Policy deny udp any 2001:DB8:1:60::/64 eq 3799 ipv6 access-list IPv6-tACL-Policy deny udp any 2001:DB8:1:60::/64 eq 514 !
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
ipv6 access-list IPv6-tACL-Policy permit icmp any any nd-ns ipv6 access-list IPv6-tACL-Policy permit icmp any any nd-na !-- Explicit deny for all other IP traffic
!
ipv6 access-list IPv6-tACL-Policy deny ip any any !
!--

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the number of SSH packets sent to TCP port 22, TCP 443, UDP port 3799, and ICMP echo requests that are sent to affected ASA-CX management interfaces, and additionally TCP Port 446 and UDP port 514 requests that are sent to affected PRSM server management interfaces that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit this vulnerability. Example output for show access-list tACL-Policy and show access-list IPv6-tACL-Policy follows:

firewall#show access-list tACL-Policy
access-list tACL-Policy; 14 elements; name hash: 0x3452703d
access-list tACL-Policy line 1 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0 
eq ssh (hitcnt=31) access-list tACL-Policy line 2 extended permit tcp host 192.168.100.1 192.168.60.0 255.255.255.0
eq https (hitcnt=13) access-list tACL-Policy line 3 extended permit udp host 192.168.100.1 192.168.60.0 255.255.255.0
eq 3799 (hitcnt=8) access-list tACL-Policy line 4 extended permit icmp host 192.168.100.1 192.168.60.0 255.255.255.0 8
(hitcnt=8) access-list tACL-Policy line 5 extended permit tcp host 192.168.100.1 192.168.60.6 255.255.255.255
eq 4466 (hitcnt=8) access-list tACL-Policy line 6 extended permit udp host 192.168.100.1 192.168.60.6 255.255.255.255
eq syslog (hitcnt=8) access-list tACL-Policy line 7 extended deny tcp any 192.168.60.0 0.0.0.255 eq ssh (hitcnt=9) access-list tACL-Policy line 8 extended deny tcp any 192.168.60.0 0.0.0.255 eq https (hitcnt=27) access-list tACL-Policy line 9 extended deny udp any 192.168.60.0 0.0.0.255 eq 3799 (hitcnt=13) access-list tACL-Policy line 10 extended deny tcp any 192.168.60.6 0.0.0.0 eq 4466 (hitcnt=11) access-list tACL-Policy line 11 extended deny udp any 192.168.60.6 0.0.0.0 eq syslog (hitcnt=12) access-list tACL-Policy line 12 extended permit icmp any any nd-ns (hitcnt=144) access-list tACL-Policy line 13 extended permit icmp any any nd-na (hitcnt=128) access-list tACL-Policy line 14 extended deny ip any any (hitcnt=8)

In the preceding example, access list tACL-Policy has dropped

  • 9 SSH packets on TCP port 22 for access control list entry (ACE) line 7
  • 27 HTTPS packets on TCP port 443 for ACE line 8
  • 13 packets on UDP port 3799 for ACE line 9
  • 11 TCP packets on TCP port 4466 for ACE line 10
  • 12 SYSLOG packets on UDP port 514 for ACE line 11
firewall#show access-list IPv6-tACL-Policy                 
ipv6 access-list IPv6-tACL-Policy; 14 elements; name hash: 0x566a4229
ipv6 access-list IPv6-tACL-Policy line 1 permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 
eq 22 (hitcnt=52) ipv6 access-list IPv6-tACL-Policy line 2 permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64
eq 443 (hitcnt=59) ipv6 access-list IPv6-tACL-Policy line 3 permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64
eq 4466 (hitcnt=12) ipv6 access-list IPv6-tACL-Policy line 4 permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64
eq 3799 (hitcnt=22) ipv6 access-list IPv6-tACL-Policy line 5 permit udp host 2001:DB8::100:1 2001:DB8:1:60::/64
eq 514 (hitcnt=11) ipv6 access-list IPv6-tACL-Policy line 6 permit icmp6 host 2001:DB8::100:1 2001:DB8:1:60::/64
(hitcnt=19) ipv6 access-list IPv6-tACL-Policy line 7 deny tcp any 2001:DB8:1:60::/64 eq 22 (hitcnt=53) ipv6 access-list IPv6-tACL-Policy line 8 deny tcp any 2001:DB8:1:60::/64 eq 443 (hitcnt=133) ipv6 access-list IPv6-tACL-Policy line 9 deny tcp any 2001:DB8:1:60::/64 eq 4466 (hitcnt=11) ipv6 access-list IPv6-tACL-Policy line 10 deny udp any 2001:DB8:1:60::/64 eq 3799 (hitcnt=35) ipv6 access-list IPv6-tACL-Policy line 11 deny udp any 2001:DB8:1:60::/64 eq 514 (hitcnt=159) ipv6 access-list IPv6-tACL-Policy line 12 permit icmp any any nd-ns (hitcnt=19) ipv6 access-list IPv6-tACL-Policy line 13 permit icmp any any nd-na (hitcnt=19) ipv6 access-list IPv6-tACL-Policy line 14 deny ipv6 any 2001:DB8:1:60::/64 (hitcnt=89)

In the preceding example, access list IPv6-tACL-Policy has dropped the following packets received from an untrusted host or network:

  • 53 SSH packets on TCP port 22 for ACE line 7
  • 133 HTTPS packets on TCP port 443 for ACE line 8
  • 11 packets on TCP port 4466 for ACE line 9
  • 35 packets on UDP port 3799 for ACE line 10
  • 159 SYSLOG packets on UDP port 514 for ACE line 11

Identification: Firewall Access List Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an access control entry (ACE) that does not have the log keyword present. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the Cisco Catalyst 6500 Series ASA Services Module is in Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerability that is described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

firewall#show logging | grep 106023
  Sep 6 2012 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.18/2944 
         dst inside:192.168.60.191/ssh by access-group "tACL-Policy"
  Sep 6 2012 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.200/2945 
         dst inside:192.168.60.33/443 by access-group "tACL-Policy"
  Sep 6 2012 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.200/2946 
         dst inside:192.168.60.33/4466 by access-group "tACL-Policy"
  Sep 6 2012 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.200/2947 
         dst inside:192.168.60.33/514 by access-group "tACL-Policy"
  Sep 6 2012 00:15:13: %ASA-4-106023: Deny udp src outside:192.0.2.200/2948 
         dst inside:192.168.60.33/3799 by access-group "tACL-Policy"
firewall#

In the preceding example, the messages logged for the tACL tACL-Policy show SSH packets for TCP port 22 , packets for TCP port 443, packets for TCP port 4466, Syslog packets for UDP port 514, and packets for UDP port 3799 sent to the address block assigned to the affected devices.

Additional information about syslog messages for Cisco ASA Series Adaptive Security Appliances is in Cisco ASA 5500 Series System Log Messages, 8.2. Additional information about syslog messages for Cisco Catalyst 6500 Series ASA Services Module is in the Analyzing Syslog Messages section of the Cisco ASASM CLI Configuration Guide. Additional information about syslog messages for the Cisco FWSM is in Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Logging System Log Messages.

For additional information about investigating incidents using syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Cisco Security Manager, Event Viewer

Beginning in software version 4.0, Cisco Security Manager can collect syslogs from Cisco firewalls and Cisco IPS devices and provides the Event Viewer, which can query for events that are related to the vulnerability that is described in this document.

Using the following filters in the Firewall Denied Events predefined view in the Event Viewer provides all captured Cisco firewall access list deny syslog messages that could indicate potential attempts to exploit the vulnerability that is described in this document.

  • Use the Destination event filter to filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Use the Destination Service event filter to filter objects that contain TCP port 22
  • Use the Destination Service event filter to filter objects that contain TCP port 443
  • Use the Destination Service event filter to filter objects that contain TCP port 4466
  • Use the Destination Service event filter to filter objects that contain UDP port 3799
  • Use the Destination Service event filter to filter objects that contain UDP port 514

For more information about Cisco Security Manager Events, refer to the Filtering and Querying Events section of the Cisco Security Manager User Guide.

Cisco Security Manager Report Manager

Beginning in software version 4.1, Cisco Security Manager supports the Report Manager, the Cisco IPS event reporting feature. This feature allows an administrator to define reports based on Cisco IPS events of interest. Reports can be scheduled or users can run ad hoc reports as required.

In the Report Manager, the Top Services report can be used with the following configuration to generate a report of events that indicate potential attempts to exploit the vulnerability that is described in this document:

  • Use the Destination IP network filter to filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Set an action of Deny on the Criteria settings page

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information

 
Alert History
 
Version 1, September 12, 2012, 12:00 PM: Cisco Applied Mitigation Bulletin initial public release


Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
CiscoCisco ASA-CX Software 9.0 .1-40, .2-68
CiscoCisco Prime Security Manager (PRSM) 9.0 .1-40, .2-68

Associated Products:
N/A




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield