Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Cisco Applied Mitigation Bulletin

Identification and Mitigation of Vulnerabilities in Cisco Voice and Unified Communications Products

 
Threat Type:IntelliShield: Applied Mitigation Bulletin
IntelliShield ID:28034
Version:1
First Published:2013 February 27 16:02 GMT
Last Published:2013 February 27 16:02 GMT
Port: 5060, 9043, 9443
CVE:CVE-2013-1133 , CVE-2013-1134 , CVE-2013-1135 , CVE-2013-1137
Urgency:Unlikely Use
Credibility:Confirmed
Severity:Mild Damage
Related Resources:
 
 
Version Summary:Cisco Applied Mitigation Bulletin initial public release.
 

Cisco Response

This Applied Mitigation Bulletin is a companion document to the following PSIRT Security Advisories:

  • Cisco Unified Communications Manager Contains Multiple Vulnerabilities
  • Cisco Unified Presence Server Denial of Service Vulnerability
  • Cisco Prime Central for Hosted Collaboration Solution Assurance Excessive CPU Utilization Vulnerability

This document provides identification and mitigation techniques that administrators can deploy on Cisco network devices.

Vulnerability Characteristics

There are multiple vulnerabilities in Cisco Voice and Unified Communications Products. The following subsections summarize these vulnerabilities:

Locations Bandwidth Manager (LBM) Cache Poisoning Vulnerability: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability could result in a denial of service (DoS) condition. The attack vector for exploitation is through IPv4 and IPv6 packets using TCP port 9004.

This vulnerability has been assigned Common Vulnerabilities and Exposures (CVE) identifier CVE-2013-1134.

Cisco Unified Presence Server Denial of Service Vulnerability: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability could result in a DoS condition. The attack vector for exploitation is through SIP IPv4 and IPv6 packets using TCP port 5060.

This vulnerability has been assigned CVE identifier CVE-2013-1137.

Cisco Prime Central for Hosted Collaboration Solution Assurance Excessive CPU Utilization Vulnerability: This vulnerability can be exploited remotely without authentication and without end-user interaction. Successful exploitation of this vulnerability could result in a DoS condition. The attack vector for exploitation is through IPv4 and IPv6 packets using TCP ports 9043 and 9443.

This vulnerability has been assigned CVE identifier CVE-2013-1135.

Mitigation Technique Overview

Cisco devices provide several countermeasures for these vulnerabilities. Administrators are advised to consider these protection methods to be general security best practices for infrastructure devices and the traffic that transits the network. This section of the document provides an overview of these techniques.

Cisco IOS Software can provide effective means of exploit prevention using transit access control lists (tACLs)

This protection mechanism filters and drops packets that are attempting to exploit these vulnerabilities.

Effective means of exploit prevention can also be provided by the Cisco ASA 5500 Series Adaptive Security Appliance, Cisco Catalyst 6500 Series ASA Services Module (ASASM), and the Firewall Services Module (FWSM) for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers using the following:

  • tACLs
  • TCP normalization

These protection mechanisms filter and drop packets that are attempting to exploit these vulnerabilities.

Effective exploit prevention can also be provided by the Cisco ACE Application Control Engine Appliance and Module using TCP normalization.

This protection mechanism filters and drops packets that are attempting to exploit these vulnerabilities.

Cisco IOS NetFlow records can provide visibility into network-based exploitation attempts.

Cisco IOS Software, Cisco ASA, Cisco ASASM, Cisco FWSM firewalls, and Cisco ACE Application Control Engine Appliance and Module can provide visibility through syslog messages and counter values displayed in the output from show commands.

Effective use of Cisco Intrusion Prevention System (IPS) event actions provides visibility into and protection against attacks that attempt to exploit these vulnerabilities.

The Cisco Security Manager can also provide visibility through incidents, queries, and event reporting.

Risk Management

Organizations are advised to follow their standard risk evaluation and mitigation processes to determine the potential impact of these vulnerabilities. Triage refers to sorting projects and prioritizing efforts that are most likely to be successful. Cisco has provided documents that can help organizations develop a risk-based triage capability for their information security teams. Risk Triage for Security Vulnerability Announcements and Risk Triage and Prototyping can help organizations develop repeatable security evaluation and response processes.

Device-Specific Mitigation and Identification

Caution: The effectiveness of any mitigation technique depends on specific customer situations such as product mix, network topology, traffic behavior, and organizational mission. As with any configuration change, evaluate the impact of this configuration prior to applying the change.

Specific information about mitigation and identification is available for these devices:

Cisco IOS Routers and Switches

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy transit access control lists (tACLs) to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized IPv4 and IPv6 packets on TCP ports 9004, 5060, 9043, and 9443 that are sent to affected devices. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.

!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocols and ports
!
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9004
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9043
access-list 150 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9443
!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 9004
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 5060
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 9043
access-list 150 deny tcp any 192.168.60.0 0.0.0.255 eq 9443
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
access-list 150 deny ip any any
!
!-- Create the corresponding IPv6 tACL
!
ipv6  access-list IPv6-Transit-ACL-Policy
  !  
  !-- Include explicit permit statements for trusted sources
  !-- that require access on the vulnerable protocols and ports
  !
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 9004
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5060
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 9043
  permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 9443
  !
  !-- The following vulnerability-specific ACEs can 
  !-- aid in identification of attacks to global and
  !-- link-local addresses
  !
  deny tcp any 2001:DB8:1:60::/64 eq 9004
  deny tcp any 2001:DB8:1:60::/64 eq 5060
  deny tcp any 2001:DB8:1:60::/64 eq 9043
  deny tcp any 2001:DB8:1:60::/64 eq 9443
  !
  !-- Permit or deny all other Layer 3 and Layer 4 traffic in 
  !-- accordance with existing security policies and configurations
  !-- and allow IPv6 neighbor discovery packets, which
  !-- include neighbor solicitation packets and neighbor
  !-- advertisement packets
  !
  permit icmp any any nd-ns
  permit icmp any any nd-na
  ! 
!-- Explicit deny for all other IPv6 traffic !

deny ipv6 any any ! ! !-- Apply tACLs to interfaces in the ingress direction ! interface GigabitEthernet0/0 ip access-group 150 in ipv6 traffic-filter IPv6-Transit-ACL-Policy in

Note that filtering with an interface access list will elicit the transmission of ICMP unreachable messages back to the source of the filtered traffic. Generating these messages could have the undesired effect of increasing CPU utilization on the device. In Cisco IOS Software, ICMP unreachable generation is limited to one packet every 500 milliseconds by default. ICMP unreachable message generation can be disabled using the interface configuration commands no ip unreachables and no ipv6 unreachables. ICMP unreachable rate limiting can be changed from the default using the global configuration commands ip icmp rate-limit unreachable interval-in-ms and ipv6 icmp error-interval interval-in-ms.

Identification: Transit Access Control Lists

After the administrator applies the tACL to an interface, the show ip access-lists and show ipv6 access-list commands will identify the number of IPv4 and IPv6 packets on TCP ports 9004, 5060, 9043, and 9443 that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show ip access-lists 150 and show ipv6 access-list IPv6-Transit-ACL-Policy follows:

router#show ip access-lists 150
Extended IP access list 150
    10 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9004
    20 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 5060
    30 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9043
    40 permit tcp host 192.168.100.1 192.168.60.0 0.0.0.255 eq 9443
    50 deny tcp any 192.168.60.0 0.0.0.255 eq 9004 (3 matches)
    60 deny tcp any 192.168.60.0 0.0.0.255 eq 5060 (40 matches)
    70 deny tcp any 192.168.60.0 0.0.0.255 eq 9043 (17 matches)
    80 deny tcp any 192.168.60.0 0.0.0.255 eq 9443 (19 matches)
    90 deny ip any any
router#

In the preceding example, access list 150 has dropped the following packets received from an untrusted host or network:

  • 3 packets on TCP port 9004 for ACE line 50
  • 40 SIP packets on TCP port 5060 for ACE line 60
  • 17 packets on TCP port 9043 for ACE line 70
  • 19 packets on TCP port 9443 for ACE line 80
router#show ipv6 access-list IPv6-Transit-ACL-Policy 
IPv6 access list IPv6-Transit-ACL-Policy
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 9004 (48 matches) sequence 10
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 5060 (10 matches) sequence 20
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 9043 (50 matches) sequence 30
    permit tcp host 2001:DB8::100:1 2001:DB8:1:60::/64 eq 9443 (29 matches) sequence 40
    deny tcp any 2001:DB8:1:60::/64 eq 9004 (19 matches) sequence 50
    deny tcp any 2001:DB8:1:60::/64 eq 5060 (16 matches) sequence 60
    deny tcp any 2001:DB8:1:60::/64 eq 9043 (8 matches) sequence 70
    deny tcp any 2001:DB8:1:60::/64 eq 9443 (39 matches) sequence 80
    permit icmp any any nd-ns (80 matches) sequence 90
    permit icmp any any nd-na (91 matches) sequence 100
    deny ipv6 any any (121 matches) sequence 110

In the preceding example, access list IPv6-Transit-ACL-Policy has dropped the following packets received from an untrusted host or network:

  • 19 packets on TCP port 9004 for ACE line 50
  • 16 SIP packets on TCP port 5060 for ACE line 60
  • 8 packets on TCP port 9043 for ACE line 70
  • 39 packets on TCP port 9443 for ACE line 80

For additional information about investigating incidents using ACE counters and syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Administrators can use Embedded Event Manager to provide instrumentation when specific conditions are met, such as ACE counter hits. The Cisco Security Intelligence Operations white paper Embedded Event Manager in a Security Context provides additional details about how to use this feature.

Identification: Access List Logging

The log and log-input access control list (ACL) option will cause packets that match specific ACEs to be logged. The log-input option enables logging of the ingress interface in addition to the packet source and destination IP addresses and ports.

Caution: Access control list logging can be very CPU intensive and must be used with extreme caution. Factors that drive the CPU impact of ACL logging are log generation, log transmission, and process switching to forward packets that match log-enabled ACEs.

For Cisco IOS Software, the ip access-list logging interval interval-in-ms command can limit the effects of process switching induced by IPv4 ACL logging. The logging rate-limit rate-per-second except loglevel command limits the impact of log generation and transmission.

The CPU impact from ACL logging can be addressed in hardware on the Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers with Supervisor Engine 720 or Supervisor Engine 32 using optimized ACL logging.

For additional information about the configuration and use of ACL logging, reference the Understanding Access Control List Logging Cisco Security Intelligence Operations white paper.

Cisco IOS NetFlow and Cisco IOS Flexible NetFlow

Identification: IPv4 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv4 traffic flows that may be attempts to exploit these vulnerabilities. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

router#show ip cache flow
IP packet size distribution (90784136 total packets):
   1-32   64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .698 .011 .001 .004 .005 .000 .004 .000 .000 .003 .000 .000 .000 .000

    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .001 .256 .000 .010 .000 .000 .000 .000 .000 .000

IP Flow Switching Cache, 4456704 bytes
  1885 active, 63651 inactive, 59960004 added
  129803821 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 402056 bytes
  0 active, 16384 inactive, 0 added, 0 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
  last clearing of statistics never
Protocol         Total    Flows   Packets Bytes  Packets Active(Sec) Idle(Sec)
--------         Flows     /Sec     /Flow  /Pkt     /Sec     /Flow     /Flow
TCP-Telnet    11393421      2.8         1    48      3.1       0.0       1.4
TCP-FTP            236      0.0        12    66      0.0       1.8       4.8
TCP-FTPD            21      0.0     13726  1294      0.0      18.4       4.1
TCP-WWW          22282      0.0        21  1020      0.1       4.1       7.3
TCP-X              719      0.0         1    40      0.0       0.0       1.3
TCP-BGP              1      0.0         1    40      0.0       0.0      15.0
TCP-Frag         70399      0.0         1   688      0.0       0.0      22.7
TCP-other     47861004     11.8         1   211     18.9       0.0       1.3
UDP-DNS            582      0.0         4    73      0.0       3.4      15.4
UDP-NTP         287252      0.0         1    76      0.0       0.0      15.5
UDP-other       310347      0.0         2   230      0.1       0.6      15.9
ICMP             11674      0.0         3    61      0.0      19.8      15.5
IPv6INIP            15      0.0         1  1132      0.0       0.0      15.4
GRE                  4      0.0         1    48      0.0       0.0      15.3 
Total:        59957957     14.8         1   196     22.5       0.0       1.5

SrcIf         SrcIPaddress    DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.10.201  Gi0/1         192.168.60.102  11 0984 84D1     1
Gi0/0         192.168.11.54   Gi0/1         192.168.60.158  06 0911 2353     3
Gi0/1         192.168.150.60  Gi0/0         10.89.16.226    06 0016 12CA     1
Gi0/0         192.168.13.97   Gi0/1         192.168.60.28   06 0B3E 24E3     5
Gi0/0         192.168.10.17   Gi0/1         192.168.60.97   06 0B89 13C4     1
Gi0/0         10.88.226.1     Gi0/1         192.168.202.22  11 007B 13C4     1
Gi0/0         192.168.12.185  Gi0/1         192.168.60.239  06 0BD7 232C     1
Gi0/0         10.89.16.226    Gi0/1         192.168.150.60  06 12CA 0016     1
router#

In the preceding example, there are multiple flows on TCP ports 9004 (hex value 232C), 5060 (hex value 13C4), 9043 (hex value 2353), and 9443 (hex value 24E3).

As shown in the following example, to view only the packets on TCP ports 9004 (hex value 232C), 5060 (hex value 13C4), 9043 (hex value 2353), and 9443 (hex value 24E3), use the show ip cache flow | include SrcIf|_06_.*(232C|13C4|2353|24E3)_ command to display the related Cisco NetFlow records:

TCP Flows
router#show ip cache flow | include SrcIf|_06_.*(232C|13C4|2353|24E3)_
SrcIf         SrcIPaddress     DstIf         DstIPaddress    Pr SrcP DstP  Pkts
Gi0/0         192.168.12.110   Gi0/1         192.168.60.163  06 092A 24E3     6
Gi0/0         192.168.11.230   Gi0/1         192.168.60.20   06 0C09 13C4     1
Gi0/0         192.168.11.131   Gi0/1         192.168.60.245  06 0B66 232C    18
Gi0/0         192.168.13.7     Gi0/1         192.168.60.162  06 0914 232C     1
Gi0/0         192.168.41.86    Gi0/1         192.168.60.27   06 0B7B 2353     2
router#

Identification: IPv6 Traffic Flow Identification Using Cisco IOS NetFlow

Administrators can configure Cisco IOS NetFlow on Cisco IOS routers and switches to aid in the identification of IPv6 traffic flows that may be attempts to exploit the vulnerabilities that are described in this document. Administrators are advised to investigate flows to determine whether they are attempts to exploit these vulnerabilities or whether they are legitimate traffic flows.

The following output is from a Cisco IOS device running Cisco IOS Software 12.4 mainline train. The command syntax will vary for different Cisco IOS Software trains.

router#show ipv6 flow cache

IP packet size distribution (50078919 total packets):
   1-32  64   96  128  160  192  224  256  288  320  352  384  416  448  480
   .000 .990 .001 .008 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
    512  544  576 1024 1536 2048 2560 3072 3584 4096 4608
   .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 475168 bytes
  8 active, 4088 inactive, 6160 added
  1092984 ager polls, 0 flow alloc failures
  Active flows timeout in 30 minutes
  Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 33928 bytes
  16 active, 1008 inactive, 12320 added, 6160 added to flow
  0 alloc failures, 0 force free
  1 chunk, 1 chunk added
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...06::201 Gi0/0    2001:DB...28::20 Local    0x11 0x16C4 0x13C4 1464
2001:DB...6A:5BA6 Gi0/0    2001:DB...28::21 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...134::3 Gi0/1    0x3A 0x0000 0x8000 1191
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::4 Gi0/1    0x3A 0x0000 0x8000 1192    
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x232C 1597
2001:DB...06::201 Gi0/0    2001:DB...128::3 Gi0/1    0x06 0x1610 0x2353 1001  
2001:DB...06::201 Gi0/0    2001:DB...128::4 Gi0/1    0x06 0x1634 0x24E3 1292  
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::3 Gi0/1    0x3A 0x0000 0x8000 1155
2001:DB...6A:5BA6 Gi0/0    2001:DB...146::3 Gi0/1    0x3A 0x0000 0x8000 1092
2001:DB...6A:5BA6 Gi0/0    2001:DB...144::4 Gi0/1    0x3A 0x0000 0x8000 1193 

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

In the preceding example, there are multiple flows on TCP ports 9004 (hex value 232C), 5060 (hex value 13C4), 9043 (hex value 2353), and 9443 (hex value 24E3).

As shown in the following example, to view only the packets on TCP ports 9004 (hex value 232C), 5060 (hex value 13C4), 9043 (hex value 2353), and 9443 (hex value 24E3), use the show ipv6 flow cache | include SrcIf|_06_.*(232C|13C4|2353|24E3)_ command to display the related Cisco NetFlow records:

TCP Flows

router#show ipv6 flow cache | include SrcIf|_06_.*(232C|13C4|2353|24E3)_
SrcAddress        InpIf    DstAddress       OutIf    Prot SrcPrt DstPrt Packets
2001:DB...6A:5BA6 Gi0/0    2001:DB...128::2 Gi0/1    0x06 0x160A 0x13C4 1597
router#

Identification: IPv4 Traffic Flow Identification Using Cisco Flexible NetFlow

Introduced in Cisco IOS Software Releases 12.2(31)SB2 and 12.4(9)T, Cisco IOS Flexible NetFlow improves original Cisco NetFlow by adding the capability to customize the traffic analysis parameters for the administrator's specific requirements. Original Cisco NetFlow uses a fixed seven tuples of IP information to identify a flow, whereas Cisco IOS Flexible NetFlow allows the flow to be user defined. It facilitates the creation of more complex configurations for traffic analysis and data export by using reusable configuration components.

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv4 flows based on source IPv4 address, as defined by the match ipv4 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv4 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.

!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv4
 match ipv4 source address
 collect ipv4 protocol
 collect ipv4 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv4
 record FLOW-RECORD-ipv4
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
 ip flow monitor FLOW-MONITOR-ipv4 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv4 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                1

  Flows added:                                   9181
  Flows aged:                                    9175
    - Active timeout      (  1800 secs)          9000
    - Inactive timeout    (    15 secs)           175
    - Event aged                                    0
    - Watermark aged                                0
    - Emergency aged                                0

IPV4 SRC ADDR   ipv4 dst addr   trns src port trns dst port intf input intf output pkts   ip prot
=============== =============== ============= ============= ========== =========== ====== =======
 192.168.10.201  192.168.60.102          1456          9043      Gi0/0       Gi0/1   1128      6
 192.168.11.54   192.168.60.158           123           123      Gi0/0       Gi0/1   2212     17
 192.168.150.60    10.89.16.226          2567          9443      Gi0/0       Gi0/1     13      6
 192.168.13.97    192.168.60.28          3451          9004      Gi0/0       Gi0/1      1      6
 192.168.10.17    192.168.60.97          4231          5060      Gi0/0       Gi0/1    146      6
   10.88.226.1   192.168.202.22          2678           443      Gi0/0       Gi0/1  10567      6
  10.89.16.226   192.168.150.60          3562            80      Gi0/0       Gi0/1  30012      6

To only view the packets on TCP ports 9004, 5060, 9043, and 9443, use the show flow monitor FLOW-MONITOR-ipv4 cache format table | include IPV4 DST ADDR |_(9004|5060|9043|9443)_.*_6_ command to display the related NetFlow records.

For more information about Cisco IOS Flexible NetFlow, refer to Flexible Netflow Configuration Guide, Cisco IOS Release 15.1M&T and Cisco IOS Flexible NetFlow Configuration Guide, Release 12.4T.

Identification: IPv6 Traffic Flow Identification Using Cisco IOS Flexible NetFlow

The following example output is from a Cisco IOS device that is running a version of Cisco IOS Software in the 15.1T train. Although the syntax will be almost identical for the 12.4T and 15.0 trains, it may vary slightly depending on the actual Cisco IOS release being used. In the following configuration, Cisco IOS Flexible NetFlow will collect information on interface GigabitEthernet0/0 for incoming IPv6 flows based on the source IPv6 address, as defined by the match ipv6 source address key field statement. Cisco IOS Flexible NetFlow will also include nonkey field information about source and destination IPv6 addresses, protocol, ports (if present), ingress and egress interfaces, and packets per flow.

!
!-- Configure key and nonkey fields
!-- in the user-defined flow record
!
flow record FLOW-RECORD-ipv6
 match ipv6 source address
 collect ipv6 protocol
 collect ipv6 destination address
 collect transport source-port
 collect transport destination-port
 collect interface input
 collect interface output
 collect counter packets
!
!-- Configure the flow monitor to
!-- reference the user-defined flow 
!-- record
!
flow monitor FLOW-MONITOR-ipv6
 record FLOW-RECORD-ipv6
!
!-- Apply the flow monitor to the interface
!-- in the ingress direction
!
interface GigabitEthernet0/0
  ipv6 flow monitor FLOW-MONITOR-ipv6 input

The Cisco IOS Flexible NetFlow flow output is as follows:

router#show flow monitor FLOW-MONITOR-ipv6 cache format table
  Cache type:                               Normal
  Cache size:                                 4096
  Current entries:                               6
  High Watermark:                                2

  Flows added:                                   539
  Flows aged:                                    532
    - Active timeout      (  1800 secs)          350
    - Inactive timeout    (    15 secs)          182
    - Event aged                                   0
    - Watermark aged                               0
    - Emergency aged                               0

IPV6 SRC ADDR     ipv6 dst addr     trns src port trns dst port intf input intf output pkts ip prot
================= ================= ============= ============= ========== =========== ==== =======
2001:DB...06::201  2001:DB...28::20           123           123      Gi0/0       Gi0/0   17      17
2001:DB...06::201  2001:DB...28::20          1265          9004      Gi0/0       Gi0/0 1237       6
2001:DB...06::201  2001:DB...28::20          1441          9443      Gi0/0       Gi0/0 2346       6
2001:DB...06::201  2001:DB...28::20          1890          5060      Gi0/0       Gi0/0 5009       6
2001:DB...06::201  2001:DB...28::20          2856          5060      Gi0/0       Gi0/0  486      17
2001:DB...06::201  2001:DB...28::20          3012            53      Gi0/0       Gi0/0 1016      17
2001:DB...06::201  2001:DB...28::20          2477            53      Gi0/0       Gi0/0 1563      17

To permit display of the full 128-bit IPv6 address, use the terminal width 132 exec mode command.

To view only the packets on TCP ports 9004, 5060, 9043, and 9443, use the show flow monitor FLOW-MONITOR-ipv6 cache format table | include IPV6 DST ADDR|_(9004|5060|9043|9443)_.*_6_ command to display the related Cisco IOS Flexible NetFlow records.

Cisco ASA, Cisco ASASM, and Cisco FWSM Firewalls

Mitigation: Transit Access Control Lists

To protect the network from traffic that enters the network at ingress access points, which may include Internet connection points, partner and supplier connection points, or VPN connection points, administrators are advised to deploy tACLs to perform policy enforcement. Administrators can construct a tACL by explicitly permitting only authorized traffic to enter the network at ingress access points or permitting authorized traffic to transit the network in accordance with existing security policies and configurations. A tACL workaround cannot provide complete protection against these vulnerabilities when the attack originates from a trusted source address.

The tACL policy denies unauthorized IPv4 and IPv6 packets on TCP ports 9004, 5060, 9043, and 9443, that are sent to affected devices. In the following example, 192.168.60.0/24 and 2001:DB8:1:60::/64 represent the IP address space that is used by the affected devices, and the hosts at 192.168.100.1 and 2001:DB8::100:1 are considered trusted sources that require access to the affected devices. Care should be taken to allow required traffic for routing and administrative access prior to denying all unauthorized traffic.

Additional information about tACLs is in Transit Access Control Lists: Filtering at Your Edge.

!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocols and ports
!
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9004
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 5060
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9043
access-list tACL-Policy extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9443
!
!-- The following vulnerability-specific access control entries
!-- (ACEs) can aid in identification of attacks
!
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 9004
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 5060
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 9043
access-list tACL-Policy extended deny tcp any 192.168.60.0 255.255.255.0 eq 9443
!
!-- Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!-- with existing security policies and configurations
!
!-- Explicit deny for all other IP traffic
!
access-list tACL-Policy extended deny ip any any
!
!-- Create the corresponding IPv6 tACL
!
!-- Include explicit permit statements for trusted sources
!-- that require access on the vulnerable protocols and ports
!
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 9004
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 5060
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 9043
ipv6 access-list IPv6-tACL-Policy permit tcp host 2001:DB8::100:1
          2001:db8:1:60::/64 eq 9443
!
!--  The following vulnerability-specific access control entries
!--  (ACEs) can aid in identification of attacks
!
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 9004
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 5060
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 9043
ipv6 access-list IPv6-tACL-Policy deny tcp any 2001:db8:1:60::/64 eq 9443
!
!--  Permit or deny all other Layer 3 and Layer 4 traffic in accordance
!--  with existing security policies and configurations
!
!--  Explicit deny for all other IP traffic
!
ipv6 access-list IPv6-tACL-Policy deny ip any any
!
!--  Apply tACLs to interfaces in the ingress direction
!
access-group tACL-Policy in interface outside
access-group IPv6-tACL-Policy in interface outside

Identification: Transit Access Control Lists

After the tACL has been applied to an interface, administrators can use the show access-list command to identify the number of IPv4 and IPv6 packets on TCP ports 9004, 5060, 9043, and 9443 that have been filtered. Administrators are advised to investigate filtered packets to determine whether they are attempts to exploit these vulnerabilities. Example output for show access-list tACL-Policy and show access-list IPv6-tACL-Policy follows:

firewall#show access-list tACL-Policy
access-list tACL-Policy; 9 elements; name hash: 0x3452703d
access-list tACL-Policy line 1 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9004 (hitcnt=61)
access-list tACL-Policy line 2 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq sip (hitcnt=91)
access-list tACL-Policy line 3 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9043 (hitcnt=27)
access-list tACL-Policy line 4 extended permit tcp host 192.168.100.1 
     192.168.60.0 255.255.255.0 eq 9443 (hitcnt=4)
access-list tACL-Policy line 5 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq 9004 (hitcnt=14)
access-list tACL-Policy line 6 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq sip (hitcnt=30)
access-list tACL-Policy line 7 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq 9043 (hitcnt=19) 
access-list tACL-Policy line 8 extended deny tcp any 192.168.60.0 
     255.255.255.0 eq 9443 (hitcnt=13) 
access-list tACL-Policy line 9 extended deny ip any any (hitcnt=34)

In the preceding example, access list tACL-Policy has dropped the following packets received from an untrusted host or network:

  • 14 packets on port 9004 for ACE line 5
  • 30 SIP packets on port 5060 for ACE line 6
  • 19 packets on port 9043 for ACE line 7
  • 13 packets on port 9443 for ACE line 8
firewall#show access-list IPv6-tACL-Policy                 
ipv6 access-list IPv6-tACL-Policy; 9 elements; name hash: 0x566a4229
ipv6 access-list IPv6-tACL-Policy line 1 permit tcp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq 9004 (hitcnt=28) 
ipv6 access-list IPv6-tACL-Policy line 2 permit tcp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq sip (hitcnt=124) 
ipv6 access-list IPv6-tACL-Policy line 3 permit tcp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq 9043 (hitcnt=81) 
ipv6 access-list IPv6-tACL-Policy line 4 permit tcp host 2001:db8:1:100::1 
     2001:db8:1:60::/64 eq 9443 (hitcnt=81) 
ipv6 access-list IPv6-tACL-Policy line 5 deny tcp any 
     2001:db8:1:60::/64 eq 9004 (hitcnt=3) 
ipv6 access-list IPv6-tACL-Policy line 6 deny tcp any 
     2001:db8:1:60::/64 eq sip (hitcnt=49) 
ipv6 access-list IPv6-tACL-Policy line 7 deny tcp any 
     2001:db8:1:60::/64 eq 9043 (hitcnt=67) 
ipv6 access-list IPv6-tACL-Policy line 8 deny tcp any 
     2001:db8:1:60::/64 eq 9443 (hitcnt=80) 
ipv6 access-list IPv6-tACL-Policy line 9 deny ip any any (hitcnt=27)

In the preceding example, access list IPv6-tACL-Policy has dropped the following packets received from an untrusted host or network:

  • 3 packets on TCP port 9004 for ACE line 5
  • 49 SIP packets on TCP port 5060 for ACE line 6
  • 67 packets on TCP port 9043 for ACE line 7
  • 80 packets on TCP port 9443 for ACE line 8

In addition, syslog message 106023 can provide valuable information, which includes the source and destination IP address, the source and destination port numbers, and the IP protocol for the denied packet.

Identification: Firewall Access List Syslog Messages

Firewall syslog message 106023 will be generated for packets denied by an access control entry (ACE) that does not have the log keyword present. Additional information about this syslog message is in Cisco ASA 5500 Series System Log Message, 8.2 - 106023.

Information about configuring syslog for the Cisco ASA 5500 Series Adaptive Security Appliance is in Monitoring - Configuring Logging. Information about configuring syslog on the Cisco Catalyst 6500 Series ASA Services Module is in Configuring Logging. Information about configuring syslog on the FWSM for Cisco Catalyst 6500 Series Switches and Cisco 7600 Series Routers is in Monitoring the Firewall Services Module.

In the following example, the show logging | grep regex command extracts syslog messages from the logging buffer on the firewall. These messages provide additional information about denied packets that could indicate potential attempts to exploit the vulnerabilities that are described in this document. It is possible to use different regular expressions with the grep keyword to search for specific data in the logged messages.

Additional information about regular expression syntax is in Creating a Regular Expression.

firewall#show logging | grep 106023
  Feb 27 2013 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.99/3342 
         dst inside:192.168.60.240/9043 by access-group "tACL-Policy"
  Feb 27 2013 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.100/3343 
         dst inside:192.168.60.115/9443 by access-group "tACL-Policy"
  Feb 27 2013 00:15:13: %ASA-4-106023: Deny tcp src outside:192.0.2.88/3344 
         dst inside:192.168.60.38/5060 by access-group "tACL-Policy"
  Feb 27 2013 00:15:13: %ASA-4-106023: Deny tcp src outside:2001:db8:d::a85e:172/5343
         dst inside:2001:db8:1:60::134/9004 by access-group "IPv6-tACL-Policy"
firewall#

Additional information about syslog messages for Cisco ASA Series Adaptive Security Appliances is in Cisco ASA 5500 Series System Log Messages, 8.2. Additional information about syslog messages for Cisco Catalyst 6500 Series ASA Services Module is in the Analyzing Syslog Messages section of the Cisco ASASM CLI Configuration Guide. Additional information about syslog messages for the Cisco FWSM is in Catalyst 6500 Series Switch and Cisco 7600 Series Router Firewall Services Module Logging System Log Messages.

For additional information about investigating incidents using syslog events, reference the Identifying Incidents Using Firewall and IOS Router Syslog Events Cisco Security Intelligence Operations white paper.

Mitigation: TCP Normalization

The TCP normalization feature identifies abnormal packets that the security appliance can act on when they are detected; for example, the security appliance can allow, drop, or clear the packets. The TCP normalizer includes nonconfigurable actions and configurable actions. Typically, nonconfigurable actions that drop or clear connections apply to packets that are considered malicious. TCP normalization is available beginning in software release 7.0(1) for the Cisco ASA 5500 Series Adaptive Security Appliance, software release 8.5 for the Cisco Catalyst 6500 Series ASA Services Module, and in software release 3.1(1) for the Cisco Firewall Services Module.

TCP normalization is enabled by default and drops packets that may exploit these vulnerabilities. Protection against packets that may exploit these vulnerabilities is a non-configurable TCP normalization action; no configuration changes are required to enable this functionality.

The TCP normalization feature can be used to limit the concurrent connection limit and idle timeout for TCP connections to the Cisco Unified Presence Server, thus preventing the DoS condition. The limits should be configured according to the maximum normal number of connections observed toward the Cisco Unified Presence Server. The reader should note that configuring the TCP normalizer to prevent an abnormal number of connections to the Cisco Unified Presence Server will not prevent a persistent attacker from exhausting the allowed number of connections but it will prevent the Cisco Unified Presence Server from running out of memory due to many idle connections.

Note: Care should be taken with the limits set in each environment as they could deny legitimate connections if they are not set to adhere to the legitimate maximum limits for the specific environment.

In the following example, 192.168.60.200/24 is the IP address of the affected device. The configuration limits the TCP concurrent connections to the device to 1000 and sets the connection idle timeout to 30 minutes. Care should be taken with the limits set in each environments as they could deny legitimate connections if they are not set to adhere to the normal maximum limits for the specific environment.

!
!--  Match TCP traffic to the Cisco Unified Presence Server
!
access-list CVE-2013-1137-acl extended permit tcp any host 192.168.60.200
class-map CVE-2013-1137-cm
 match access-list CVE-2013-1137-acl
!
!--  Configure the connection limits for TCP traffic
!--  to the Cisco Unified Presence Server
!
policy-map global_policy
 class CVE-2013-1137-cm
  set connection conn-max 1000
  set connection timeout idle 0:30:00
service-policy global_policy global

Additional information about TCP normalization is in the Configuring TCP Normalization section of the Cisco ASA 5500 Series Configuration Guide using the CLI, 8.2 and the Configuring TCP Normalization section of the Cisco Catalyst 6500 Series ASA Services Module CLI Configuration Guide, 8.5.

Identification: TCP Normalization

For the Cisco ASA 5500 Series Adaptive Security Appliance the show service-policy command can identify the number of packets that the TCP normalization feature has dropped, as shown in the following example:

firewall# show service-policy set connection detail

Global policy:
  Service-policy: global_policy
    Class-map: CVE-2013-1137-cm
      Set connection policy: conn-max 10000
        current conns 15, drop 5
      Set connection timeout policy:
        idle 0:30:00
        DCD: disabled, retry-interval 0:00:15, max-retries 5
        DCD: client-probe 0, server-probe 0, conn-expiration 0            11
firewall#

For additional information about debugging accelerated security path dropped packets or connections, reference the Cisco Security Appliance Command Reference for show asp drop.

Cisco ACE

Mitigation: TCP Normalization

TCP normalization is a Layer 4 feature that consists of a series of checks that the Cisco ACE performs at various stages of a flow, beginning with the initial connection setup through the closing of a connection. Many of the segment checks can be controlled or altered by configuring one or more advanced TCP connection settings. The Cisco ACE uses these TCP connection settings to decide which checks to perform and whether to discard a TCP segment based on the results of the checks. The Cisco ACE discards segments that appear to be abnormal or malformed.

TCP normalization is enabled by default and drops packets that may exploit these vulnerabilities. Protection against packets that may exploit these vulnerabilities is a nonconfigurable TCP normalization action; no configuration changes are required to enable this functionality.

The TCP normalization feature can be used to limit the concurrent connection limit, connection rate and idle timeout for TCP connections to the Cisco Unified Communications Manager, thus preventing the DoS condition. The limits should be configured according to the maximum normal number and rate of connections observed toward the Cisco Unified Communications Manager. The reader should note that configuring the TCP normalizer to prevent an abnormal number of connections to the Cisco Unified Presence Server will not prevent a persistent attacker from exhausting the allowed number of connections but it will prevent the Cisco Unified Presence Server from running out of memory due to many idle connections.

Note: Care should be taken with the limits set in each environment as they could deny legitimate connections if they are not set to adhere to the legitimate maximum limits for the specific environment.

In the following example, 192.168.60.200/24 is the IP address of the affected device. The configuration limits the TCP concurrent connections to the device to 1000, the connection rate to 100000 connections per second and sets the connection idle timeout to 30 minutes.

!
!--  Create a connection parameter map to group together TCP/IP
!--  normalization and termination parameters
!
parameter-map type connection CVE-2013-1137-parameter-map
 limit-resource conc-connections 1000
 set timeout inactivity 1800
 rate-limit connection 100000
!
!--  Match TCP traffic to the Cisco Unified Presence Server
!
class-map match-any CVE-2013-1137-cm
 match destination-address 192.168.60.200
!
!--  Configure the connection limits for TCP
!--  traffic to the Cisco Unified Presence Server
!
policy-map multi-match CVE-2013-1137-policy
 class CVE-2013-1137-cm
  connection advanced-options CVE-2013-1137-parameter-map
!
!-- Apply the policy to the interface
!
interface vlan 50
 service-policy input CVE-2013-1137-policy

Additional information about TCP normalization is in the Configuring TCP/IP Normalization and IP Reassembly Parameters section of the Cisco ACE 4700 Series Appliance Security Configuration Guide.

Identification: TCP Normalization

The Cisco ACE Application Control Engine Appliance and Module does not provide show command output for packets that are dropped while attempting to exploit these vulnerabilities.

Cisco Intrusion Prevention System

Mitigation: Cisco IPS Signature Table

Administrators can use the Cisco IPS appliances and services modules to provide threat detection and help prevent attempts to exploit several of the vulnerabilities described in this document. The following table provides an overview of CVE identifiers and the respective Cisco IPS signatures that will trigger events on potential attempts to exploit these vulnerabilities.

CVE ID Signature Release Signature ID Signature Name Enabled Severity Fidelity*
CVE-2013-1137 S593 6009/0 SYN Flood DOS No Medium 85
CVE-2013-1137 S573 6920/0 Net Flood TCP No Info 100

* Fidelity is also referred to as Signature Fidelity Rating (SFR) and is the relative measure of the accuracy of the signature (predefined). The value ranges from 0 through 100 and is set by Cisco Systems, Inc.

Administrators can configure Cisco IPS sensors to perform an event action when an attack is detected. The configured event action performs preventive or deterrent controls to help protect against an attack that is attempting to exploit the vulnerabilities listed in the preceding table.

Cisco IPS sensors are most effective when deployed in inline protection mode combined with the use of an event action. Automatic Threat Prevention for Cisco IPS 7.x and 6.x sensors that are deployed in inline protection mode provides threat prevention against an attack that is attempting to exploit the vulnerability that is described in this document. Threat prevention is achieved through a default override that performs an event action for triggered signatures with a riskRatingValue greater than 90.

For additional information about the risk rating and threat rating calculation, reference Risk Rating and Threat Rating: Simplify IPS Policy Management.

Cisco Security Manager

Identification: Cisco Security Manager

Cisco Security Manager, Event Viewer

Beginning in software version 4.0, Cisco Security Manager can collect syslogs from Cisco firewalls and Cisco IPS devices and provides the Event Viewer, which can query for events that are related to the vulnerabilities that are described in this document.

Using the IPS Alert Events predefined view in the Event Viewer, the user can enter the search strings 6009/0, and 6920/0 in the event filter to return all captured events related to Cisco IPS signatures 6009/0, and 6920/0.

Using the following filters in the Firewall Denied Events predefined view in the Event Viewer provides all captured Cisco firewall access list deny syslog messages that could indicate potential attempts to exploit the vulnerabilities that are described in this document.

  • Use the Destination event filter to filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Use the Destination Service event filter to filter objects that contain TCP ports 9004, 5060, 9043, and 9443

An Event Type ID filter can be used with the Firewall Denied Events predefined view in the Event Viewer to filter the syslog IDs shown in the following list to provide all captured Cisco firewall deny syslog messages that could indicate potential attempts to exploit the vulnerabilities that are described in this document:

  • ASA-4-106023 (ACL deny)

For more information about Cisco Security Manager Events, refer to the Filtering and Querying Events section of the Cisco Security Manager User Guide.

Cisco Security Manager Report Manager

Beginning in software version 4.1, Cisco Security Manager supports the Report Manager, the Cisco IPS event reporting feature. This feature allows an administrator to define reports based on Cisco IPS events of interest. Reports can be scheduled or users can run ad hoc reports as required.

Using the Report Manager, the user can define an IPS Top Signatures report for Cisco IPS devices of interest based on time-range and signature characteristics. When the Signature ID is set to

  • 6009/0
  • 6920/0
Cisco Security Manager will generate a comprehensive report that ranks the count of the alerts fired for the signature of interest compared to the total sum of all signature alerts shown in the report.

Also in the Report Manager, the Top Services report can be used with the following configuration to generate a report of events that indicate potential attempts to exploit the vulnerabilities that are described in this document:

  • Use the Destination IP network filter to filter network objects that contain the IP address space that is used by the affected devices (for example, IPv4 address range 192.168.60.0/24 and IPv6 address range 2001:DB8:1:60::/64)
  • Set an action of Deny on the Criteria settings page

For more information about Cisco Security Manager IPS Event Reporting refer to the Understanding IPS Top Reports section of the Cisco Security Manager User Guide.

Identification: Event Management System Partner Events

Cisco works with industry-leading Security Information and Event Management (SIEM) companies through the Cisco Developer Network. This partnership helps Cisco deliver validated and tested SIEM systems that address business concerns such as long-term log archiving and forensics, heterogeneous event correlation, and advanced compliance reporting. Security Information and Event Management partner products can be leveraged to collect events from Cisco devices and then query the collected events for the incidents created by a Cisco IPS signature or deny syslog messages from firewalls that could indicate potential attempts to exploit the vulnerabilities that are described in this document. The queries can be made by Sig ID and Syslog ID as shown in the following list:

  • 6009/0 SYN Flood DOS
  • 6920/0 Net Flood TCP
  • ASA-4-106023 (ACL deny)

For more information about SIEM partners, refer to the Security Management System website.

Additional Information

THIS DOCUMENT IS PROVIDED ON AN "AS IS" BASIS AND DOES NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE INFORMATION ON THE DOCUMENT OR MATERIALS LINKED FROM THE DOCUMENT IS AT YOUR OWN RISK. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE THIS DOCUMENT AT ANY TIME.

Cisco Security Procedures

Complete information on reporting security vulnerabilities in Cisco products, obtaining assistance with security incidents, and registering to receive security information from Cisco, is available on Cisco's worldwide website at http://www.cisco.com/web/about/security/psirt/security_vulnerability_policy.html. This includes instructions for press inquiries regarding Cisco security notices. All Cisco security advisories are available at http://www.cisco.com/go/psirt.

Related Information

 
Alert History
 

Alert History

Initial Release


Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
CiscoCisco Unified Communications Manager 8.6 Base | 9.0 Base | 9.0(1) Base | 9.1 Base | 9.1(1) Base
CiscoCisco Unified Presence Server 8.6 .4
CiscoCisco Hosted Collaboration Solution 8.6(x) Base | 8.6(2) Base | 9.0(x) Base | 9.0(1) Base
CiscoCisco Unified Communications Manager IM and Presence Service 9.0 (1) | 9.1 (1)

Associated Products:
N/A




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield