Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Vulnerability Alert

OpenSSL TLS and AES-NI Denial of Service Vulnerability

 
Threat Type:CWE-310: Cryptographic Issues
IntelliShield ID:28098
Version:5
First Published:2013 February 06 17:23 GMT
Last Published:2013 September 16 13:06 GMT
Port: Not available
CVE:CVE-2012-2686
BugTraq ID:57755
Urgency:Possible use
Credibility:Confirmed
Severity:Mild Damage
CVSS Base:5.4 CVSS Calculator
CVSS Version 2.0
CVSS Temporal:4.5
 
Version Summary:Apple has released a security advisory and updated software to address the OpenSSL TLS and AES-NI denial of service vulnerability.
 
 
Description
OpenSSL contains a vulnerability that could an unauthenticated, remote attacker to cause a denial of service (DoS) condition.

The vulnerability is due to improper handling of Cipher Block Chaining (CBC) cipher suites in the Transport Layer Security (TLS) 1.1 and TLS 1.2 versions used in the affected software. An unauthenticated, remote attacker could exploit the vulnerability by using an unspecified vector to cause a DoS condition on the targeted system.

Functional code that exploits this vulnerability is publicly available as part of the Metasploit framework.

OpenSSL has confirmed the vulnerability and released software updates.
 
Warning Indicators
OpenSSL version 1.0.1c is vulnerable.
 
IntelliShield Analysis
The vulnerability is exploitable through the AES-NI platform for TLS 1.2 or TLS 1.1 implemented on OpenSSL version 1.0.1c. OpenSSL platforms that do not support AES-NI or versions of OpenSSL that do not implement TLS 1.2 or 1.1, such as OpenSSL 0.9.8 and 1.0.0, are not affected.
 
Vendor Announcements
OpenSSL has released a security advisory at the following link: secadv_20130204

Apple has released a security advisory at the following link: HT5880

FreeBSD has released a VuXML document at the following link: OpenSSL -- TLS 1.1, 1.2 denial of service
 
Impact
An unauthenticated, remote attacker could exploit the vulnerability to cause the affected software to stop responding. This could result in a DoS condition for the legitimate applications that use the affected software for secure transmission services.
 
Technical Information
The vulnerability is due to improper implementation of the Advanced Encryption Standard New Instructions (AES-NI) standard in the affected software.

An unauthenticated, remote attacker could exploit the vulnerability by an unspecified vector to cause a DoS condition on the targeted system.
 
Safeguards
Administrators are advised to apply the appropriate updates.

Administrators may consider using an alternate product.

Administrators are advised to monitor critical systems.

Administrators may consider using IP-based access control lists (ACLs) to allow only trusted systems to access the affected systems.
 
Patches/Software
OpenSSL has released updated versions at the following link: OpenSSL 1.0.1d

Apple has released updated software at the following links:

Mac OS X and Mac OS X Server 10.6.8
Security Update 2013-004 (Snow Leopard)
Security Update 2013-004 Server (Snow Leopard)

Mac OS X and Mac OS X Server 10.7.5
Security Update 2013-004 (Lion)
Security Update 2013-004 Server (Lion)

Mac OS X Mountain Lion 10.8.5
OS X Mountain Lion Update 10.8.5
OS X Mountain Lion Update 10.8.5 (Combo)

FreeBSD has released ports collection updates at the following link: Ports Collection Index
 
Alert History
 

Version 4, March 25, 2013, 3:14 PM: Functional code that demonstrates an exploit of the OpenSSL TLS and AES-NI denial of service vulnerability is publicly available.

Version 3 March 22, 2013, 11:51 AM: Functional code that demonstrates an exploit of the OpenSSL TLS and AES-NI denial of service vulnerability is publicly available.

Version 2, February 7, 2013, 6:41 AM: FreeBSD has released a VuXML document and updated ports collection to address the OpenSSL TLS and AES-NI denial of service vulnerability.

Version 1, February 6, 2013, 8:23 AM: OpenSSL contains a vulnerability that could an unauthenticated, remote attacker to cause a denial of service condition. Updates are available.



Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
OpenSSLopenssl 1.0.1c Base

Associated Products:
AppleMac OS X 10.6.8 Base | 10.7.5 Base | 10.8 Base | 10.8.1 Base | 10.8.2 Base | 10.8.3 Base | 10.8.4 Base
AppleMac OS X Server 10.6.8 Base | 10.7.5 Base
FreeBSD ProjectFreeBSD 6.3 Base | 6.4 Base | 7.0 Base | 7.1 Base | 7.2 Base | 7.3 Base | 7.4 Base | 8.0 Base | 8.1 Base | 8.2 Base | 8.3 Base | 9.0 Base | 9.1 Base




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield