Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Security Activity Bulletin

Parallels Plesk Remote PHP Command Execution Vulnerability

 
Threat Type:IntelliShield: Security Activity Bulletin
IntelliShield ID:29594
Version:2
First Published:2013 June 05 19:43 GMT
Last Published:2013 June 12 18:58 GMT
Port: Not available
Urgency:Possible use
Credibility:Confirmed
Severity:Mild Damage
 
Version Summary:Parallels has released additional information to address the Parallels Plesk remote PHP command execution vulnerability.
 

Description
 
A vulnerability in Parallels Plesk could allow an unauthenticated, remote attacker to execute arbitrary PHP script on a targeted system with the privileges of the web service.

The vulnerability is due to an unsafe configuration of PHP in the affected application. An unauthenticated, remote attacker could exploit the vulnerability by sending malicious HTTP responses to the targeted system containing malicious Content-Length fields. The processing of the Content-Length fields by the application could trigger the execution of supplied PHP code within the security context of the web service.

Proof-of-concept code is publicly available.

Parallels has confirmed the vulnerability is a variation of the CVE-2012-1823 vulnerability which is documented in IntelliShield Alert 25816 at the following link: Response from Parallels #43928803

Parallels has also confirmed that all current supported versions of Parallels Plesk Panel 9.5 or later are not vulnerable from this variation.

Customers are advised to upgrade to the latest version of Parallels Plesk Panel.


Administrators may consider using IP-based access control lists (ACLs) to allow only trusted systems to access the affected systems.

Signatures
 
Cisco Intrusion Prevention System (IPS) 6.0
Signature IDSignature NameReleaseLatest Release Date
2271/0PHP Remote Code ExecutionS7222013 Jun 06 
 
Alert History
 

Version 1, June 5, 2013, 7:43 PM: Parallels Plesk contains a vulnerability that could allow an unauthenticated, remote attacker to execute arbitrary PHP script on a targeted system. Updates are not available.



Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
Parallels, Inc.Plesk 8.6 Base | 9.0 Base | 9.2 Base | 9.3 Base

Associated Products:
N/A




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield