Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Vulnerability Alert

McAfee ePolicy Orchestrator Cross-Site Scripting Vulnerability

 
Threat Type:CWE-79: Cross-Site Scripting (XSS)
IntelliShield ID:30063
Version:1
First Published:2013 July 15 12:18 GMT
Last Published:2013 July 15 12:18 GMT
Port: Not available
Urgency:Possible use
Credibility:Highly Credible
Severity:Mild Damage
CVSS Base:6.5 CVSS Calculator
CVSS Version 2.0
CVSS Temporal:5.6
 
 
Version Summary:McAfee ePolicy Orchestrator contains a vulnerability that could allow an authenticated, remote attacker to execute arbitrary SQL code or conduct cross-site scripting attacks. Updates are not available.
 
 
Description
Multiple vulnerabilities in McAfee ePolicy Orchestrator could allow an authenticated, remote attacker to execute arbitrary SQL code and conduct a cross-site scripting attacks on the affected application.

The vulnerabilities are due to insufficient sanitization performed on user-supplied input by the affected software. An attacker could exploit this vulnerabilities by persuading a user to visit a malicious URL that is designed to submit crafted input to the affected software. A successful exploit could allow the attacker to add rogue systems to an enterprise ePO server, steal domain credentials, obtain sensitive information associated with the user's current session, upload files, and execute commands on the ePO server.

Proof-of-concept code is publicly available.

McAfee has not confirmed this vulnerability and updated software is not available.
 
Warning Indicators
McAfee ePolicy Orchestrator versions 4.6.6 and prior are vulnerable.
 
IntelliShield Analysis
Attackers must authenticate to the ePO application before conducting an exploit. This authentication requirement limits the likelihood of a successful exploit.
 
Vendor Announcements
Vendor announcements are not available.
 
Impact
These vulnerabilities could be exploited to allow an attacker to execute arbitrary code on the system with elevated privileges. Due to the enterprise nature of this product, this may allow the attacker to compromise multiple systems within the environment.
 
Technical Information
The SQL injection vulnerability is due to improper validation of user-supplied input by the registeredTypeID parameter, which statically registers new users of the showRegisteredTypeDetails.do script in the affected application. An authenticated, remote attacker could exploit this vulnerability by sending malicious requests to the vulnerable script. Processing the malicious requests could cause the application to execute attacker-provided SQL commands in the underlying database. Successful exploitation could allow an attacker to add rogue systems to an enterprise ePO server and execute commands on the ePO server as well as on any systems managed by ePO.

The reflected cross-site scripting vulnerability is due to improper validation of user-supplied input by the uid parameter of the sysDetPanelBoolPie.do, sysDetPanelQry.do, and sysDetPanelSummary.do scripts and in the propKey parameter of the affected application. Successful exploitation could allow an attacker to obtain sensitive information and gain unauthorized access to the application.
 
Safeguards
Administrators are advised to contact the vendor regarding future updates and releases.

Administrators are advised to allow only privileged users to access administration or management systems.

Administrators may consider using IP-based access control lists (ACLs) to allow only trusted systems to access the affected systems.

Administrators are advised to monitor affected systems.
 
Patches/Software
Patches and software updates are not available.
 
Alert History
 
Initial Release


Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
McAfeeePolicy Orchestrator 4.6 Base, .1, .2, .3, .4, .5, .6

Associated Products:
N/A




Alerts and bulletins on the Cisco Security Intelligence Operations Portal are highlighted by analysts in the Cisco Threat Operations Center and represent a subset of the comprehensive content that is available through Cisco Security IntelliShield Alert Manager Service. This customizable threat and vulnerability alert service provides security staff with access to timely, accurate, and credible information about threats and vulnerabilities that may affect their environment.


LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield