Products & Services
Support

Product Categories


Popular Downloads


Manage Software

How to Buy

For Home

Linksys Products Store
Linksys is now part of Belkin
Products for everyone

All Ordering Options

Training & Events Partners
Guest

Vulnerability Alert

Cisco Unified Computing System Arbitrary Command Execution Vulnerability

 
Threat Type:CWE-78: OS Command Injections
IntelliShield ID:31002
Version:1
First Published:2013 September 26 20:28 GMT
Last Published:2013 September 26 20:28 GMT
Port: Not available
CVE:CVE-2012-1313
Urgency:Unlikely Use
Credibility:Confirmed
Severity:Mild Damage
CVSS Base:6.5 CVSS Calculator
CVSS Version 2.0
CVSS Temporal:5.4
 
 
Version Summary:Cisco Unified Computing System contains a vulnerability that could allow an authenticated, local attacker to execute commands on the underlying operating system with elevated privileges. Updates are available.
 
 
Description
A vulnerability in the remote debug shell in Cisco Unified Computing System PALO adapter cards could allow an authenticated, local attacker to execute commands on the underlying operating system with elevated privileges.

The vulnerability is due to insufficient handling of special characters. An attacker could exploit this vulnerability by sending malformed parameters to the show-macstats command. A successful exploit could grant the attacker root access to the underlying operating system.

Cisco has confirmed the vulnerability in a security notice and released software updates.
 
Warning Indicators
At the time this alert was first published, Cisco Unified Computing System versions 2.1 and prior were vulnerable. Later releases of Cisco Unified Computing System may also be vulnerable.
 
IntelliShield Analysis
To exploit this vulnerability, an attacker must be able to authenticate and have local access to a targeted device. These access requirements decrease the likelihood of a successful exploit.

Cisco indicates through the CVSS score that functional exploit code exists; however, the code is not known to be publicly available.
 
Vendor Announcements
Cisco has released a security notice at the following link: CVE-2012-1313

Customers are advised to consult Cisco bug ID CSCub13772 for a complete list of affected product versions.
 
Impact
An authenticated, local attacker could exploit this vulnerability to execute arbitrary commands on the underlying operating system of a targeted device with elevated privileges. A successful exploit could result in a complete system compromise.
 
Technical Information
The vulnerability is due to insufficient handling of special characters by the remote debug shell in Cisco Unified Computing System PALO adapter cards.

An authenticated, local attacker could exploit this vulnerability by sending malformed parameters to the show-macstats command. A successful exploit could grant the attacker root access to the underlying operating system, which could result in a complete system compromise.
 
Safeguards
Administrators are advised to apply the appropriate updates.

Administrators are advised to allow only trusted users to access local systems.

Administrators are advised to allow only privileged users to access administration or management systems.

Administrators are advised to monitor affected systems.
 
Patches/Software
Cisco customers with active contracts should contact their Cisco support team for assistance in upgrading to a software version that includes fixes for this vulnerability. Cisco customers without contracts may contact the Cisco Technical Assistance Center at 1-800-553-2447 or 1-408-526-7209 or via email at tac@cisco.com for assistance.
 
Alert History
 
Initial Release


Product Sets
 
The security vulnerability applies to the following combinations of products.

Primary Products:
CiscoCisco Unified Computing System (Managed) 1.0 Base, (2k) | 1.1 Base, (1m) | 1.2 Base, (1d) | 1.3 Base, (1c), (1m), (1n), (1o), (1p), (1q), (1t), (1w), (1y) | 1.4 Base, (1i), (1j), (1m), (3i), (3l), (3m), (3q), (3s), (3u), (3y), (4f), (4g), (4i), (4j), (4k) | 2.0 Base, (1m), (1q), (1s), (1t), (1w), (1x), (2m), (2q), (2r), (3a), (3b), (3c) | 2.1 Base

Associated Products:
N/A



LEGAL DISCLAIMER
The urgency and severity ratings of this alert are not tailored to individual users; users may value alerts differently based upon their network configurations and circumstances. THE ALERT, AND INFORMATION CONTAINED THEREIN, ARE PROVIDED ON AN "AS IS" BASIS AND DO NOT IMPLY ANY KIND OF GUARANTEE OR WARRANTY, INCLUDING THE WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR USE. YOUR USE OF THE ALERT, AND INFORMATION CONTAINED THEREIN, OR MATERIALS LINKED FROM THE ALERT, IS AT YOUR OWN RISK. INFORMATION IN THIS ALERT AND ANY RELATED COMMUNICATIONS IS BASED ON OUR KNOWLEDGE AT THE TIME OF PUBLICATION AND IS SUBJECT TO CHANGE WITHOUT NOTICE. CISCO RESERVES THE RIGHT TO CHANGE OR UPDATE ALERTS AT ANY TIME.
Powered by  IntelliShield